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Welcome to TextMaker, the friendly full-featured word processor for Windows 95 to XP, Hand-
held PCs, Pocket PCs, and Linux. TextMaker includes many easy-to-learn features for creating
professional-looking documents, but please take a moment to review this introduction before
jumping in.

Please note

TextMaker is available for Windows, Handheld PCs, Pocket PCs, and Linux. The screenshots in
this manual are taken from the Windows version, so if you are running TextMaker on another op-
erating system, the screenshots might slightly differ from the actual layout on your computer. Al-
so, some features of TextMaker are not available on all platforms.

LEARNING TEXTMAKER

To use TextMaker to its potential, you first need some basic skills in running graphical operating
systems like Windows. If you don’t know how to use the mouse, choose commands, open files, or
work with windows, for example, we suggest you spend some time with the documentation that
came with Windows before attempting to use TextMaker.

If you're a newcomer to word processing...

If you're new to word processing, you should read Chapter 2, Tips & Techniques. This chapter
starts with the basics and builds on them, covering many topics central to modern word process-
ing. It shows you how to edit and format text, manage your documents, and make use of the rich
set of tools in TextMaker. You'll soon find yourself creating documents that may have previously
seemed beyond your reach.

But don't forget, the best way to learn TextMaker is to use it, so don’t be intimidated to try
new features and commands or experiment with new ideas.

If you're an experienced user...

If you're comfortable with the concepts of word processing and are anxious to begin, go ahead
and start up TextMaker. You can browse through the menus to get a quick glimpse of its capabil-
ities.

If you're switching from another word processor, you'll be especially pleased: you probably
have a number of documents created with your previous word processor that you'd like to access.
To make the transition an easy one, TextMaker comes with file translators for Microsoft Word,
Rich Text Format (RTF), HTML, and other formats.

All users...

Chapter 3 through chapter 10 cover the commands in TextMaker as they are presented on the me-
nus. These chapters provide detailed information about all commands and options in TextMaker,
and also contain several tips and pointers to help you expand your expertise.
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CONTACTING TECHNICAL SUPPORT

If you find that TextMaker is not operating correctly, you can contact us for technical support. Be-
fore doing so, however, please first check this User Guide. Many times you will find the answer
there, saving yourself time and the cost of a long-distance telephone call.

If you are having a problem that you think is caused by TextMaker, we would appreciate hav-
ing the document file sent along with a description of the problem. This makes e-mail the best op-
tion for technical support.

If you need to contact us for technical support, you have the following options:

World Wide Web: www.softmaker.de

Our web site is kept current with answers to frequently asked questions, program updates, and
fresh ideas for using TextMaker. Visit us on the web at www.softmaker.de

E-mail

You can send support-related e-mail to support@softmaker.de

Fax or snail mail

You can mail or fax questions to us at:

SoftMaker Software GmbH
Kronacher Str 7

D-90427 Nuernberg
GERMANY

Fax: +49-911-303796

Telephone

You can also phone us. Before calling, please have your customer number ready, and a complete
description of your problem written down. The number of our technical support department is:

Phone +49-911-936 386 50

TextMaker 2002 — User Manual 3



s | TIPS & Techniques

Welcome to the TextMaker manual. In this chapter you are introduced to techniques and concepts
that will give you a deeper understanding of TextMaker and the ways you might want to use it. If
you want a more detailed explanation of a command or dialog box option, go to the reference
chapters of this manual.

OVERVIEW OF TEXTMAKER

The purpose of this section is to provide you with a basic understanding of TextMaker’s features
and operation. If you are at all familiar with word processors—especially Windows word process-
ors—you probably already know most of what you need to know to effectively use TextMaker.

TextMaker is designed for creating documents such as letters, memos, fax cover pages, reports,
newsletters, and brochures. It contains commands and features for creating both simple and so-
phisticated documents. You have complete formatting control over characters (font, size, style),
paragraphs (indentation, tabs, line height), and whole documents (margins, page size).

In addition to powerful text manipulation and formatting capabilities, TextMaker lets you cre-
ate and edit different types of graphic objects.

Documents you create with TextMaker can include headers and footers, multiple columns, and
calculated fields such as date, time, and page numbers. You can draw simple objects such as lines,
rectangles, and ellipses. You can also create specialized objects such as text frames, table frames,
and picture frames into which you can import graphic files in many different formats (BMP, TIFF,
JPEG, GIF, etc.)

TextMaker has two basic modes: text and object. Text mode is the default mode. This is where
you enter, edit, and format text. Object mode is where you draw objects and frames, and create grid
lines. You switch between the two modes by clicking the Text/Object mode button on the Format
strip. If the button is not pressed, TextMaker is in Text mode; when the button is depressed, Text-
Maker is in Object mode. Clicking the right mouse button displays a pop-up menu allowing you to
switch between modes also.

A spell checker and thesaurus let you check for spelling mistakes, correct them, and search for
synonyms (words with similar meanings). You can add your own words to a customized user dic-
tionary. This is useful for words such as personal names and acronyms.

You can also print merge your documents with data from Comma Delimited (CSV) or dBASE
(DBF) files. Print merging is useful if, for example, you want to print the same document several
times, but change address information for each document. If you have a data file containing
names and addresses, TextMaker will substitute the fields you specify from it each times it prints a
copy of the document.
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THE TEXTMAKER WINDOW
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O Format strip

(3] Paragraph style menu
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O status strip

@ Text/ Object mode button

You can control the display of certain TextMaker items. For example, you can turn the display of
the rulers ®, Toolbar @, Format strip @, and Status strip ® off, giving you more room on screen
for your document contents. You determine display options by choosing commands from the
View menu.

The Format strip

The Format strip changes depending on which mode is active. In Text mode, the Format strip con-
tains buttons for formatting text, changing alignment options, and creating tabs, as well as menus
for selecting font, font size, and paragraph styles (a paragraph style is a collection of formatting
commands that can be applied all at once).

In Object mode the Format strip changes to the Object strip containing buttons for drawing
text frames, picture frames, tables, OLE objects, and drawing tools for creating simple shapes:
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THE BASICS

If you are familiar with word processing, or are an experienced Windows user, you may skip this
section. TextMaker uses industry standard approaches to common operations, so that you don’t
have to learn new commands and concepts.

The following basics are of value to users new to computers or word processing, as well as to
anyone who wants to fully understand the workings of TextMaker.

In this section you will learn:

» The basics of text editing

» How text is organized in a document

» How to select text with keyboard and mouse

» How to print your document

Simple text editing

Each time you start TextMaker, a new document is created. Unless you have changed the default
document template, this is an empty document, ready for you to create a letter, memo, report, or
any other type of document.

To start editing, just start typing. Don’t be afraid of making mistakes. Even the most experi-
enced users make them. One of the benefits of modern word processing is the ease with which
you can fix them. So take charge and get going.

Whenever you type a letter on the keyboard, a character is inserted into your document at the
current text cursor. The text cursor is indicated on the screen by a thin blinking vertical line, the
caret. This is also called the text insert position.

Besides becoming familiar with the location of all the characters on the keyboard, here are
some special keys you should also become familiar with:

Del Deletes the next character in the text
Backspace Deletes the previous character in the text
Right Arrow Moves the text cursor forward one character
Left Arrow Moves the text cursor back one character
Up Arrow Moves the text cursor to the previous line
Down Arrow Moves the text cursor to the next line
Text organization

When you enter text into your document, it is broken up into logical organizations. For the most
part, these follow natural rules of language. It is still useful to understand what they are, and how
TextMaker refers to them.

The following terms are used to describe simple text constructs in a TextMaker document:

Character A single letter, number, or punctuation mark typed from the keyboard.
Word Any collection of two or more characters.
Line A group of characters or words that share a common vertical position on a
page.
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Paragraph A grouping of text separated by carriage returns. Note that a paragraph
may take up any number of lines, due to the automatic wrapping of text at
the end of lines.

Simple text selection

There are many times when you will want to make changes to blocks of text with a single action.
For example, you might want to delete a word, or make a heading bold. To make these types of
changes, you must first select the text you want to change.

You will recognize a selected block of text immediately when you see it on the screen. Instead
of seeing the blinking caret, you will see a block of text displayed in reverse video. That is, the
characters will be drawn in white with a black background.

You can select text either with the keyboard or with the mouse. Either way, you are telling
TextMaker where the start of the selection begins and where it ends.

Selecting text with the keyboard

To select text with the keyboard, you use the Left, Right, Up, and Down arrow keys while holding
down the Shift key at the same time. If you want to select the next word, for example, press and
hold down the Shift key, and press the Right arrow key until the whole word appears selected.

Selecting text with the keyboard is not limited to the arrow keys. Any key that moves the caret
from one location to another, such as the Page Up and Page Down keys, can also be used to select
text. Just remember to hold down the Shift key at the same time.

To learn more about caret movement keys, refer to Appendix A.

Selecting text with the mouse

Selecting text with the mouse is often easier and faster, especially when you are selecting a lot of
text. Like everything with the mouse, it takes a little time to become coordinated with its use, but
once you do, you'll find it is worth the effort.

To select text with the mouse, click into the document at the position you want to begin the se-
lection. When you click, do not release the mouse button, but keep it pressed down.

Now with the left mouse button down, simply move the mouse to the end of the selection. You
can move it left, right, up or down. Characters, lines and paragraphs are selected accordingly. If
the end of the selection is not visible on the screen, simply move the mouse to the top or bottom
of the screen, and the document will automatically scroll.

There are two other handy methods for selecting text with the mouse. First, if you double click
anywhere in the text, it will select the whole word where you double clicked. Second, if you move
the mouse to the left of any line of text, the mouse will turn into an arrow. Clicking selects the en-
tire line. Double-clicking selects the whole paragraph. Dragging up or down selects lines above
and below.

Simple text formatting

Now that you know how to select text in a document, you can start to add formatting to enhance
its appearance and bring attention to points of interest in the text.

The Format strip, which sits just above the horizontal ruler at the top of the main window, pro-
vides access to the most commonly used text formatting commands. By using the Format strip,
you can immediately start enhancing the look of your document.
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To use the Format strip, first select some text as described in the previous section. Then, using
the mouse, click on the button with the bold face B. The B stands for Bold, and that is just what
will happen to the text when you press the button.

From left to right on the Format strip, use a similar technique to apply the following
commands:

Paragraph Style Select from a list of paragraph styles to apply to the selected paragraphs.
Learn more about paragraph styles in the Using Styles section.

Font Select from a list of available fonts. All fonts available within your operat-
ing system are shown in this list.
Point Size Select from a list of point sizes for the selected font. If the font is scalable,
the list is there for convenience only, but you can enter any value from 4
to 999.
Text Color Select from a list of defined colors for your document. The last entry al-

lows you to define your own colors.

Text Style The first group of buttons contains text style commands. From left to right,
they apply Bold, Italics, Underline, or any combination of the three.

Text Alignment The next group of buttons applies basic paragraph alignment. You can
have paragraphs aligned to the left or right paragraph indents, centered
between them, or justified.

Tabs The final group of buttons sets the pending type for tab stops set on the
ruler. For more information, see the section Using the Rulers.

These are just the basics, of course. Be sure to check out the Character and Paragraph dialog boxes
from the Format menu for loads more formatting options.

Printing a document

Note: Printing is not available on Pocket PCs

Once you've created a document, chances are you'll want to print it. To print a document, just call
up the Print command in the File menu, and the printing dialog will appear. Check to be sure that
the printer indicated at the top of the dialog box lists the correct printer. If not, simply open the
list and change the printer selection. Finally, press the OK button and a single copy of your entire
document will be sent to the printer.

The purpose of most of the options in the print dialog box is fairly obvious. Others are a little
more sophisticated. For more information, see the Printing Documents section.

From now on, we will abbreviate “call up the X command from the Y menu” as “Y > X”. For example, if you
see “File > Print”, this means “call up the Print command from the File menu”.

WORKING WITH TEXT

In this section you will learn:

4 How to use the clipboard
> How to cut, copy, and paste text
» How to move text within and between documents

Text can be entered in several ways, the most obvious is typing it from your keyboard. But you
can also insert the contents of other documents or text files into the current document using the
Insert > Document command, or copy and paste text from other TextMaker documents, or even
from other programs.
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Another way to enter text is by using Insert > Symbol. This feature gives you access to extended
characters, and provides a quick and easy way to enter them in your documents.

Cutting and pasting text

Use the Cut, Copy, and Paste commands to quickly rearrange text in your document, move se-
lected text to a different document, or even to different Windows programs.

The Copy and Cut commands copy—or duplicate—selected text and place it on the clipboard.
The clipboard is a temporary holding area; text you copy or cut remains on the clipboard until the
next time you choose Copy or Cut, or until you exit Windows.

The difference between Copy and Cut is that Copy leaves the selected text intact in your docu-
ment after putting it on the clipboard, whereas the Cut command deletes the selected text from
your document after putting it on the clipboard.

To copy or duplicate text to another place in your document

1. Select the text using the mouse or the Shift and arrow keys.
2. Choose Edit > Copy.

3. Use the mouse or arrow keys to move the caret to the point in your document where you
want to place the duplicate text.

4. Choose Edit > Paste. The text now appears in two places in your document.

The Copy command can be a great time-saver. Suppose that you are writing an article about
the Norman conquest, and you need to make several references to a certain Saint Wulfstan of Wor-
cester (an English archbishop). Rather than typing Saint Wulfstan of Worcester each time (or Wulfy)
select his name the first time you type it, choose Edit > Copy, then choose Edit > Paste for each ad-
ditional time you would otherwise have had to type Saint Wulfstan of Worcester.

Note also that each time his name appears, it is italicized. When you copy text, all formatting
information is copied as well.

Moving text with the Cut command

You can use the Cut command to move text. For instance, if you want to change the order of two
paragraphs, placing one paragraph before another, select all the text in the second paragraph,
choose Edit > Cut, move the caret to a position above the first paragraph, then choose Edit > Paste.

When you cut text, it maintains only a temporary existence on the clipboard. If you choose Cut or Copy
again before pasting it, the previously cut text is gone forever, as it is then replaced by the new text that was
cut or copied. If you exit or restart Windows, all information on the clipboard is destroyed.

Moving text between documents

If you find yourself about to retype some lengthy text from a previous document into your current
document, you should probably be using the Copy command to insert a duplicate of the text into
your new document instead. (If you want to use almost all of the old document in your new one, it
might be even easier to copy the entire document to a new file name. To learn how to do this, re-
fer to the section Saving a Document with a New file name.)

To copy text from one TextMaker document to another

1.  Select the text in the source document and choose Edit > Copy.
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2. Choose File > Open and select the destination document you want to paste the text into.

3. Move the caret to the position in the document you want the text to appear and choose
Edit > Paste.

For example, if you are writing a cover letter for a job application, and you want to include a
paragraph about your current job that you wrote in a previous letter, retyping it would be a waste
of time. Open the old letter, select the paragraph that you want to insert into the new letter, and
choose Edit > Copy. Then choose File > Open to open the new letter, move the caret to the point
at which you want to insert the paragraph, and choose Edit > Paste.

Since TextMaker lets you have many documents open at once, you could even display the
documents side-by-side using Window > Tile. In this fashion, moving text between documents is
barely different from moving text around within the same document.

Multiple document windows are not supported on Handheld PCs and Pocket PCs.

Because the text you copy remains on the clipboard until you cut or copy something else, you
can also paste TextMaker text into other programs.

MORE TEXT FORMATTING

In this section you will learn:

4 More about formatting text and paragraphs

» Aligning text with indents and tabs

» Creating lists with numbers and bullets

» Using the horizontal ruler

» Changing the default font in your documents

TextMaker lets you apply character and paragraph formatting commands in a couple of differ-
ent manners.

For example, if you wanted to make some selected text bold, you could click the Bold button
on the Format strip; you could choose Format > Character and click the Bold style option in the
Character dialog box; or finally, you could press a quick key combination, in this case Ctrl+B. It
makes no difference which method you choose, the result is the same.

The Format strip contains the most widely used formatting options; the Format menu’s dialog
boxes contain all formatting options. If you are changing a single formatting option, such as mak-
ing text bold, or centering a paragraph, the quickest way to do it is from the Format strip or by
pressing a quick key combination. But if you are changing several formatting options at once, such
as choosing a different font, increasing its size, and changing the style to bold and italics, it would
be faster to do it from the dialog box rather than from the Format strip.

You can format text before or after you have typed it. Choosing formatting options before you
type determines how text appears as soon as typing begins. Formatting options remain in effect
until you turn them off (such as the Bold command), or choose a different option that changes the
first option (such as changing alignment from left to justified—both can’t be active at once).

To format existing text, you must first select it. You select characters for formatting by high-
lighting them as described earlier; you select paragraphs simply by placing the caret anywhere
within the paragraph, or by highlighting them.

Formatting characters

Character formatting consists of variations you apply to text for emphasis. You can choose these
attributes in several combinations. For example, you can make text bold, italicized, and under-
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lined at the same time, or just bold, or just underlined, etc. Just like fonts and sizes, you can
change character attributes before or after you type something.

The Format strip contains buttons for three of the most common font attributes: bold, italics,
and underline. When you click one of the buttons to turn on an attribute, the button appears
pressed down. Text you type from that point will appear in the selected attribute. If text is se-
lected, changing the attributes applies only to the selected text. Click the button again to turn off
the attribute.

If you select some text that contains more than one font, the font menu on the Format strip is
blank, indicating an ambiguous selection. For example, if you selected some text formatted with
Times New Roman and Arial, the font menu would appear blank. You could still pull down the
menu and select a font, but the font you selected would be applied to the entire selection. The size
menu would also appear blank if the current text selection contained text of different sizes. Simi-
larly, the formatting buttons on the Format strip appear gray if some of the selected text is format-
ted and some is not. If you selected some text that contained both normal and bold attributes, the
Bold button would appear gray. This is called an ambiguous selection—a selection that contains
contradicting formats. If you press an attribute button that is gray (ambiguous) the attribute is ap-
plied to the entire selection; pressing it again turns it off for the entire selection. There is no way,
however, to return it to the ambiguous state (except by using Edit > Undo).

Formatting paragraphs

Paragraph formatting consists of variations that affect entire paragraphs: alignment, line spacing,
tab settings, hyphenation, etc., are examples of paragraph attributes. You can choose these attrib-
utes in several combinations. For example, you can change a paragraph’s line spacing, alignment,
and border or fill patterns at the same time, or just change its line spacing, or alignment, etc. Just
like character formatting, you can change paragraph attributes before or after you type a para-

graph.

Paragraph formatting attributes are applied to entire paragraphs rather than single characters
or words. This means that you don’t have to select any text in a paragraph in order to format it.
Paragraph attributes are applied to the paragraph where the caret is. In other words, to select a
paragraph to be formatted, simply position the caret anywhere within the paragraph. To format
more than one paragraph at a time, select all the paragraphs you want new formatting to be ap-
plied to.

Alignment, tabs, & indents

Aligning text on the page is a great way to draw attention to important topics in your document. It
is also useful when you want to line up numbers or topics that appear on successive lines of text.

In the past, especially with early computers and typewriters, spaces were commonly used to
align text. This was possible because most of the fonts in use at that time were monospaced
fonts—every character had exactly the same width, which made it easy to line things up.

Most fonts used today, however, are proportional fonts (e.g., Times New Roman and Arial).
Each character has a width based on what looks best. As a result, spaces wind up being a terrible
way to align text. This is very noticeable if you were to load a plain-text file formatted with spaces:
nothing lines up.

Fortunately, TextMaker has very easy-to-use yet powerful mechanisms for aligning paragraphs
of text, and none of them involve the use of spaces. Instead, text is aligned to absolute positions
on the page (measured in inches or centimeters).

We strongly urge you to get used to using the following alignment tools, and use the space only
for what it was intended: to separate words.
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Paragraph alignment

The most fundamental alignment tool is paragraph alignment. This determines whether the para-
graph is aligned to the left or right, centered, or fully justified. To set the paragraph alignment, use
the buttons on the Format strip or select Format > Paragraph to open the Paragraph dialog box
and choose the alignment from there.

Paragraph indents

Paragraph indents are used to offset a paragraph’s left or right boundaries from the page margins.
Quite often the page margins and paragraph indents are the same, but this needn’t be the case.
Probably the most common indent seen is when the first line of a paragraph is indented a slight
amount. You can also change the indent for the left and right sides of the paragraph to visually set
the paragraph apart from the rest of the text on the page.

To set the Paragraph Indent, choose Format > Paragraph. There are independent settings for
First Line, Left, and Right. The First Line indent can be either positive or negative, and is used as
an offset from the left side of the paragraph.

Hanging indents

Hanging indents are easy to create and an effective way to set off items in a list. The left side of the
paragraph is indented from the left margin, and the first line is outdented (or the indent is speci-
fied as a negative number).

A common rule of thumb when creating hanging indents is to define the First Line indent the
same as the Left Indent, only negative. The first line then aligns with the rest of the document,
while the left indent is moved in.

Creating lists with numbers and bullets

You can easily highlight important points or steps by creating lists with bullets or numbers. These
combine the text alignment techniques described above with special symbols (bullets) or numbers
to further distinguish the text. TextMaker has two special commands for automating the creation

of these lists.

To create a bulleted list

1.  Select the paragraphs you want to be part of the list, or start a new paragraph to be the
first item in the list.

2. Choose Format > Bullets. Set Type to Bullet and click the OK button. This automatically
turns bullets on for any selected paragraph, and adjusts the paragraph indents accord-
ingly.

3. Asyou create new list items (by pressing the return key), they are automatically created
with bullets.

4. When you want to resume with normal text, choose Format > Bullets, set Type to None
and click the OK button to turn bullets off.

To create a numbered list

1.  Select the paragraphs you want to be part of the list, or start a new paragraph to be the
first item in the list.

2. Choose Format > Bullets. Set Type to Number and click the OK button. This automati-
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cally numbers each selected paragraph, and adjusts the paragraph indents accordingly.

3. Each new numbered paragraph will continue with the numbering from the last num-
bered paragraph.

4. When you want to resume with normal text, choose Format > Bullets, set Type to None
and click the OK button to turn numbering off.

Tabs

Tabs allow you to precisely align text horizontally on a line. There are four types of alignment you
can apply to a tab: left, right, centered, and decimal. Tab alignment determines how text is typed
at a tab. By default, tabs are left-aligned. Decimal tabs are used to aligh numbers to the decimal
point.

The easiest way to set tabs is by clicking the horizontal ruler. See the following section on us-
ing the horizontal ruler for more details. Once you've discovered how easy it is to align text with
tabs, you'll never be tempted to use spaces again.

Using the horizontal ruler

The horizontal ruler at the top of the page helps indicate where text is positioned relative to the
page margins. But its real value is in allowing you to visually setup paragraph indents and tab
stops. Using the horizontal ruler will greatly enhance your ability to easily align text in your docu-
ments.

Setting tabs on the ruler

You can quickly create, move, and delete tab stops on the ruler using the mouse.

To add a tab to the ruler

1  Select the type of tab you want to create by clicking one of the four tab buttons on the Format
strip. The buttons are the four right-most on the strip, representing left, right, center, and dec-
imal tabs respectively.

2 Click the mouse on the ruler near the position you want the tab to be placed. A tab marker ap-
pears on the ruler. You can easily move the tab using the following steps.

To move a tab on the ruler

3 Click the tab marker you want to move, and hold the left mouse button down. Drag the
marker to its new position. A dotted line will extend down into the text while the mouse is
down to help you visualize exactly where the tab will appear in the text. Release the mouse
button, and any text aligned to the tab moves accordingly.

To delete a tab on the ruler

4  Follow the steps for moving a tab, but instead of dragging the marker to a new position, drag
it down below the ruler and release the mouse. The tab disappears from the ruler, and any
text aligned to the deleted tab becomes aligned to the tab immediately following it.

Setting paragraph indents on the ruler

Paragraph indents can be set directly on the horizontal ruler, allowing you to visualize the effects
the indents have on the surrounding text.

TextMaker 2002 — User Manual 13



The paragraph indents are represented on the ruler by three small markers. There are two
markers on the left, stacked on top of each other, and one on the right. The two on the left repre-
sent the first line indent (on top), and the left indent (on bottom). The marker on the right repre-
sents the right paragraph indent.

Setting the indents on the ruler

1  Select the indent marker you want to change with the mouse. With the left button down, drag
the marker to its new position. A dotted line extends down into the text while the mouse is
down, to help you visualize exactly where the indent will appear in the text. Release the
mouse button, and the paragraph aligns to it.

2 To move the left and first line indents simultaneously, select the small rectangle below the in-
dent markers, and follow the steps above.

USING STYLES

In this section you will learn:
» About paragraph and character styles
» How to define styles
» How to apply styles to text

Documents often have different types of paragraphs that need to have consistent appearance,
such as headings, captions, and page footers. To ensure uniformity and save time formatting,
TextMaker lets you create styles that record character and paragraph formatting attributes. You
can edit and delete styles and use them instead of applying formatting manually.

Formatting text without using styles is a one-time procedure. You format individual words and
paragraphs until they appear just the way you want. But if you want to use that format again, you
must remember how you formatted the text, and then apply that formatting to new text. Many
people are satisfied formatting text this way, but enlightened users know that using styles is the
best way to format text. By defining and using styles, you avoid repetitive tasks such as applying
numerous formatting attributes and choosing typeface, point size, alignment, line spacing, etc.; in-
stead, you apply them all at once.

You can create two kinds of styles in TextMaker:
» Character styles

» Paragraph styles

Character styles

A character style is a group of character attributes, such as font, size, style, color, and spacing. For
example, you can create one character style for the main body text of your document using 10-
point Times New Roman, and another style for headings using 14-point Arial bold.

When you define a character style, it appears in the Font menu on the Format strip (and within
the Character dialog box) as if it were a font. Character styles are preceded with an icon that looks
like an ‘S” within a circle.

Paragraph styles

A paragraph style is a group of attributes that affect entire paragraphs, such as indents and align-
ment, line spacing, hyphenation, tabs, and many other settings. Paragraph styles can also specify
character formatting. For example, you can create a paragraph style for headings that uses a cer-
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tain type of character formatting, but that also specifies additional line spacing and center align-
ment.

Defining styles

If you're comfortable formatting text using the Character and Paragraph commands under the For-
mat menu, you already know most of what you need to define styles. To define a style, use the
commands Format > Character Style and Format > Paragraph Style.

But if you were just formatting text ad hoc, any changes you specified would only apply to the
current text selection or paragraph; if you were defining a style, any changes you specified would
apply to the entire document, changing any paragraphs formatted with those styles.

Applying styles
Applying a style is a single action that applies several formatting attributes simultaneously. You
can apply styles to selected paragraphs by two methods:

1.  Selecting a style from the list on the Format strip;
2. By choosing Format > Character Style or Format > Paragraph Style.

The style menus always display the name of the style applied to the currently selected para-
graph, i.e., the paragraph in which the caret is positioned. Choosing a different style applies that
style to the currently selected paragraph or paragraphs.

CHANGING THE DEFAULT FONT

The default font is the font that is automatically selected when you start TextMaker. Depending on
your setup, the default font is probably Times New Roman 10 point. The default font is deter-
mined by the default document template—Normal.tmv (or another document template you speci-
fied as the default for new documents). It’s quite a simple manner to change the default font (or
any other default settings for that matter).

To select another font as the default for new documents

1  Choose the File > New command to create a new document using your default template.
(Most likely the Normal.tmv template unless you have specified a different one.)

The default character and paragraph formats (including font, size, alignment, line spacing, hyphenation, etc.)
are determined by the character and paragraph style “Normal.” You can change these default formatting at-
tributes for the current document by editing the Normal character style and/or paragraph style. You do this
by calling up Format > Paragraph Style and/or Format > Character Style, making changes to the “Normal”
style and saving those changes. You can also specify different default attributes for all new documents, i.e.,
not just the current document, by creating a document template that contains a modified Normal style.

2 Choose Format > Character Style, then click on Edit. The Character dialog box appears.

3 Select the font you want to be the default for new documents. Change any other options you
want as defaults.

Click the OK button, then click on Close in the Character Style dialog.
Choose File > Save As. The Save As dialog box appears.

Select Template from the Save as Type menu.

© oo N O

Choose the file Normal.tmv from the list.
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10 Click OK to save the template and close the dialog box. A message appears asking if you want
to overwrite the existing template—click Yes.

Any changes you made will now be the default for new documents you create using the Nor-
mal.tmv template.

SPECIFYING DIFFERENT UNITS OF MEASUREMENT

TextMaker displays measurements in its dialog boxes based on the unit of measurement settings
specified in your operating system. For most of the world, measurements are displayed in the Met-
ric system, i.e., in centimeters. In the United States, inches is the default measurement, based on
the English measurement system. In Windows, use the Control Panel > Regional Settings to
change the measurement system.

Even though TextMaker displays values in dialog boxes using these default settings, you can
specify any measurement in inches, centimeters, points, or picas (the latter are typographic meas-
urement systems). You simply need to specify which units of measurement you want to use. To
enter units in points, type pt after the value; to specify picas, type pi after a value; type cm for cen-
timeters, and type in for inches. If you don’t specify anything, the default measurement system is
assumed.

Refer to the following chart to see how units are converted from one measurement system to
another:

Inches Points Picas Centimeters Millimeters
0.01 1 0.08 0.04 0.4
1/8 (0.125) 9 0.75 0.32 3.2
0.17 12 1 0.42 4.2
1/4 (0.25) 18 1.5 0.64 6.4
3/8 (0.375) 27 2.25 0.95 9.5
0.39 28.35 2.36 1 10
1/2 (0.5) 36 3 1.27 12.7
5/8 (0.625) 45 3.75 1.59 15.9
3/4 (0.75) 54 45 1.91 19.1
7/8 (0.875) 63 5.25 2.22 22.2
1 72 6 2.54 25.4

WORKING WITH FILES

In this section you will learn:

> How to create, open and save TextMaker documents
» How to open and save documents in other file formats
» How to use the TextMaker File Manager to search, preview, and print documents

This section discusses how you use TextMaker to create, open, and save documents and tem-
plates. The commands used for these tasks are located under the File menu (for more information
about File menu commands and their associated dialog boxes, see the File menu chapter in the
reference section of this manual).
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Creating new documents

When you start TextMaker, the screen contains a new document, ready for you to begin entering
text, formatting it, adding graphics, etc. You can create a new document at any time simply by
choosing File > New.

Choosing the New command displays a dialog box where you must first select a document
template—a pre-configured document whose primary purpose is to provide initial settings for new
documents you create—and specify whether you want the new document to appear in a new win-
dow.

Opening documents

You can open documents at any time either by double-clicking a document icon on the desktop,
or by choosing File > Open in TextMaker and selecting a document from the dialog box.

TextMaker lets you open as many documents as will fit in memory. If you do not want the
document that you are opening to replace the current document, you can open the document in
its own window. To open a document in a new window, just select the New Window check box in
the Open File dialog box.

You can then use Window > Tile or Window > Cascade to arrange the document windows on
your screen, or you can minimize all but the document that you are currently working on. If you
are going to be doing a lot of cutting and pasting between multiple documents, it is easier to open
them in multiple windows than to close one and open another each time you want to paste some-
thing.

The Window menu lists the name of each currently opened document in the order you opened
them, and provides an easy way to cycle between open documents.

Multiple document windows are not supported on Handheld PCs and Pocket PCs.

Opening documents in other file formats

In addition to documents and templates created with TextMaker, you can also open documents
created by other programs such as Microsoft Word, and WordPad, as well as any documents that
have been saved as plain text files, HTML files, or Rich Text Format (RTF) files. Text files only con-
tain unformatted text, spaces, tabs and line returns; they do not contain formatting information
such as font, paragraph, and page settings. RTF files, on the other hand, contain such formatting
information, as well as text frames, tables and pictures.

If you want to import documents into TextMaker that were created with applications that are
not on the list, save them as RTF files, and then open them with TextMaker.

If you want to import documents created by Microsoft Word, simply open them with Text-
Maker’s File > Open command.

To open a document saved in another format

1  Choose File > Open or press Ctrl+O. The Open dialog box appears.
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2 Select the format of the file you want to open from the Files of Type list.

3 Select the appropriate drive and folder where the document you want to open is located. Text-
Maker displays any documents of the specified type it finds.

4  Select the file you want to open from the list and double-click it (or click it once and choose
the Open button). This opens the document.

If you make changes and save the document, the TextMaker format is selected as file format.
Be sure to change this if you want to save it in a different format.

@ The most recently opened documents are listed at the bottom of the File menu for easy access. Selecting one of
these documents opens it immediately, bypassing the Open File dialog box.

On Pocket PCs, recently used files are accessible from the Recent menu.

Saving your work

Saving a document in TextMaker is a very simple process.

To save a new document

1 Choose File > Save or File > Save As. The Save as dialog box appears.
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2 Select the drive and folder where you want the document to be saved. If you want to create a
new folder, click the New folder button and enter a name for it.

3 Type a name for your document in the File Name text box.

You don’t have to type an extension because TextMaker automatically gives all documents the
extension TMD (unless you enter a different one).

C Keep in mind that file name extensions are often hidden from view in Windows, depending on how you've
configured Windows. If you"ve changed an extension but the extension does not appear on the desktop, it
may be an extension you have told Windows not to display.

4  Select Save.

The document is now saved on your hard disk with the file name you typed, and you can re-
turn to editing it. This is the file name that you will look for next time you want to open the docu-
ment.

After you have saved your document for the first time, you will still need to save your work pe-
riodically. Choose Save from the File menu, or press Ctrl+S. The document is saved, with all of
your updates.

Saving a document with a new file name

There are times when you want to give a document a new name, such as when you want to edit an
existing document, but keep an unchanged copy of the original state. If you were to open the
document, edit it, and use the File > Save command, the edited version would overwrite the old
version, so you would have no copy of the original un-edited document. The File > Save As com-
mand provides a way to save your changes as well as retain a copy of the original. After opening
the original document and making changes to it, simply choose the Save As command and enter a
different file name, or the same file name but a different location.

Saving a document in another file format

If you need to export your document for use in another program or computer, or save it as a Text-
Maker document template, you can use the Save As command to save the document in a different
format.
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Normally when you save a document, the Save as type field in the Save File As dialog box dis-
plays “Document.” This is the default file format, and is the recommended format for TextMaker
files.

If you are going to open the file in another program, you can save it in one of the standardized
formats such as Text file, Text file/DOS, or Rich Text Format, as well as in specific formats such as
Microsoft Word and HTML. If you choose one of the text file formats, all text in your file is saved,
but no graphics, objects, styles, or formatting are saved. If you choose the Rich Text Format (RTF)
or Microsoft Word format, all text, text frames, tables, pictures, OLE objects, styles, and formatting
are saved. RTF files can be opened by many programs, and can be transferred to programs on the
Apple Macintosh.

Using the File Manager

TextMaker has a central facility for searching, previewing, and managing your document files.
This is the File Manager command found on the File menu.

The File Manager is a great way to quickly find and open documents whose names or locations
you may have forgotten. You can search for files by keywords, author name, or subject. You can
preview documents to see their actual content before you open them. You can also print docu-
ments without having to open them first.

File Manager

[ Tit
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. ABRIEFABRF2P.TMY  Personal Letter 2
“.ABRIEF\BRF3P.TMY  Personal Letter 3 Document te.
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“.ABRIEF\BRF5P.TMY  Personal Letter & Document te.
. ABRIEFSBRFEP. TMY  Personal Letter 6 Document te...
.

[}
]
[}
]
[}
M\ ABRIEF\ERF7-P.TMY  Personal Letter 7 Document te

Open Oose | Seach. | Oupi~ | Doete | Preview. |

The File Manager is also a great way to clean up your disks of any unwanted or unnecessary
documents. You can preview documents first to be sure that they are no longer needed. Then,
simply click Delete.

Searching for files

When you open the File Manager, you are presented with a list of all the document files in the cur-
rent folder on your disk. The file names are shown in in the first column, allowing you to pick
your documents easily.

If you don't find the file you are looking for, or have forgotten its name, click the Search but-
ton. From the Search dialog box, you can search for files using wildcard file names, as well as in-
formation contained in document summaries. You can tell TextMaker to search in any sub-folders
of the current folder.

File summary

If you create a large number of documents, you may want to get in the habit of entering informa-
tion in the summary, also found on the File menu under File > Properties. Used in conjunction
with the File Manager, summary information is a powerful way to manage, organize and track
documents.

WORKING WITH PLAIN-TEXT DOCUMENTS

Plain-text documents are documents which have no special formatting codes embedded within
them. They are commonly found, for example, on the web, or in Readme files, since any program

TextMaker 2002 — User Manual 20



can easily open and access the text inside. Such a program is Notepad in Windows. Plain-text files
are often formatted with spaces to align text, since there is no other alignment option available.

Keep in mind when working with plain-text files that no formatting information will be re-
tained if you save it as a plain-text file. Therefore, any font or style changes (bold, italic, etc.) or
text alignment will be lost unless you save it as a TextMaker document.

PRINTING DOCUMENTS

Once you have created a document and are ready to see how it looks on paper, follow these steps
to print it.

To print a document from TextMaker

1  Choose File > Print or press Ctrl+P. The Print dialog box appears.

2 Check that the correct printer name is displayed at the top of the dialog box and that this is
the one you want to use. If it is not, you can change the printer selection by choosing a differ-
ent one from the Printer list at the top of the dialog box. You can also click the Setup button
in the dialog to change any printer-specific options.

3 Enter the number of copies you want to print in the Copies box. The default number of copies
is 1.

4 Specify the pages you want to print.

TextMaker assumes that you want to print all of the pages in your document, so the All option
is on by default. If you do not want to print all pages, select the Current Page option to print
the page where the caret is located, or select the Pages option and type the range of pages
(e.g., 3-5,7,12-22) that you want to print.

5 Click OK to print the document.

The document prints. A dialog box appears during the printing process. If you want to abort
the printing process, click Cancel or press the Esc key, and your document will stop printing.

CREATING A MAIL MERGE

With TextMaker you can easily merge data from a dBASE database or comma-delimited list file
when you print a document.

This lets you easily create form letters. Suppose you want to send the same letter to several
people. Rather than creating a separate copy of the letter for each person you want to send it to,
you can create a single copy and merge it with data from an address book or database (name, ad-
dress, etc.). If you have a database containing the names and addresses of everyone you want to
send it to, creating a “form letter” and merging the names and addresses is a snap.

Print merging involves telling TextMaker which data file you want to use, and then specifying
which fields from that data file you want to appear in the document. When you insert a field from
a database file in a document, the field name appears in braces, for example, {NAME}. But when
you print the document, the contents of the field, e.g., “Bridget Cavanaugh,” are substituted for
the field name. A copy of the document is printed for each record in the database, substituting the
{NAME]} field in this example for each record.

To print merge with a data file

1  Call up Extras > Set Merge File to select the data file—dBASE or comma separated list—you
want to merge your document with. dBASE files generally have the extension DBF, and com-
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ma-delimited files usually have the extension CSV or TXT. TextMaker will automatically search
for files with these extensions.

2 Next, position the caret where you want to insert a field from the database or data file, and
choose Insert > Field. The Insert Field dialog box appears.

Field type:
Cloze

Creation date
Settings...

Creatian time
File name

Merge file info
Page number
Page count
Chapter number
Frint date

Print tirne

User (Home]

U ser (Busingss)
Summary

The Merge Fields list displays the field names available from the selected database.
3 Select the field you want to insert at the caret position, and click the Insert button.

4  If you want to insert another merge field adjacent to the first one, repeat steps #2 and #3 for
each one.

The inserted field name appears in braces at the caret position. For example, if you are creat-
ing a form letter, your document might look something like “Dear {FNAME},” where {FNAME}
is the first name field from a dBASE file. The first name field from each database record will be
substituted for FNAME} when the letter is printed.

You can format inserted merge fields as if they were regular words. Simply double-click a
merge field to highlight it, then change font, size, etc. as you normally would. All of the for-
matting control that applies to regular text also applies to merge fields.

5 Choose File > Print Merge to merge the document with the selected data file. The Print Merge
dialog box appears.

6  Specify which records from the selected data file are to be merged.

Select All to print one copy of the document for each record in the selected data file. Select
Range to print a group of contiguous records. Enter the first record number to be merged in
the From box, and the last record number to be merged in the To box. Select Selected records if
you have selected records in TextMaker’s database viewer before.

7  Click OK.

A copy of the document is printed for each record in the selected merge file, with the contents
of the data file substituted for the field names you inserted.

MULTIPLE COLUMNS

Working with columns in TextMaker is very simple. While it is possible to create columns using
text frames (which are actually objects you can move around on the page), this section discusses
creating a multi-column layout using the Section command.

To create a multi-column layout

1  Choose Format > Section. The Section dialog box appears.

2 Enter the number of columns you want to create. One is the default (this turns multiple col-
umns off). You can create up to eight columns.

3 Select the Gutter field and enter the amount of space you want separating each column. Text-
Maker automatically determines the width of each column by dividing the printable area of
the page by the number of columns you specify.
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4  Select a column height from the Height list box. The Height option determines the height of
columns:

» Choose Auto if you want TextMaker to adjust the column height automatically depending
on the length of the text, so that all columns are balanced to the same height

» Choose Page height to instruct TextMaker to fill each column first until the end of the page
and then proceed to the next column.

» Enter an arbitrary value to get columns of arbitrary height.

5 Click OK to accept the column settings and close the Section dialog box.

Turning multiple columns off

To turn columns off, choose Format > Section again and enter 1 for the number of columns. Text
is reformatted into a single column between the left and right paragraph indents.

PAGE LAYOUT IN TEXTMAKER

In this section you will learn:

» About desktop publishing using TextMaker

4 Drawing simple graphics

» Selecting, grouping and deleting objects
» Moving, resizing, and rotating objects

» Background shades and borders

» Copying and pasting objects

As you've probably figured out by now, TextMaker has two modes—Text mode and Object mode.
You are already familiar with Text mode; this is where you enter and format text. Objects are cre-
ated and manipulated in Object mode. To change between the modes, call View > Object mode or
click on the Object mode button in the Format strip.

TextMaker knows which commands are available in each mode. Most Format menu com-
mands (except for Borders, Lines, and Shades) are not used to manipulate objects, and are there-
fore grayed out when TextMaker is in Object mode. Likewise, most of the Object menu com-
mands are unavailable when you are in Text mode. Certain types of objects—specifically text
frames and tables—have properties that are edited using both modes. The text contained within a
text frame is edited in Text mode, but the frame properties—size, position, border, shading and fill
patterns, etc.—are edited in Object mode.

- Click this button in the Format strip to switch to Object mode where you can
create, modify, and position graphic objects, pictures, text frames, tables, and
OLE objects.

Click this button again to switch back to Text mode where you can enter, edit,
and format text.

@ You can also switch modes by clicking the right mouse button and choosing the opposite mode of the one you
are currently in. For example, if you are in Text mode, you can switch to Object mode by clicking the right
mouse button and choosing Object mode from the pop-up menu. You can also make a double click with the
right mouse button to switch the modes.
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Drawing objects

You can draw lines, rectangles, rounded-corner rectangles, and ellipses using the drawing tools lo-
cated on the object strip. These same tools are also available by opening the Object > New Draw-
ing sub-menu.

When you select a drawing tool, the cursor changes to a crosshair containing a representation
of the object you are about to create. If you are drawing an ellipse, for example, the cursor is a
crosshair with an ellipse below. Position the crosshair where you want the object to begin, then
click and hold down the left mouse button while dragging to where you want it to end. The out-
line of the object you are drawing rubberbands as you move the mouse. Let go of the mouse button
when you are satisfied with the size and shape of the object.

There is no limit to the number of objects you can draw in a document. You cannot draw ob-
jects that extend past the boundaries of the page, but you can draw objects past the margins. Mar-
gins affect text only.

Immediately after drawing an object, it is highlighted, or, in other words, selected. When an
object is selected, you can change its properties such as line width, fill pattern, color, resize it,
move it, etc.

When drawing objects, press the Shift key to constrain the object. Holding down the Shift key as you draw a
rectangle, for example, lets you draw squares, circles if you are using the oval tool, and horizontal or vertical
lines if you are using the line tool.

Selecting an object

You select objects in Object mode by clicking on them with the mouse. When an object is selected,
it is highlighted. A lighter colored border line also appears around the outside of the object—this is
the object’s wrap margin. Wrap margins determine how close text in your document will appear
to the object before wrapping over or below the object. (See the section “Changing wrap margins
with the mouse” for more information.)

Selecting multiple objects

You can select more than one object at a time by holding down the Shift key when you click. For
example, select an object with the mouse, hold down the Shift key, and click another object. Both
objects are now selected. While still holding down the Shift key, click another object. Now three
objects are selected. You can also select multiple objects by clicking and dragging—rubberbanding—a
selection rectangle around them. When you release the mouse, any objects within the selection
rectangle are selected.

You can move multiple objects together at once, or group them using Object > Group. This al-
lows you to position multiple objects as a single unit, and the group is maintained even if you se-
lect something else.

Moving objects with the mouse

To move an object, switch to Object mode, click the pointer anywhere on the object and drag. The
pointer changes to the one shown above when you position it over a selected object. When you let
go of the mouse button, the object is moved to the new location. It is still selected, allowing you to
move it again, format it, delete it, etc. Objects can not be moved past the edges of a page. If you
want to move an object to a different page, you have to cut it, go to the destination page, then
paste the object. See the section Copying and Pasting Objects in the Edit Menu Commands chapter.
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Deleting an object

To delete an object, first select it then press the Delete key, or choose Edit > Delete.

Rotating an object

Most objects in TextMaker can be rotated in 90 degree increments. You can always set a specific
angle in the Object Properties dialog box (double-click on the object to open its properties dialog
box).

Resizing an object with the mouse

To change an object’s size, first select the object by clicking on it, then move the mouse directly
over one of its sides or one of its corners. Make sure to position the pointer over the object boun-
dary itself and not its wrap margin (the light colored border line around the outside of the object).
The pointer changes to a white double-arrow, its direction depending on which side or corner it is
positioned. Simply click and drag in one of the directions of the double-arrows to increase or de-
crease the object’s size.

Holding down the Shift key while resizing the object constrains its aspect ratio to a square or a
circle.

Changing wrap margins with the mouse

When you select an object, a border line appears around it. This line represents the object’s wrap
margin. The wrap margin determines how close text in your document may appear above, below,
or to either side of an object before wrapping. To change an object’s wrap margin, first click the
object, then move the mouse directly over the wrap margin you want to change. The pointer
changes to a gray double-arrow, its direction depending on which wrap margin you want to
change. Simply click and drag in one of the directions of the double-arrows to increase or decrease
the wrap margin.

In the following examples, compare the size of the wrap margins, and the effect they have on
the surrounding text:
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Editing an object’s properties from a dialog box

Double-click an object to display a dialog box containing options for editing the object’s appear-

ance and changing its position on the page. TextMaker knows what type of object it is when you
double-click it, and displays the appropriate dialog box. See the Properties command later in this

chapter for more information.
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Changing line types, shading, and fill patterns

You can change the line width, style, and color of any object you draw. For some objects, you can
even specify shading and fill patterns.

There are a couple of different ways to change the line width or line style of an object: select
the object and choose Format > Lines; or double-click the object to open its properties dialog box
(or choose Object > Properties). If the object is a text frame, table, or picture, go to the Borders tab
to change its border type and line style.

You can change an object’s shading or fill pattern in the same way—by choosing Format >
Shades, or by double-clicking the object to open its attributes dialog box, and then selecting the
Shades tab. Some objects such as pictures and straight lines do not have a shade attribute.

TextMaker provides several different line widths to choose from, ranging from Hairline (the
thinnest line your printer can generate) to 12 point. You can also enter a custom line width, meas-
ured in points (72 points equals one inch). There is also a multi-line style; you can edit the width
of each line that makes up the multi-line, as well as specify the amount of space between the lines.
The Borders command controls the style or width of border lines for the object. The default border
line style for imported graphics is None, or no border, but you can add border lines to any im-
ported graphic object.

Cutting and pasting objects

You can copy a selected object to the clipboard so you can later paste it back into the document at
a different location, or even to a different document. Say, for example, you need to create several
1 inch by 4 inch rectangles. Rather than drawing and re-sizing the rectangles one at a time, create
a single rectangle, copy it, then paste as many copies as you need.

To copy an object, select it with the pointer tool (you must be in Object mode), then choose Ed-
it > Copy. A duplicate of the object—including its attributes such as line width and fill pattern—is
placed on the clipboard. Now you can paste copies of the object wherever you need them. The ob-
ject remains on the clipboard until you choose Cut or Copy again, or exit TextMaker.

Once an object has been copied to the clipboard, choose Edit > Paste to place it back into the
document. If you need to, you can copy an object from one document and paste it into another.

To copy and paste an object

1  Select the object you want to copy using the pointer tool.
2 Choose Edit > Copy. The object is copied to the clipboard.

3 Go to the page in your document you want to place a copy of the object and choose Edit >
Paste. A duplicate of the object is pasted into the middle of the current window.

To copy an object to a different document

1  Select the object you want to copy.

2 Choose Edit > Copy.

3 Choose File > Open and select the document you want to copy the object to.
4

Go to the page in the new document you want to place the object and choose Edit > Paste.
The object you copied now appears in both documents.
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Pasting objects into document text

You can copy certain objects (pictures and tables only) and paste them into document text as if
they were text. This is useful if you want the object to be anchored to the surrounding text, flow-
ing with the text as it moves.

To copy an object into body text

1  Select the picture or table you want to copy.
2 Choose Edit > Copy.

3 Put TextMaker back into Text mode by clicking the Object mode button (button should be un-
pressed afterwards) on the object strip.

4  Position the caret in your text where you want the picture or table to appear, and choose Edit
> Paste.

The picture or table is pasted into the text, exactly as if it were text. That is, it will move along
with the text as you type, edit, format, etc.

Pictures and tables you paste into text can be manipulated just like other objects—they can be
resized, scaled, cropped, etc.—but their position on the page cannot be moved relative to the text.
They are anchored to the text, literally part of the text. Think of objects you paste in this manner
as if they were characters typed from the keyboard.

USING THE OUTLINER

In this section you will learn:

» To manage your documents with the outliner
4 To set and display outline levels

» To expand and collapse outline levels

» To organize your document

» To use paragraph styles and the outliner

The outlining feature in TextMaker is not a separate program, but rather a different view of the
document, like Standard view or Continuous view. You switch to Outline view by choosing View
> Outline.

Any document can be displayed in Outline view, whether you have specifically created an out-
line or not. Changing to Outline view does not change your document, but any changes or edits
you make while in Outline view are there when you return to Standard or Continuous view.

If you are creating a complex document that has several headings and sub-headings, or that re-
quires an index or table of contents, you can probably benefit from occasionally editing the docu-
ment in Outline view.

Defining an outline

An outline is a tool for viewing the main ideas of a document. You probably first encountered the
concept of outlining in grade school, where you were taught that the most important ideas are
identified with Roman numerals: I, II, III, IV, etc. Each of these top-level ideas acts as an umbrella
for subtopics identified with letters of the alphabet: A, B, C, D, etc. Each subtopic likewise can be
broken down further using Arabic numerals: 1, 2, 3, 4, etc.
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Traditional pen and paper outlines such as those we learned to create in grade school are ex-
tremely logical and straightforward, but generally not very useful. In a pen and paper world, out-
lines are inflexible because they exist separately from the documents they are supposed to help or-
ganize.

With TextMaker, you can outline a document before, during, or after you have created it. In
addition, you always have an up-to-date outline; you can get a quick overview of where you have
been and where you are going with your document simply by popping into Outline view.

Outlining is a method of organizing your ideas by assigning them different outline levels. An
idea is contained in a paragraph, and each paragraph can be assigned an outline level between 0
and 9. By reevaluating the outlining techniques we learned in grade school, you can see that Ro-
man numeral headings correspond to level one ideas, uppercase letters to level two ideas, Arabic
numbers to level three ideas, and so on. The ideas to which you assign these levels serve as head-
ings. The rest of the text is the document’s body text.

Usually when you are creating a document and using an outline, you create the headings in the
Outline view and assign the headings a level. You then write the body text while in Standard or
Continuous view.

Outlining makes revising and editing your documents easy because you can change the level
by promoting or demoting any outline paragraph simply by clicking a button. You also can use the
outline to get a quick overview of your document’s organization.

You can choose to view your entire document organized as an outline, or you can choose to
view only certain outline levels. If, for example, you want to revise top-level headings only, you
can collapse, or hide from view, all but the level one paragraphs so that only the Roman numeral
level headings are visible. The other paragraphs still exist, but they remain collapsed until you ex-
pand the outline or exit Outline view.

In Outline view, you cannot create or edit objects like graphics using the standard drawing
tools. You can only create objects while in Standard view.

Switching to Outline view

You can view new or existing documents in Outline view by choosing View > Outline. You can al-
so create documents entirely in Outline view without ever switching to Standard or Continuous
views if you so desire.

To change to Outline view

1  Open the document you want to outline, or create a new document.
2 Choose View > Outline.

To switch out of Outline view, simply choose one of the other views from the View menu. You
can switch between Outline view and the other views as frequently as you need. Changing views
does not affect the document.

Setting outline levels

You can assign an outline level to any paragraph. Paragraphs with outline levels between 1 and 9
are treated as outline headings, with 1 being the highest, or most general, outline level. Para-
graphs with an outline level of 0, the default outline level, are treated as regular body text.

There are two methods for changing a paragraph’s outline level: you can assign an outline level
from the Paragraph dialog box, and thus define outline levels as part of a paragraph style, assign-
ing a style for titles or headlines, for example, with an outline level of 1 or 2; or you can click the
Promote and Demote buttons on the outline strip.

TextMaker 2002 — User Manual 29



Promote button: Click the left-pointing arrow to promote a paragraph’s outline level. Click-
ing this button changes a paragraph’s level from 2 to 1, or from 4 to 3, etc. If a paragraph
has an outline level of 0 (i.e., it is body text), clicking this button promotes it to level 1.

—
Demote button: Click the right-pointing arrow to demote a paragraph’s outline level. Click-
ing this button changes a paragraph’s level from 1 to 2, or from 3 to 4, etc. If a paragraph
has an outline level of 0 (normal body text), clicking this button has no effect.

_ﬁ.

Demote to Normal Text button: Click the double right-pointing arrow to demote a para-
graph’s outline level to 0, or normal body text.

Displaying outline levels

After you have assigned different outline levels to paragraphs, you can choose which levels you
want displayed in Outline view.

12 3 4 &5 B 7 8 9 |al

The numbered buttons on the Outline strip determine which levels are displayed. When you
click one of the numbered buttons, only paragraphs with an outline level corresponding to the
number of the button, as well as any paragraphs with a higher level, are displayed. For example, if
you clicked the level 4 button, only paragraphs with an outline level between 1 and 4 would be
displayed.

To display all levels, including normal text, click the All button on the Outline strip.

These buttons do not change any outline level you may have assigned to a paragraph, but
rather control which levels will be displayed in Outline view.

Expanding and collapsing outline levels

Clicking the numbered buttons as discussed above controls the display level for the entire outline,
but you can hide or show paragraphs and their subordinate paragraphs one at a time as well. This
is known as expanding and collapsing. You expand headings to see more of the outline—headings,
subordinate headings, as well as any normal body text associated with a heading. You collapse
headings to focus more on higher level structure and less on detail.

= -

Click the minus button on the Outline strip to collapse a heading one level at a time. Subordi-
nate levels below the selected heading are collapsed, or hidden from view, one level at a time, i.e.,
each time you click the minus button, one less level of detail is displayed.

For example, if you placed the caret in a level 2 paragraph, clicking the minus button would
hide from view all body text (level 0 paragraphs) between that level 2 paragraph and the next level
2 paragraph in the document. With the caret still in the level 2 paragraph, clicking the minus but-
ton again would hide the next level of subordinate paragraphs, level 4 headings, for instance.
Clicking it yet again would hide any level 3 headings, and so on. Finally you would get to a point
where all the subordinate levels below the level 2 paragraph would be hidden from view, leaving
only the selected level 2 paragraph. Clicking the minus button at this point would then hide the
level 2 paragraph itself. If the caret is placed in a level 0 paragraph, i.e., normal body text, clicking
the minus button simply hides that paragraph (level 0 paragraphs do not have subordinate para-
graphs, and thus nothing to collapse).

Click the plus button on the Outline strip to expand a collapsed heading one level at a time.
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Neither the expand nor collapse buttons delete text from your document, they simply control
the level of detail that is displayed while in Outline view. When you switch to Standard or Contin-
uous view, all paragraphs are displayed.

Organizing your document in Qutline view

In addition to using the expand and collapse feature to view your document at different levels of
detail, you can also use it, in conjunction with the Cut and Paste commands, to move large chunks
of text from one position in the document to another. When you collapse a heading, you can move
it and all of the collapsed text under it with the Cut and Paste commands. Even though all of the
collapsed text is conveniently hidden from view, when you move the heading with the Cut and
Paste commands, all of the hidden text is moved along with it.

Using outlines with styles

When you change outline levels in Outline view, the outline level displayed in the Paragraph dia-
log box changes as well. In other words, the outline level is a paragraph attribute, which means
that an outline level can be defined as part of a style.

Outlining becomes a powerful feature when used in conjunction with styles, because you can
combine the way text looks with the way text is organized. You may want a report title, for exam-
ple, to be formatted using a large, bold font, such as Arial 24-point bold; a report title is also a
good example of a heading level 1 paragraph. Section titles in the report would likely be smaller
than the report title itself, perhaps set in Arial 14-point bold. A section title might be assigned an
outline level of 2.

When you apply styles containing outline levels to text, the text automatically is numbered and
indented in Outline view. You don’t have to change levels using the promote and demote buttons
unless you want to override the level you defined as part of the style.

Where to go from here...

This concludes the Tips & Techniques section of this manual. The following chapters cover all menu
commands of TextMaker in the same order they are shown in the program. Use these reference
chapters to find out about the features of TextMaker that have not been mentioned in the Tips &
Techniques section.
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wpes | Fil@e Menu Commands

The File menu contains commands for working with document files. These commands let you
perform such tasks as creating new documents, opening, saving and searching for existing ones,
and printing, for example.

The commands in this chapter are organized in the same manner they appear on the menu.

NEW

Use the New command to create a new TextMaker document.

Choosing the New command displays a dialog box from which you select a document template
to base your new document on and specify whether you want the new document to appear in a
new window or not.

A document template is a pre-configured document whose purpose is to provide initial settings for
new documents you create. These initial settings determine properties such as the default font,
character and paragraph styles, page dimensions, the placement of indents and tabs, even pre-
typed text and graphics such as logos and addresses for letterhead—virtually anything that can be
saved with a document can also be saved in a template.

New dialog box
New
Template:
07 inquiry.tmv [iT3 |
Invoice tmy
g letter. by Cancel
B St default
¥ New Window
rDescription
Set Default Click this button if you want the selected template to be the default template

when you start TextMaker.

New Window Check this option if you want TextMaker to create the new document in a
new window. If this option is not checked, TextMaker will use the current
window for the new document. If the current window contains a document
that has unsaved changes, you are prompted to save them first.

To: Press:
Create a new TextMaker document Ctrl+N
OPEN

Use File > Open to open an existing TextMaker document or template, or to import documents
created in other formats such as text files or Microsoft Word files, for example. Choosing the
Open command displays a dialog box where you can select documents or templates located in
various folders, drives, or network servers you specify.
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Open File dialog box

Look in gl
[Slaabke [ font 5
[“beeb [ Home2K, s
Doz [ Mouss Er
"I Downloads [ Diffice2K Ear
|“IEigene Dateion (2] Program Files ke
| IEurowE ;IPlogramme S
| | —— |
EieName: | Open |
File of Type: |Documenl [®tnd) j Carcel

¥ Hewwindaw
Quickpah  v| Elemensger. | Preview. |
Look in Select the drive and folder where you want TextMaker to look for documents.

Files of Type

After selecting a folder, any documents of the type specified (from the Files of
Type menu) are displayed.

Select options from this menu to tell TextMaker the type of document you
want to open—normal TextMaker documents (this is the default), templates,
text files, RTF (Rich Text Format) files, and file formats from other word pro-
cessors such as Microsoft Word.

The type you choose here determines the available files displayed in the list.
For example, if you select Template from this menu, TextMaker will only dis-
play template files (which have the extension TMV) in the list. If you want all
files from a particular folder to be listed, select the All Files option. If you want
all files to be listed that can be opened by TextMaker, choose the All Documents
option.

@ Use the Rich Text Format option to import documents from other word processing applications not on the
list. You'll first need to save, or export, the documents as RTF files, but almost all Windows word processors
provide this capability.

New Window

Quick Path

File manager

Preview

Check this option if you want TextMaker to open the document in a new win-
dow. If this option is not checked, TextMaker will use the current window. If
the current window contains a document that has unsaved changes, you are
prompted to save them first.

You can tell TextMaker to check or uncheck this option by default. Open Ex-
tras > Preferences > General and toggle the Use New Windows by Default op-
tion to your preferred state: on or off.

Click this button to use TextMaker’s Quick Path feature. Quick Paths are
named pointers to actual paths on your hard disk. You could create a Quick
Path “Documents” pointing to c:\My Documents\SoftMaker and, after that,
simply select “Documents” from the Quick Paths list to quickly switch to that
folder.

Click this button to access the TextMaker File Manager, a utility you can use
to search for documents, templates, text files, or any other files of type on
your hard drive or network drive. Pressing this button is the same as choosing
the File Manager command from the File menu.

Click this button to get a quick preview of the document before opening it in
TextMaker.

TextMaker 2002 — User Manual 33



To: Press:

Open an existing document Ctrl+O

CLOSE

Use File > Close to close the current document window. If unsaved changes have been made to
the document, you will be prompted to save them first—TextMaker won't discard a document
without asking you first.

To: Press:
Close the current document window Ctrl+W (or Ctrl+F4)
SAVE

Use File > Save to save any changes you have made to the current document. If this is the first
time you are saving the document, choosing this command displays the Save File As dialog box
where you can specify a file name and folder where you want to store the document.

Choose the Save command on a regular basis as you work on your documents to ensure that
you do not accidentally lose changes in the event of a system crash or power interruption.

To: Press:
Save the current document Ctrl+S
SAVE AS

Use File > Save As to save the current document with a new name and/or to a different folder or
drive. If you enter a file name of an existing document or template, TextMaker asks you whether
you want to overwrite the existing file. Choosing Yes overwrites the existing file; choosing No re-
turns you to the Save File As dialog box where you can enter a different name or select a different
drive or folder.

Save File As dialog box

Save as HE
Speichern in:| s WEEE gl
lbatkz (ot Es
{“beetb (£ HomezK =
Des [ Mouse Er
" Downloads [ Difice2K, EaT
" IEigene Dateien (2] Program Files e
| IEurowE ;IPlogramme S
|l —— |
Dateiname: | Speichern I
Dateityp: IDucumenl [*tmd) ﬂ Abbrechen
Quick path - Summary..
File Name Enter a name for the document. The default file name extension for docu-

ments is TMD and is automatically appended to the file name you enter, un-
less you enter a different extension.

Save as type You can save TextMaker document files in different formats:

» Document—the native format for TextMaker files.
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» Template—saves the document as a TextMaker template. Templates are
pre-configured documents. Their purpose is to provide initial settings
for new documents you create. These initial settings determine the de-
fault font, character and paragraph styles, page dimensions, the place-
ment of indents and tabs on the ruler, even pre-typed text and graphics
such as logos and addresses for letterhead. Virtually anything that can
be saved with a document can also be saved in a template.

@ Documents saved as templates must be saved in the “Templates’ folder or a folder below this one for Text-
Maker to recognize them. The Save File As dialog box defaults to this location when you save files as tem-
plates. You can save templates in different folders, but in order for TextMaker to use them, they must first be
located in the Template folder or a folder below that folder. (The default template path can be set in Extras >

Preferences).

4 Word for Windows—saves the document in a format capable of being
opened with Microsoft Word for Windows.

» Rich Text Format—saves the document and formatting information
(fonts, styles, etc.) in a format capable of being transferred between dif-
ferent applications or different computers, such as the Macintosh. All
text, text frames, tables, pictures, styles, and formatting are saved, but
not objects such as lines, rectangles, or ellipses.

» Pocket Word/Pocket PC—saves the document in a format capable of
being opened by Pocket Word on Pocket PCs.

» Pocket Word/Handheld PC—saves the document in a format capable of
being opened by Pocket Word on Handheld PCs.

» HTML 4.0—saves the document as an HTML file.

» Text file/DOS—saves the document as a plain text file. Text files can be
opened and edited by all word processors, but formatting information
and graphics cannot be included in them.

> Text file—the same as a DOS text file, but saves text using the Windows
ANSI character set. Certain characters such as line drawing characters
are not part of the Windows ANSI character set.

Quick Path Click this button to use TextMaker’s Quick Path feature. Quick Paths are
named pointers to actual paths on your hard disk. You could create a Quick

Path “Documents” pointing to c:\My Documents\SoftMaker and, after that,

simply select “Documents” from the Quick Paths list to quickly switch to that

folder.
Summary This button lets you enter additional information that will be saved along with

the document. You can specify a title, subject, author, keywords and a short
description of the document.

You must save your document in order to be able to retrieve it again. Saving your document
means that you are giving the document a name and copying the document onto your hard disk,
where it remains until you open it again for modification, or delete it.

Until your work is saved with a file name, it is extremely vulnerable; any number of incidents
can result in the loss of your entire document (a power failure for example), leaving you with no
record of your work-TextMaker supports autosaving, however, at timed intervals. If the computer
crashes, TextMaker will find the documents when it is launched again, and asks whether you
want to restore the documents. In most cases, you will only lose a few minutes of work. This
handy feature is turned on by default; you can manage its behavior through Extras > Preferences >
Files.
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When you save a document with a file name, the file name appears on the title bar. This is very
helpful if you have multiple documents open at once. If the title bar of your document window
says “Untitled 1,” you are working on a document that has not been saved. “Untitled 1” is the
name assigned to the first document you create; the default title for the second document you cre-
ate is “Untitled 2,” and so on.

SAVE ALL

Use File > Save All to save changes to all open documents. Save All differs from the Save com-
mand in that the Save command only saves changes you have made to the active document. Say,
for example, you have two open documents in separate windows. Choosing the Save command
would save changes to the active document only (the document where the caret is currently lo-
cated), but the Save All command would save changes to both documents.

ACQUIRE

If you have a TWAIN-compatible device (scanner or digital camera) hooked up to your computer,
you can use File > Acquire to transfer pictures directly into TextMaker. This command starts the
image acquisition. Depending on whether you are in Text mode or Object mode, the new graphic
is inserted either as part of the body text or as a picture frame.

SELECT SOURCE

If you have multiple TWAIN devices hooked up to your computer, File > Select Source lets you se-
lect from which of these you want to acquire images when calling up File > Acquire.

PROPERTIES

Use the Properties command to inspect and modify the following document settings.

Summary This tab lets you access the document summary that stores additional infor-
mation along with the document. You can specify a title, subject, author, key-
words and a short description of the document.

View This tab lets you access the TextMaker viewing options where you can decide
things like the handling of hidden objects, the locking behaviour of objects, if
inserted fields are displayed by name or content etc.

Colors This tab lets you modify the color palette of the current document. You can
set up user-defined colors that are specific to each document-by saving a
document template with user-defined colors, future documents based on that
template will inherit the color palette.

Fax Here you can setup faxing-related options for your document. Specifically,
you can enter the name and fax number of the recipient—if you set up a fax
merge document, you can insert field names here as well. TextMaker will
then pick the fax number, name of the recipient etc. from the attached data-
base—very similar to a merge print job.

Internet This tab lets you set up colors and background pictures for HTML files.

Info Provides document statistics. You can see how many keystrokes, characters,
words, sentences, paragraphs, sections, chapters, lines and pages are in your
document. Also, the number of objects is displayed, and you will get a quick
measurement of the readability of your document.
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Protection This tab is used to set options for read and write-restrictions and lets you as-
sign passwords for reading and writing your document.

Forms This tab is used to set options for forms mode.

FILE MANAGER

Use the File Manager to locate, preview, and open TextMaker documents. You can also print and
delete selected documents directly from the File Manager.

The first time you choose this command, the File Manager lists all TextMaker files in the cur-
rent folder. You may refine this list by specifying search criteria. Search criteria can be as general
as telling TextMaker to locate all TextMaker documents on a particular drive, or you can restrict it
to more specific search criteria, such as certain file names, subjects, or keywords, for instance.
Any files that meet the search criteria are displayed in the File Manager. You can select files from
the list and open, preview, print, or delete them.

File Manager dialog box

File Manager [Co[x]

LORETE
EF\BRF2P.T

hA | -
M ABRIEFSBRFI-P.TMY  Personal Letter 3 Dacurnent te..
tAABRIEFSERFAP.TMY  Personal Letter 4 Document te...
M ABRIEF\BRFE-P.TMY  Personal Letter 6 Documert te.
b\ ABRIEF\BRFE-P.TMY  Personal Letter & Document te...
MAABRIEF\BRF7-P.TMY  Personal Letter 7 Documert te.

Open LClose Seaich Output w Delete Preview

To search for a file

1  Choose File > File Manager. The File Manager dialog box is displayed.
2 Click the Search button. The Search File dialog box is displayed.

Search File
File name: | R e g oders
T:ymypersonal
File type [ Al documents JE1 I =y add ot
™ Inglude subfolders Cancel
X documents
Tite: [ S book. Quick paths »
Subi [5] viewer
Subict £ Fonts =l Hetiale
etwark..

Author I Difives: —

Keywords: [E=r Wsiverserertier 2]

Description, I

3 Choose a document type from the File type list. By default, TextMaker shows all supported file
types, but you can also search just for TextMaker documents, text files, RTF files, etc.

4 If you know the file name of the document you are searching for, enter it in the File Name
field. Otherwise, leave this field set to its default.

5 Choose the drive and folders where you want TextMaker to search from the Drives and Fold-
ers lists. If you want to search an entire drive, double-click its icon at the top of the Folders list,
then check the Include subfolders check box.

6 In the Title, Subject, Author, and Keywords fields, type information to specify additional search
criteria. TextMaker will restrict its search to any information you enter here.

7 To create a new list in the File Manager dialog box, click the New list button. This replaces any
existing list with the results of the current search.

— Or —
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To append to an existing list, click the Add fo List button. Any files TextMaker finds are ap-
pended to the current files list.

Network

PAGE SETUP

This button allows you to access network drives and establish connections to
remote network shares.

Use File > Page Setup to change document orientation, paper size, and margins. Choosing this
command displays the Page Setup dialog box.

.
Page Setup dialog box
Dtientafion—————
& Faialt —
€ Landscape
- Paper zi Margir
Letter - Top: EBottom
wrsn [ [omn &

idth: Height,

Leit Right:

[327in & [11.690n

[oran B [omin [F

r-Paper bin;

FEirst page:

Mest pages:

|

Use printer setting

B

[Use piinter setting

Orientation

Paper Size

Margins

Paper bins

PRINT

Click Portrait for a top-to-bottom page orientation (long edge vertical); click
Landscape for a side-to-side page orientation (long edge horizontal).

Choose from several different paper and envelope sizes. Letter size (8.5 by 11
inches) is the default in the Normal.tmv template. To use a custom paper size,
enter the appropriate values in the Width and Height boxes.

Enter values for left, right, top, and bottom margins. Margins are the white
space around the borders of a page.

Choose from the list of paper bins that your printer supports.

Use File > Print to print one or more copies of the current document to the active printer, or direct
printer output to a file. Choosing this command displays the Print dialog box.

Print dialog box
Print
- Frint devic
FErinter.
- Setup...
rPage Optior:
(Y coes 1
' Selected Pagels] ¥ Collate copies
£ Pages: [1-1 ™ Print to file
Pages to print: r Drop pictures
Al selected - ™ Reyerse arder
Printer Select the printer you want to use from this list. Any printers you have in-

stalled in Windows appear in the list.
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Pages

Pages to print

If you leave All selected, TextMaker prints all pages in your document. Click
the Current Page option to print the page the caret is on. If you have high-
lighted any text in your document prior to choosing the Print command, this
option changes to Selected Pages, and will print only the page(s) containing the
selected text. To print a range of pages, enter the beginning and ending page
numbers in the Pages boxes (e.g., 2-4,15,17-)

You can choose to print only pages with odd or even page numbers. This is
useful when printing two-sided copies.

To print two-sided documents

1  First print all odd pages of the document by selecting the Odd Pages option.

2 Next take the paper out of the printer, turn it over and place it back into the feed tray of your

printer.

3 Ifyou have an odd number of pages in your document, remove the top sheet from the feed
tray (this will be the last page printed). You need to do this because there is no even page for
the last page of the document.

4 Print all the even pages of the document by selecting the Even Pages option and checking the
Reverse Order option. This is necessary since you turned the pages over when you placed them
back into the feed tray.

Copies
Collate Copies

Enter the number of copies you want to print.

This option prints one complete copy of the document before printing the
next copy.

To speed up printing, you should turn off the Collate Copies option if you are printing multiple copies on a

laser printer.

Print To File

Drop Pictures

Reverse Order

This option lets you print to a disk file rather than to a printer. Check this op-
tion if you are preparing a document for printing by a service bureau, for ex-
ample, or if you want to send it to the printer at a later time. After selecting
Print To File and clicking OK, a dialog box is displayed prompting you to en-
ter an output file name. Enter the path and file name, then click OK to create
the output file. It will then be stored on your hard disk with the file name you
entered. Printer files cannot be opened and edited in any applications, but
they can be printed using the DOS Copy command. To print a printer file, go
to a DOS prompt and type:

COPY filename LPT1 /b

where “filename” is the path and file name of the printer file. If your printer is
connected to a printer port other than LPT1 (such as LPT2, for example), then
be sure to specify it correctly.

Click this option if you do not want pictures in your document to be printed.
This is useful for printing drafts and can significantly reduce the amount of
time it takes to print a document.

Normally, TextMaker prints from the first page of the document to the last. If
you want to print it in reverse order—from the last page of the document to
the first—check this option. This is useful if you are printing two-sided docu-
ments (see above).
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PRINT MERGE

Use this command to activate the dialog for Print Merging. Print merging is a process in which
you print out form letters to multiple recipients with certain personalized pieces of text taken
from a database.

The Print Merge dialog offers all the options of the regular Print dialog but also allows you to se-
lect which records are drawn from the database and merged with your form letter. Available
choices are All (print all records), Selected (print only records that have been selected in Text-
Maker’s database module before), and Range (specify the from-to range of records).

SETTING UP THE PRINTER

Before you can actually print your document, you may need to check that the printer is set up
properly, and that the correct printer driver is chosen.

To set up the printer

1  Select the File > Print. The Print dialog box appears.

2 Select the printer you want to use from the Printer list.

3  Click the Setup button. The setup dialog box for the selected printer appears.

4 Change any printer-specific options as needed, such as paper source, printer resolution, etc.
5 Click OK to return to the Print dialog box; then click Close to exit the Print dialog box.

You don’t need to do this each time you print, but rather only if you need to change printer
options.

SEND > E-MAIL

Use File > Send > E-Malil to send the current document via e-mail.

Your e-mail software must be compatible with Microsoft’s MAPI protocol (Microsoft Outlook,
Outlook Express, Mozilla, and Netscape Communicator are). Note that the actual sending of
documents is handled by the MAPI mail program and not by TextMaker.

SEND > FAX

Use File > Send > Fax to send the current document through a fax modem.

The following fax programs are currently supported: WinFax Pro, Microsoft Fax, Tobit Fax-
Ware, FaxLine2, VipFax, and AVM FritzFax Note that the actual sending of documents is
handled by the fax software and not by TextMaker.

EXIT

Use File > Exit to quit TextMaker. If any unsaved changes have been made to open documents
when you choose this command, you are prompted to save them first.
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To:

Press:

Quit TextMaker

Ctrl+Q (or Alt+F4)
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wers | ECAIt Menu Commands

The Edit menu contains basic text and object manipulation commands.

UNDO & REDO

Use Edit > Undo to reverse the effect of the last action you performed, such as typing, deleting, or
formatting text, creating or moving graphic objects, inserting a page break, etc.

The Undo command provides a safety net to prevent unwanted changes, allowing you to undo
the last changes (up to 999, depending on what you set in Extras > Preferences) you made to your
document.

Upon selecting an Undo command, the command Edit > Redo becomes available. The Redo
command lets you undo the last Undo operations you have executed.

To: Press:

Undo Ctrl+Z (or Alt+Backspace)
Redo Ctrl+Y

T

Use Edit > Cut to delete the selected text or object from your document and place it on the clip-
board where it can be pasted elsewhere in the document, or to a different document.

Text and pictures can be cut and pasted to other Windows programs such as Microsoft Paint or
WordPad, but objects created with TextMaker, such as lines, rectangles, ellipses, frames, and ta-
bles, can only be cut and pasted to other TextMaker documents. Pictures can be cut and pasted to
other applications that support such formats.

To: Press:
Cut Ctrl+X (or Shift+Delete)
copPYy

Use Edit > Copy to place a duplicate of the selected text or object onto the clipboard where it can
be pasted elsewhere in the document, or to a different document.

Text and pictures can be copied and pasted to other programs such as Microsoft Paint or
WordPad, but objects created with TextMaker can only be copied and pasted to other TextMaker
documents. Pictures can be copied and pasted to other applications that support such formats.
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To: Press:

Copy Ctrl+C (or Ctrl+Insert)

PASTE

Use Edit > Paste to place the contents of the clipboard (the last text or object you cut or copied)
back into the document, or to a different document.

Pictures and tables can be pasted in Text mode as well as Object mode. By pasting a picture or
table in Text mode, you can anchor it to the text. Call up View > Object mode to put TextMaker in-
to Object mode.

To: Press:

Paste Ctrl+V (or Shift+Insert)

PASTE SPECIAL

Use Edit > Paste Special to paste the contents of the clipboard into your document in a specific for-
mat.

If you copy text or pictures to the clipboard, the clipboard stores different formats or “repre-
sentations” of the same content. For example, text is often stored both formatted and unformat-
ted. Advanced applications paste the formatted representation of the text, simpler programs often
just paste text unformatted.

The Paste Special command lists the contents of the clipboard in all available formats, letting
you choose in which format to paste.

Paste Special is not needed under regular circumstances as TextMaker picks the most suitable
clipboard format automatically. There are some cases where Paste Special has the edge: for exam-
ple, when you copy formatted text to the clipboard, move the caret to another documentation, and
paste there. If you paste formatted with Edit > Paste, the text from the clipboard will keep its old
formatting. But maybe you wanted the text to take on the formatting around the destination posi-
tion—this is where Paste Special comes in handy, letting you paste unformatted.

DELETE

Use Edit > Delete to remove a selected object or delete selected text from your document.

SELECT ALL

Use Edit > Select All to highlight, or select, all text in the document or in the current text frame or
table cell. If you are in Object mode, the Select All command selects all objects on the current page
(but not those on other pages).

SEARCH & REPLACE

Use Edit > Search to search the document, including text frames, for specific text. Use Edit > Re-
place to replace the located search text with different text.
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Searching for text

The Search command searches through the document until it finds the first occurrence of the de-
sired text, and then it selects the text so you can edit it.

To search for text

1 Position the caret where you want the search to begin.

Move the caret to the beginning of the document (Ctrl+Home is the easiest way to do this) if
you want to search the document from beginning to end, otherwise TextMaker only searches
from the caret location to the end of the document.

2 Choose Edit > Search to display the Search dialog box.
3 Type the text you want to find in the Search For box.
4  Click the Search button to locate the text.

TextMaker scans the document for the search text, highlighting the first occurrence it finds. To
find the next occurrence of the search text, click the Search again button, or, if you closed the
Search dialog box, no need to open it again... just choose Edit > Search Again or press F3. This
command repeats the most recent Search command using the same text. Or choose the Search
command again; the last search text you entered always appears in the Search For box as a default.

Searching for tabs, returns and other special characters

You can search for tabs, paragraph breaks and other special characters in your document by
choosing them from the lists Format or Special. After you select them from either list, a special code
string will be inserted in the Search For field:

Search for: Special inserted code
Paragraph break "a
Line break "z
Tab “t
Any number “#
Any letter "$
Any character "?

I//\I/) AN

Caret (literal character

Search dialog box

Search and Replace [<]
Search | Replace |

Il Close
Format:

Reduce &

Optior:

[ Case-sensitive I Search from top

™ whele word ™ Search backwards
[ Search all frames

Reset I Format w | Special =
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Search For

Reduce, Enlarge

Case-sensitive

Whole Word

Search From Top

Search Backwards

Search All Frames

Search again

Close

Reset

Replace

Replacing text

TextMaker can search for any text you enter from the keyboard. Spaces are
okay, enabling you to search for more than one word at a time such as “There
was a moo cow coming down along the road.”

You can search for tab and new-line characters by choosing them from the
Special menu. This can be useful for removing extraneous new-lines from a
plain-text document. You could search for Paragraph breaks and replace them
with nothing.

In its default state, the dialog will show only major options for searching. If
you want to see all the available options, click on the Enlarge button. The dia-
log will be resized, and more options will become visible. Click Reduce to re-
turn to the previous state.

By default, the Search command is not case-sensitive. If you entered Moo cow
in the Search For box, for example, it would locate MOO COW or moo cow or
any other upper/lower case combination of the term, unless the Case sensitive
option is checked.

You can search just for whole words, or also for text embedded within other
words. If you entered win in the Search For box, TextMaker would locate win-
dows, winter, Irwin—any word with win in it—unless you check Whole Word, in
which case it would only locate the whole word win.

If you check this option, searching will start from the beginning of your docu-
ment instead of the current caret position.

TextMaker can search forward (to the end of the document) or backward (to
the beginning of the document) from the current caret location. By default, it
searches forward.

If you check this option, the Search From Top option changes to Search From
Bottom.

Check this option if you want TextMaker to search for text also in text frames
as well as in normal document text. If this option is not checked, TextMaker
ignores all text contained within text frames.

Click the Search button to begin the search. If TextMaker can’t find the search
text, it displays an error message telling you so. If this happens, you might
want to change the direction of the search and click Search again. If it still
doesn’t find the text, then it doesn’t exist in your document.

Click this button to close the Search dialog box.

Click this button to remove the search text and any character and paragraph
formatting attributes you may have specified from the dialog box. This makes
it easy to start over again with your search.

Clicking this tab changes the dialog box to the Replace dialog box, where you
can choose to replace the search text with replacement text you specify.

Suppose you are writing a report about Chinese customs, and you realize that you have typed Pe-
king throughout the document, rather than the more modern spelling Beijjing. You could have quite
a task ahead of you if you have to delete every occurrence of Peking and type Beijing in its place,
even with the help of the Search command. The Replace command can make this change for you,
and with only one step.

You can choose the Replace command from the Edit menu, or if the Search dialog box is al-
ready open, click the Replace tab.
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To replace text with revised text

1 Move the caret to the beginning of the document. (Ctrl+Home is the easiest way to do this.)

2 Choose Edit > Replace, or click the Replace tab in the Search dialog box if you have already
typed in your search text and want to replace it. The Replace dialog box appears.

Search and Replace [<]
Search | Replacs |
| Fioplaos

Farmat: Replace all

Replace with
I Close:

Format: Reduce =

Option:

" Case-sensitive ™ Seaich from top

I whole word I Search backwards
™ Search all frames

Resst | Fometw | Spedalw

3  Enter the text you want TextMaker to search for.
4  Enter the text you want to replace it with.

5 Optionally, specify character and paragraph formatting for either the search text or the re-
placement text, or both.

6  Click Replace.

TextMaker searches the document for the text you typed in the Search For box, and stops at
and highlights the first occurrence it finds. At this point, you have to decide if you want to replace
this particular occurrence with the text you typed in the Replace With box—TextMaker does not
replace it automatically—or move on to the next occurrence.

To replace the text, click the Replace button. To leave the highlighted text as is, and continue
the search, click Search again. Continue this process until the search is complete.

The Case-sensitive and Whole Word options work just as they do with the Search dialog box.

In the above example, you know that you want to replace every occurrence of Peking with
Beijing, without skipping any. It is thus a waste of time to replace one occurrence at a time. So,
click Replace All to change every occurrence of Peking to Beijing.

Searching and replacing formatted text

If you want to search and replace various character and paragraph formats, specify them using the
Format button in the Search and Replace dialog boxes. You can use TextMaker to search for text
formatted with one attribute (italics, for example), and replace it with text formatted with a differ-
ent attribute (bold, for example). You don’t even have to search and replace specific text; you can
search and replace just the formatting attributes themselves. For example, you could search for
any underlined text and make it italic, or search for text formatted with one font and change it to a
different font.

Formats for the Search For and Replace With boxes are set independently of each other, that
is, if you want to search for Bold text, click in the the Search For field, then click on Character
under the Format menu and choose Bold; if you want to replace it with italic text, click in the Re-
place With field, then click on Character under the Format menu and choose Italic. Notice that
any formats you specify are listed directly under the Search For and Replace With fields to remind
you that formatting options are in effect.
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If TextMaker can’t find text...

If TextMaker reports that it can’t find text, and you are positive it exists, you may have specified
formatting attributes. For example, if you've told TextMaker to search for the word “duh” in
italics, it will not locate any occurrences of “duh” that are not italicized. If you want it to search for
(or replace) all occurrences, click the Reset button before searching.

To: Press:
Search Ctrl+I
Replace Ctrl+H

SEARCH AGAIN & REPLACE AGAIN

Use Edit > Search Again to repeat the last Search command you issued. TextMaker searches for
the next occurrence of the text you entered in the Search dialog box.

To: Press:
Search Again F3
GO TO

Use Edit > Go To to move the caret to a particular page, chapter, footnote, object, or to a named
bookmark location.

Bookmarks are locations you can set throughout your document, and refer to them by name.
Bookmarks provide a convenient method for navigating between various locations in your docu-
ment, especially long documents such as manuscripts or reports. To insert a bookmark at the cur-
rent caret location, use the Insert > Bookmark command.

When using the Go To command to jump to a specific page, you can enter either a standard
page number—for example, 13, 21, 34, etc.—or a chapter/page number combination, for example,
2-3, 5-8, etc. The number before the hyphen is the chapter number; the number after the hyphen
is the page number (relative to the chapter).

Using the Go To command to go to a page number takes you to the top of the specified page.
Using the Go To command to go to a bookmark takes you to the exact location on the page where
you inserted the bookmark.

Go To dialog box

1 oK. |
Enter a page number between 1 Cancel
and 1
Previous
Hest

Select the type of element you want to go to in the left list. Available elements are page number,
chapter number, bookmarks, footnotes, footnote text, and objects. After that, the input field on
the right lets you select the specific element to go to. The Previous and Next buttons move the
caret to the previous or next occurrence, respectively, of elements of the same type.
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Select a bookmark from the list, or enter a page number, then click OK. Bookmarks are created us-
ing the Insert > Bookmark command.

To: Press:
Go To F5
GO TO LINK

You can format, with Format > Character, parts of your text to contain hyperlinks to bookmarks in
the document, or to external URLs (uniform resource locators, in plain English: Internet addresses
like http://www.softmaker.com).

When the caret is in text that contains a hyperlink, you can use Edit > Go To Link to follow the
link. If it is an internal link in your document, the caret is simply placed there. If it is an URL,
TextMaker switches to your web browser and instructs it to go to the URL in the hyperlink.

SORT

You can sort selected paragraphs with Edit > Sort.

To sort text

1  Select the paragraphs you want to sort.

2 Choose Edit > Sort.

3 Set the sorting order to ascending (A...Z) or descending (Z...A).
4  Click on OK to sort the paragraphs.

Some additional options are available:

Sort by In most cases, you want the selected paragraphs to be sorted alphabetically by
the first word in the paragraph. However, if you have text that is separated by
some clearly identifiable separator (a tab or a semicolon, for example)-like a
list of “name;firstname;address;zip;city”-, you can also specify to sort by the
second, third, or n-th column.

Then sort by There are cases in which the text you are sorting by contains duplicates. In the
name list example above, there might multiple Millers or Joneses. By selecting
additional columns here, you can specify the sorting order in these cases.

Separator This lets you select, in multi-column sorting, the identifier TextMaker uses to
split up the columns.

First Paragraph
contains Headings Switch this option on if the first selected paragraph contains a heading. In this
case, TextMaker will leave out this paragraph when sorting.

Case-sensitive Check this option if you want sorting to be aware of uppercase and lowercase
letters when sorting.

EVALUATE

Edit > Evaluate gives you a quick way to do simple calculations: Type in a calculation, select it, and
choose Edit > Evaluate. The result is immediately inserted in your document.
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Usage:
1 Type “The sum is: 90+55+220".
Select “90+55+220”.

2
3 Choose Edit > Evaluate or press F8.
4

TextMaker will calculate the sum for you and replace the calculation with the result in the
text.

LINK

Use the Edit > Link command to change a linked OLE object’s link status, such as whether it is to
be updated automatically in your TextMaker document whenever changes have been by the OLE
server application. This command is grayed unless you have inserted an OLE file into your docu-
ment with the Link option active. When you insert an OLE object into a document using the OLE
tool, you can choose to create a new object (which are never linked), or import an existing file cre-
ated by one of the OLE server applications (programs such as WordPad, Paint, or media objects
such as video or sound files, for example). If you choose the latter, that is, if you inserted an exist-
ing OLE file into your document, you can change its link status using the Edit Links command.

Links Choose the linked OLE object you want to edit or change its update link sta-
tus from this list. Any linked files you have inserted in your document appear
in this list.

Update There are two update options—automatic and manual. If the Automatic option
is checked, any changes made to the linked file by the server application ap-
pear automatically. If the Manual option is checked, changes you make to the
linked file do not appear in TextMaker until you click the Update Now button.

Update Now Click this button to update the linked file. Any changes made to it by the serv-
er application will be reflected when you close the dialog box.

Open Source Click this button to open the linked file and the server application that created
it, where you can make changes to it. For OLE to import an object properly,
the source application must be an OLE server, and your system must have
enough memory available for both it and TextMaker.

Change Source Click this button to insert a different OLE file into the same position in the
document as the current OLE file.

Break Link Click this button to sever the OLE link. The object remains in your document,
but is no longer treated as a linked file.

OBJECT

Use Edit > Object to edit a selected OLE object. If no OLE object is selected, this command is
grayed-out. If an OLE object is selected, the name of this command changes to reflect the type of
object, for instance, if a Paintbrush object is selected, the command name will be Bitmap Image
Object, and it will display a sub-menu containing commands for opening, editing, or converting
the object to a different format.

The easiest way to edit an object’s properties—including opening and editing an OLE object—is to click it
with the right mouse button, which displays a pop-up menu providing easy access to various editing com-
mands.
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waers | VIOW Menu Commands

The View menu contains commands for changing page display size, as well as options for turning
on or off the display of certain TextMaker tools.

TEXTMAKER DOCUMENT VIEWS

TextMaker has four distinct views in which you can edit your documents: Standard, Continuous,
Master Pages and Outline. Each view allows you to focus on different aspects of your work. For
example, the Master Pages view is where you would design the general page layout, including set-
ting up such items as snap-to guidelines, headers, footers, etc., that you want repeated on every
page. Continuous view is best suited for text editing and formatting. Outline view lets you concen-
trate on the overall organization of topics and ideas in your documents. Here you can move head-
ings and sub-heading around, and all the body text associated with them moves accordingly.

You choose which view to work in by selecting it from the View menu. A check mark appears
to the left of the active view.

Standard view

Standard view lets you see and edit all items on a page, such as text, graphics, guidelines, and
margins. This view most closely resembles the way the document will appear when printed.
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In Standard view (above) all document items are displayed, including snap-to guides, headers, footers, and

top and bottom margins. If you regularly work with graphic objects, text frames, and tables, Standard view
should be your default view, because you can switch between Text mode and Object mode in this view (you
can switch to Object mode in Continuous view, but doing so changes to Standard view).

Continuous view

Continuous view is the most efficient view for typing, editing, and formatting text. This view is
similar to Standard view except that top and bottom margins are not displayed in Continuous
view, you can’t edit footnotes, and you can’t create or move objects (although you can see them).
Horizontal and vertical guides are also not displayed in Continuous view; although switching to
this view does not delete them, they simply are not displayed.

The benefit to editing your documents in Continuous view is that you can scroll through pages
more quickly, and your document text will appear as a continuous stream, making it easier to edit
text across page breaks, which appear in Continuous view as thin gray lines.
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In Continuous view (above), document items such as snap-to guides, headers, footers, and top and bottom
margins are not displayed. Page breaks are displayed at thin gray lines, and text appears as a continuous
stream. If you primarily use TextMaker to type and edit text, Continuous view should be your first choice.

Master Pages view

Use View > Master Pages to create and edit master pages. A master page typically contains design
elements such as headers, footers, and page numbers, for example, that will repeat on all pages of
your document. Other items you might want to place on master pages are horizontal and vertical
guidelines, background graphic images, or letterhead items such as company name and address,
for example. Master pages can save time and ensure consistency across pages in your document.

Objects are created on master pages by first selecting View > Master Pages. Any object added
to a master page will be repeated on every page of the document, regardless of which page you are
currently editing when you choose the Master Pages command. After placing items on master pa-
ges, you can also edit them from any location in your document simply by choosing View > Master
Pages.

When you switch to master pages, all body text and objects placed on individual pages disap-
pears and only Master Page objects are visible. In a new document, it may not be immediately ob-
vious that you are on a Master Page, since there is no body text to disappear. In fact, it is not pos-
sible to enter body text on a master page. You can create text frames, headers, and footers, and en-
ter and edit text in them, but it is not possible to click the text tool on the page and begin typing as
you can in Standard view.
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Master Pages (above) are where you create items you want repeated on every page of your document, such as
headers, footers, pages numbers, and snap-to guides. You can have multiple master pages in the same docu-
ment by inserting chapter breaks (see the Chapter command under the Format menu, and the Insert > Breaks
> Chapter command). You can switch to Master Pages view from any page in your document, but you cannot
edit normal document text in this view.

Outline view

Use View > Outline to view your document in a hierarchical fashion, displaying each paragraph
according to its outline level. You can change the outline level of paragraphs in this view (outline
levels can also be assigned to paragraphs from the Format > Paragraph command). This helps fo-
cus and organize your thoughts, aiding the creation of structured documents.

For more information regarding use of the outliner, refer to the Outliner chapter in the Tips &
Techniques section of this manual.
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ACTUAL SIZE

Use View > Actual Size to set the page display to the size it will be when printed. This is the de-
fault view.

The following example shows a sample document as it might appear at actual size:
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A check mark appears next to the Actual Size command when you select it, indicating that it is
the current view.

FIT PAGE IN WINDOW

Use View > Fit Page In Window to set the page display so that an entire page fits in the window.
This is useful as a print preview, which you may be familiar with from using other programs, but
unlike other programs, the Fit Page In Window view is completely editable. It is not restricted to
simply viewing the document.

The following example shows a document as it might appear when Fit Page In Window is se-
lected:
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A check mark appears next to this command when you select it, indicating that it is the current
view.

FIT MARGINS TO WINDOW

View > Fit Margins To Window adjusts the view so that the distance between the page margins fits
within the width of the window.

100M

Use View > Zoom to change the view size of a page from its current size to a larger, custom size.
The cursor changes to a magnifying glass, which you can use to “zoom in” on any portion of the
document.

To zoom to a custom size, choose Zoom from the View menu, or click the Zoom button in the
toolbar and move the mouse to the position in the document you would like displayed in the
upper left-hand corner of the window. Press the left mouse button and drag the mouse down and
to the right. Drag the mouse so that the rectangle encloses the area you want to zoom in on. When
you release the mouse button, the view scale and position is set so that region fits within the win-
dow.

CUSTOM

Use View > Custom to select a view size from a list of commonly-used sizes, or enter a view size of
your own. Choosing this command displays the Zoom dialog box:
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t page o)
Fit rnargins to window Cancel
Previgus zoam level

200%

150%

100%

75

0%

Select a view size from the list, or type a view size and click OK. Custom view sizes you enter must
be in the range of 30-1000%.

OBJECT MODE

Use View > Object mode to switch TextMaker between editing modes. A check mark appears next
to this command when you are in Object mode.

Choosing this is the same as clicking the Object mode button on the Format strip. You can also
toggle between Object mode and Text mode by clicking the right mouse button, which displays a
pop-up menu where you can choose the opposite mode of the mode you are currently editing.

Text mode is the default mode. This is where you enter, edit, and format text. Whenever you
open a document, or create a new one, it is automatically set to Text mode.

Object mode is where you create and manipulate objects such as pictures, frames, and guide-
lines, for example.

It may be useful to think of Text mode as word processing mode—this is what you'll spend the
majority of your time doing—and Object mode as desktop publishing or page layout mode.

FORMS MODE

You can use TextMaker to create fill-out forms containing edit fields, check boxes, and drop-
down lists. Forms can then be saved as a file and filled out by another person. In most cases, you
wouldn’t want others to change static parts of the form like explanatory text. Switching to Forms
mode makes this impossible: In Forms mode, only edit fields, check boxes, and dropdown lists
stay editable; all other parts of the document are protected against changes and deletion. Also, in
Forms mode you can easily switch from one entry field to the next (and back) with the Tab and
Shift-Tab keys.

To create a form that is protected against accidental changes, create the form first by placing all
text and edit fields, check boxes, etc. where they belong, then turn on Forms mode, and save the
document. When the document is opened again, Forms mode is still active, and the form can be
filled out safely.

When TextMaker is in Forms mode, the caption of your document changes to indicate this
fact.

If you do not want users to be able to make changes to your form by simply turning off Forms mode, you can
assign a Forms password in the File > Properties > Forms dialog.

CONTROL STRIPS

View > Control Strips opens a dialog in which you can activate and deactivate control strips, cre-
ate new control strips, set their position and edit what buttons they contain.

HORIZONTAL RULER

View > Horizontal Ruler shows or hides the horizontal ruler.
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mers | FOFMat Menu Commands

The Format menu contains commands for changing the appearance of text and paragraphs, as
well as commands for editing section and chapter properties.

CHARACTER

Use Format > Character to change the character formatting attributes of selected text, or to set the
attributes for new text you type. Character formatting attributes consist of typeface selection (font
and font variations such as bold, italic, etc.), font size in points, underlining options, and position
and spacing options (superscript, subscript, spacing, and pitch). Choosing the Format > Character
command opens the Character dialog box, which is divided into three tabs: Font, Spacing, and

Link.

Character dialog box: The Font tab

Character
Font | Spacing I Link, I
Typeface: Size Text colour
- j10 =] |EEBlack hd
, Backaround colour;
I lalic I~ Allcaps D reperen 2]
I Bol ™ Small caps: % | Language
o Etr:zagut r glink" ? l_ English [US] -
I Hidden ™ Erotected Underline !
S ™ Continuous
™ ward
A B ey ez @ Single
" Double
Beset Cancel

Typeface Choose from a list of fonts installed in your system.

Size You can either select a point size from this menu, or type in any size between
1 and 999. You can enter point sizes in one-tenths steps, like 9.5 or 10.1.

The unit of measurement for fonts is points. The higher the number, the larg-
er the font. There are 72 points in an inch, so a 36 point font, for example,
would be approximately one-half inch in height.

Text Color Choose from a list of colors you can apply to text. The last item in this list is
Define Colors. Choose this option to open a dialog box where you can set up a
user-defined color and assign it a name. The new color will then appear in all
color menus.

Background Color Choose from a menu of colors you can apply to the background of the selected
text. The Background Color setting does not shade the whole paragraph, like
Format > Paragraph > Shades does. It works like a “highlighter” instead, shad-
ing only individual characters.

Language For on-the-fly spell-checking and automatic hyphenation to work, you must

tell TextMaker which language you are writing in. Here, you can set the lan-
guage to use for the proofing tools. Either pick a specific language from the
list, or select Standard—in the latter case, TextMaker picks up the language set-
ting from Extras > Preferences > Language.

You can also set the language to None. In this case, TextMaker will neither
spell-check nor hyphenate this passage of text. This is useful for highly-techni-
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Style

Underline

Sample

Reset

cal parts of your document with many words the spell-checker does not know,
or for writing in languages for which TextMaker has no proofing tools.

Check an option, or any combination of options, for the available type styles
bold, italic, strikeout, hidden, all caps, small caps, blink and protected.

Most styles are probably obvious, but hidden, blink, and protected deserve spe-
cial mention:

> Blinking text is just that, text that flashes on screen. This is useful for ex-
porting to HTML. Please note that TextMaker, however, does not flash
the text on screen but just displays it in a different color (usually yel-
low, unless you have set a different color in File > Properties >
Internet).

» Hidden text is text that will not appear on the screen and/or in the ac-
tual printout. This can be useful for adding annotations to a document
that should not appear in the final printout, for example. TextMaker’s
behavior regarding printing and displaying hidden text can be set in
File > Properties > View.

» Protected text is text that cannot be accidentally changed. To change it,
you must first remove the Protected style.

There are two different types of underlining attributes: continuous underline
and word underline. Continuous underline (which is the underlining option
you can choose from the Format strip) underlines text, spaces, and tabs. Word
underline does not underline spaces or tabs. For either underlining option,
you can specify whether you want the underline to be a single or double line.

The Sample area displays a sample of the currently selected formatting op-
tions, letting you see the effect of your formatting choices before applying
them.

Clicking the Reset button returns all character format settings to the current
character style.

Character dialog box: The Spacing tab

Character
Font | Spacing | Link |

~Super/Subscript———————————————————

I Bupersornl Rastor | %

r Subscript Size; E4

~Spacing

Armount: 100

PBitch: 100

rSampl

AaBhCexVyZz

Fieset Cancel

Super/Subscript  Choose Superscript to move text above the baseline (an imaginary line where

characters rest); choose Subscript to move text below the baseline. If neither
option is selected, text is positioned on the baseline.

The Position value determines how much, relative to the normal text height,
text should be moved up or down. 20% is the default. The Size value lets you
specify whether super- or subscripted text should be reduced in size. The de-
fault value of 80% means that text will be reduced to 80% of its original size,
e.g., if the point size is 10 points, super- or subscript text will appear as 8-
point text.
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To return text to its normal position on the baseline, select it and un-check the
Superscript or Subscript options.

Spacing In addition to adding space between letters and words by pressing the space-
bar, TextMaker lets you adjust spacing in fractional amounts. Each character
in a font is surrounded by a certain amount of space. Otherwise, letters would
all run into one another and legibility would be very poor. You can expand or
condense this space by entering a value in the Amount box. 100% is the de-
fault, and is the equivalent of no extra spacing at all. Values less than 100%
will decrease, or condense, the amount of space between letters and words;
values greater than 100% will increase, or expand, letter and word spacing.

TextMaker also lets you alter the width of the characters themselves (as op-
posed to just the space between them) by entering values in the Pitch field.
Values greater than 100% increase the width of individual characters, stretch-
ing them horizontally; values less than 100% decrease the width; compressing
characters horizontally.

Character dialog box: The Link tab

Character
Font I Spacing I Link, |
URL or file name:
Baookmark:; Browse..

The Link tab lets you create and edit hyperlinks. Hyperlinks are what you see in a web brows-
er: Text that is underlined, indicating that you can click on it to follow the link to a bookmark in
your document, to a different file, or to an Internet-based URL (Uniform Resource Locator, for ex-
ample http://www.softmaker.com).

In this tab, you can specify the URL, file name or bookmark to jump to when the link is fol-
lowed by the user. To follow a link in TextMaker, the user sets the caret into the text and selects
Edit > Go to Link, or right-clicks into the text and chooses the Go to Link command from the pop-
up menu that appears.

Hyperlinks are also exported to HTML, and in a web browser, simply clicking on a link brings
up the corresponding web page.

STANDARD

Use Format > Standard command to reset all changes made by formatting characters back to the
default. Select the paragraphs you want to return to their default formatting and call up this com-
mand—TextMaker will then remove all character formatting.

Paragraph formatting and character formatting from paragraph styles are not affected by this
command.
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To: Press:
Standard Ctrl+Space
PARAGRAPH

Use Format > Paragraph to change the paragraph formatting attributes of selected text, or set the

attributes for the current paragraph. Paragraph formatting attributes are applied to entire para-

graphs, rather than single characters or words. Alignment, indents, line spacing, tab placement,
etc., are examples of paragraph formatting attributes. Choosing the Paragraph command opens
the Paragraph dialog box.

Paragraph

Tabs Cancel |
Always 'I Bullets... Reset I

rIndent

Left 0 iy

Right: Oin

First: Qin

7 Alignment

Left = I

Hyphenation

Outline level IU

Shades...

r-Line spacing

- Pagination
™ Column break
I™ Page break

Borders..
Drop caps

rParagraph spacing

r Typography

™ Keep with next
™ Keep together
I™ Widows/arphans

Before: Opt

Autar =] 100
After: leI—

Indent

Line Spacing

Enter values in these boxes to control the amount of space between a para-
graph and the left or right margin. By default, paragraph indents are lined up
on the margins, i.e., set to 0.00 inches.

There is a key difference between margins and indents: margins control the size
of the page and remain the same for each page in the document; indents con-
trol the width of paragraphs and can change from paragraph to paragraph. In
other words, margins are a page formatting attribute, while indents are a para-
graph formatting attribute.

See the section “Changing paragraph indents” later in this chapter for more
information about indent settings.

Line spacing is the vertical distance between lines of text in a paragraph, and
is controlled by two factors: the size of the font, and the line space value, also
known as leading, specified for the paragraph. A line spacing value of 100%
means no additional spacing beyond that built into the font itself. Entering a
larger value increases the space between lines. You may find a leading value of
100%, for example, to be the optimal leading for many text fonts. Using this as
your guideline, a value of 150% would be the equivalent of one and one half
lines of spacing; 200% would be approximately equal to double line spacing,
etc.

TextMaker also supports two additional line spacing systems, Exactly and At
least. With these, you do not specify the spacing relative to the point size but
in absolute values (pt, points). Exactly means what it says: Regardless of the
font size, the line spacing is set to a fixed amount. At least sets a minimum val-
ue for the line spacing; if some text in the paragraph is larger than this, Text-
Maker ignores this minimum value and uses the line spacing built into the
font.

Paragraph Spacing You can also add spacing, in inches, centimeters, or points, between para-

graphs. To add extra space between paragraphs, enter values for the amount
of space you want above or below the current paragraph or selected para-
graphs in the Before and After boxes. These values do not affect the amount of
space between lines within a paragraph, just before and after it.
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@& Use the Before and After spacing options to add space between paragraphs rather than adding blank lines
after each paragraph. For example, enter a value of 10 points in the After field for the equivalent of a blank

line.

Alignment

Choose options from this list to apply left or right alignment to a paragraph,
or to center or justify it.

Left-aligned paragraphs have an even left edge, and an uneven, or ragged,
right edge. Left-alignment is the default for new paragraphs.

Right-aligned paragraphs are even with the right paragraph indent, but have a
ragged left edge.

Center-aligned paragraphs are centered between the left and right indents.

Justified paragraphs have both an even left and right edge. For justified para-
graphs, TextMaker adjusts the amount of space between words so that each
line of the paragraph is even with both the left and right paragraph indents.
Depending on the size of your margins, the position of the paragraph indents,
and the font size, text may appear too tight or too loose. Spacing of justified
text may be more consistent if you hyphenate text using TextMaker’s auto-
matic hyphenation.

Since alignment is the most commonly changed paragraph formatting attrib-
ute, buttons for the four different types of alignment also appear on the con-
trol strip.

@ Remember that paragraph alignment is relative to the paragraph indents, not the edges of the page, and not
necessarily the margins either.

Hyphenation

Choose one of three types of hyphenation from the list—Always, Every 2 Lines,
or Every 3 Lines.

The Always option hyphenates eligible words at the end of each line (if neces-
sary). The Every 2 Lines and Every 3 Lines options hyphenate eligible words,
but make sure that at least two or three non-hyphenated lines appear between
each hyphenated line. In most cases, Always provides the best hyphenation
for a paragraph. But for some paragraphs, too many hyphenated lines may
look awkward-the right side of the paragraph looks like a ladder. If this hap-
pens, try using Every 2 Lines or even Every 3 Lines.

To understand automatic hyphenation, compare it to manual hyphenation:
you can manually hyphenate words by typing a “-” (hyphen key) at the posi-
tion you want the word to break. For example, if near the end of a line you
type the word “misanthropic,” but it wraps to the next line, you could try typ-
ing a hyphen between “misan” and “thropic” so that the first part of the word
fits at the end of one line, and the second part of the word begins the next
line. This method is labor-intensive and error-prone: if you edited the text or
changed the formatting in a way that caused line breaks to change, you run
the risk of hyphens occurring in the middle of a line (“misan-thropic”).

TextMaker can automatically hyphenate eligible words in a paragraph to im-
prove line breaks. By choosing one of the three types of automatic hyphena-
tion, you don’t have to worry about words being hyphenated before the end
of a line. With automatic hyphenation on, if you cause a hyphenated word to
wrap to the next line by adding text before it, TextMaker automatically re-
moves the hyphen, and, if necessary, adds one to the next eligible word.

- Soft hyphens, also called discretionary hyphens, are different from hyphens you type with the hyphen, or mi-
nus, key. The latter are also called “hard” hyphens because they appear even when the word does not fall at
the end of a line. Soft hyphens, on the other hand, only appear at the end of a line.
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TextMaker’s hyphenation routines are highly reliable, but may err or cause aesthetically un-
pleasing hyphenation in rare cases. In these cases, you can suggest a better place for hyphenation
by inserting a soft hyphen. Soft hyphens are inserted by pressing Ctrl+Minus. If a word contains
one or more soft hyphens, these will be the only places TextMaker considers for hyphena-
tion-automatic hyphenation is turned off for this word. You need not remove unneeded soft hy-
phens as TextMaker will only make them visible if they are needed. If a word is positioned in the
middle of a line, for example, soft hyphens are invisible.

To: Press:
Insert a soft hyphen Ctrl+Minus
Outline Level Any paragraph can be assigned an outline level. Paragraphs with outline lev-

els 1 through 9 are treated as headings, 1 being the topmost heading level.
Paragraphs with an outline level of 0—the default outline level—are treated as
normal body text. Outline levels are used for auto-numbering fields (see the
Field command under the Insert menu for more information) as well as in
Outline view. See the description of the outliner in the Tips & Techniques
chapter of this manual.

Pagination Click Column Break if you want the paragraph to begin a new column (multiple
columns must first be specified with Format > Section before this will have
any visible effect); click Page Break if you want the paragraph to begin a new
page. A page break will be automatically inserted immediately before the
paragraph, regardless of its position on the page.

Keep With Next  Check this option to ensure that the last line of a paragraph stays with the first
line of the following paragraph.

Keep Together Check this option to prevent the paragraph from breaking between pages or
columns.

Widows/Orphans Check this option to ensure that no less than two lines of a paragraph will ap-
pear at the top or bottom of a column or page.

Character Click this button to open the Character dialog box where you can choose char-
acter formatting attributes to be applied to the current paragraph. (See the
Character command section in this chapter for more information.)

Tabs Click this button to open the Tabs dialog box. See the Tabs command later in
this chapter.
Reset Click Reset to return all formatting options to the default state as determined

by the current style.

Bullets Click Bullets to open the Bullets dialog box where you can create different
types of bulleted or numbered paragraphs. See the Bullets command later in
this chapter for more information.

Shades Click Shades to open the Shades dialog box where you can select different
shades, patterns, and colors to apply as backgrounds for paragraphs. See the
Shades command later in this chapter for more information.

Border Click Border to open the Paragraph Border dialog box where you can control
the placement and style of paragraph border lines. See the Border command
later in this chapter for more information.

Drop Caps Click Drop Caps to open the dialog box for setting up drop caps-large initial
characters in a paragraph. TextMaker provides an easy way to create drop
caps. All you have to do is click the Drop Cap button. TextMaker automati-
cally adjusts the baseline of the first character in the paragraph (regardless
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whether text is currently selected or not) in such a way that it falls below the
baseline of the first line, or even the first few lines, of the paragraph. Initial
drop caps are by default set using the current font to a size of 24 points. You
can change both the font as well as the size of the drop cap character. To
change the size, enter or select a point size from the Point Size menu, or click
the Drop Cap Character button, where you can then change both font and
size as well as other attributes.

After you have created a drop cap, you can change it by opening the Drop
Cap dialog box again, or you can simply format it as you would any other
character in your documents.

TABS

Use Format > Tabs to set tabs and alter their position and alignment. Tabs are used to move the
caret to a specific location without using the spacebar. Tabs are useful for lining up text or num-
bers in tables, or for aligning text to a specific location in the document. Initially, left-aligned tabs
are positioned every half inch from the left margin to the right margin. You can replace these pre-
set tabs by adding your own.

When you are typing text and want to move the caret to a tab stop, press the Tab key on your
keyboard. The caret jumps to the right to the nearest tab.

Tab settings are paragraph attributes, meaning that each paragraph in your document can have
different tab settings. Some paragraphs may only need one tab stop—for example, a decimal
aligned tab near the right side of the page for entering numbers. On the other hand, some para-
graphs, such as a table of numbers, may require multiple tab stops.

TextMaker lets you create four different types of tabs: left, right, centered, and decimal
aligned.

There are two ways you can create and edit tab stops: on the ruler using the mouse, or from
the Tabs dialog box.

Tabs dialog box

Tabs

Tabs Alignment

Tab leader: Clear Cancel
Nore I8 Clgar Al

Defalt widthe LI

naan 5

The Tabs dialog box provides the most control for creating and editing tabs. You can access the
Tabs dialog box either by choosing the Tabs command from the Format menu, or by clicking the
Tabs button in the Paragraph dialog box.

The Tabs box lists the position and alignment of each tab on the ruler, starting from the left. A
tab’s position is measured from the left margin: if you change your margins, all tab stops are ad-
justed automatically.

To add a new tab using the Tabs dialog box

1  Choose Format > Tabs, or click the Tabs Button in the Paragraph dialog box.

2 In the Tabs box, enter the position in inches—relative to the left margin—where you want to
place a tab. You can specify a tab’s position to 1/100ths of an inch (two decimal places).

3 Choose an alignment type from the Alignment box. The default is Left, but you can also choose
Right, Center, or Decimal.
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4  Click the Set button. The tab is added to the list. You can add as many tabs as you need fol-
lowing the above steps.

5 Click OK to close the dialog box and add the new tabs to the ruler.

You can change the position and alignment of existing tabs from the Tabs dialog box anytime.
For example, say you placed a right-aligned tab on the ruler, but want to change it to a decimal
tab. You can accomplish this from the Tabs dialog box:

To change tab alignment using the Tabs dialog box

1  Choose Format > Tabs, or click the Tabs button in the Paragraph dialog box.

2 Click the tab you want to change from the Tabs list box. The selected tab’s current alignment
option is indicated in the Alignment box.

3 Select a different type of alignment.

4  Click the Set button. You can change the alignment of as many tabs as you need following the
above steps.

5 Click OK to close the dialog box and update the ruler with the changes you made.

To remove tabs from the Tabs dialog box, highlight the tab from the Tabs list, and click the
Clear button. You can remove all tabs by clicking the Clear All button. Click OK to close the dialog
box and update the ruler with the changes you made.

BULLETS AND PARAGRAPH NUMBERING

Use the Bullets command to create bulleted or numbered paragraphs. Bulleted paragraphs can be-
gin with round, diamond, or character bullets. Numbered paragraphs begin with consecutive
numbers, the style of which you may freely define.

Bullets and Numbered Lists dialog box
Bullets and Numbered Lists

& Fioes Horz. Positiar: 0.25in
Rl

" Bullet Wert. Position: Oin Cancel |
@ e oo [MMBsck 5]

sous SOTOTO[R[T] 5ol
Custom E‘I@"E”EHT":I Cfigrgs... |

Bafore Format After

-Mumber

[rza. = | Chayacter.
Mumber starts with: 1. ™ Skip numbering
Type Select the type of bullet or numbering you want. The available types are:
» None—No bullets or numbers are used.

» Bullet—Check the Bullet option at Type and then click one of the Default
or Custom bullets. Then enter a custom size in the Size field.

» Number—Check the Number option at Type, then select the numbering
style in Format. Optionally, enter text that is to appear Before and/or
After the number. If you do not want your numbers to start 1, enter a
different value in Number Starts With.

Horz. Position Specify the distance to the left of the paragraph where you want the bullet to
appear.
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Vert. Position

Color

BORDERS

Specify the vertical position relative to the default position where you want
the bullet to appear. A zero value results in the default position. A positive val-
ue moves the bullet up and a negative value moves the bullet down.

Select a bullet color from this list of standard colors. The last item in this list is
Define Colors. Choose this option to open a dialog box where you can set up a
user-defined color and assign it a name. The new color will then appear in all
color menus.

Use Format > Borders to create border lines around paragraphs and objects. TextMaker lets you
create several styles of borders, as well as controlling their placement relative to the text.

Paragraph Border dialog box

Paragraph Border

Borders I

Line style:

Sinale
Double

Thitkness 1

Thickness 2

1ot 3pt
oipt—E s —E
05p — 2pt —
Tt — . Mesp—

15pt— [l 2 — [

Clearancs

Lete [3or |
Bight [3p | ’ <
Top [2pt |
Bottom: [3pt |

rSampl

Eounds:

I Inderts 2 > <

Color

Separation: |2 Pt

[ Elock =

Line Style

Thickness 1, 2

Separation

Clearance

Bounds

Color

Sample

Choose a line style from this list. The available styles are No line, Single line,
and Double line.

Choose from one of the pre-defined line thicknesses or enter a value of your
choosing. If a single line has been selected, only the first thickness is used. If a
double line is selected, you may set the thickness of each line as well as the
distance between lines.

If you have selected the Double line style, you can specify the distance between
the two lines.

Specify the distance between each edge and the paragraph text.

Choose Margins if you want the border to extend to the page margins. Choose
Indents if you want the border to extend only to the paragraph indents.
Choose Text if you want the border to surround only the text within.

Choose the color you want for the border from the list of standard colors. The
last item in this list is Define Colors. Choose this option to open a dialog box
where you can set up a user-defined color and assign it a name. The new color
will then appear in all color menus.

This field serves two purposes: first, it displays an example of the currently
chosen border; second, it is used to specify which edges will be affected when
an additional line style is applied. The inward-pointing arrows are used to
mark the edges that will be affected. You can select an edge by clicking it with
the mouse. Multiple edges can be selected by holding the Shift key down
while you click.

The outer edges (the top, bottom, left, and right) may be selected by clicking on the interior of the sample.
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LINES

Use Format > Lines to choose a line thickness and type for objects (lines, rectangles, ellipses, pic-
tures, OLE objects).

This command is only active when you are in Object mode or when a suitable object is selected.

Lines dialog box

Rectangle

Format | Propetties | Lines | Shades |

Line style:
Nane

Double
Thickness 1:

Thitkness 2

rSample

Choose the line type you want. You may choose to have No Line, Single line, or

Choose from one of the pre-defined line thicknesses. If a single line has been
selected, only the first thickness is used. If a double line is selected, you may
set the thickness of each line as well as the distance between lines.

1 pt 1 pt

oipt— & [ore —E

i |

ipp —

15pt— = 150 — ]

Senataon |1D.—

Color:  [EBlack B

Cancel
Line Style
Double line.

Thickness

Use Format > Shades to apply a shade or fill pattern to an object or a paragraph.

Shades dialog box
Shades
Shades |
[Lve Shad Sampl
:‘:Ejﬂone: l:l l:l l:l
= | .
€ Pattem - - -
Faten Foreground.
=N
[[m]]] E @ Bélkgmund
Cancel

Shades

Patterns

Foreground Color

Click one of the pre-defined shades, or enter any custom shade value from 0
(white) to 100% (solid color).

Click one of the pre-defined fill patterns.

If you have selected a shade, this field specifies the color for the shade; if you
have selected a pattern, this field specifies the color to be used for the fore-
ground portion of the pattern.
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The last item in this list is Define Colors. Choose this option to open a dialog
box where you can set up a user-defined color and assign it a name. The new
color will then appear in all color menus.

Background Color If you have selected a pattern, this field specifies the color to be used for the
foreground portion of the pattern; if you have selected a shade, this field is not
available.

CHAPTERS AND SECTIONS EXPLAINED

» A chapter is a part of your document that has a unique page size and orientation.
If you want to change page size, paper bins, or orientation halfway through your docu-
ment, split up the document into multiple chapters by inserting chapter breaks through In-
sert > Breaks > Chapter Break.

» A section is a part of your document with a unique number of columns.
If you want to create a document with different column settings, you split up this docu-
ment in multiple sections by inserting section breaks through Insert > Breaks > Section
Break.

A document may contain multiple chapters, with each chapter containing multiple sections.

CHAPTER

Use Format > Chapter to set up chapter-specific settings.

A chapter is a part of your document that has a unique page size and orientation. If you want to
change page size, paper bins, or orientation halfway through your document, split up the docu-
ment into multiple chapters.

The Chapter dialog box lets you specify the page and chapter numbering system and control mas-
ter page behavior.

Chapter dialog box
Section =]
Columpns———————————
Humber: E —
Gutter: Im |
Height: m
Line between | Apply o

™ Bestart auto numbers I” Page break

Chapter Number You can either set a specific chapter number here or let the system automati-
cally increment it from the previous chapter. The chapter number is available
as an inserted field through Insert > Field.

Page Number You can number pages incrementally starting with 1 for the first page in the
chapter, or assign a different starting number. This is useful if your document
is part of a series of documents, and you require consecutive page numbering
from one document to the next. Use the Value option to specify a starting page
number other than 1.

You can insert page numbers in your document through Insert > Field.

Chapter starts on If you are creating a multi-chapter document, you might want to have all new
chapters start on a right page (like in many books). Instead of fiddling with
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manual page breaks, simply instruct TextMaker to do this automatically by
setting Chapter starts on to Right page. Alternative options are Left page and Ei-
ther page.

Master Page You can enter the page number from which on master pages are displayed
and printed. Master pages contain items such as headers and footers, and you
might not always want them to begin on the first page. Perhaps the first page
of your document is a title page, for example, and the main document begins
on page 2. You would use this feature to begin displaying master pages on

page 2.

Facing Pages Check to use the Facing Pages option. After turning on Facing Pages, two
things will happen: TextMaker will create separate Master Pages for left and
right pages in your document, and the Inside Gutter option becomes available.
The value you enter here is the distance between each page and the bookbind-
ing: it is applied to the right of left pages and to the left of right pages.

Page Setup This button displays the Page Setup Dialog, letting you set up page size, paper
bin, page margins etc. for the current chapter—it is the same dialog that you
choose from File > Page Setup.

SECTION

Use Format > Section to format text in multiple columns.

A section is a part of your document with a unique number of columns. If you want to create a
document with different column settings, you split up this document in multiple sections by in-
serting section breaks through Insert > Breaks > Section Break.

The Section command also provides a way for you to restart any auto numbers you may have
inserted in your document.

TextMaker lets you control the number of columns (you can create up to eight), the amount of
space between columns (called the gutter), and the height of columns. TextMaker even has an Auto
column height option for making all the columns in a section the same height, ensuring that one
column doesn’t run the length of the page, while another column is only a few lines high.

Section dialog box

Chapter number—  ~Chapter starts on————

& dncrement I " Right page
 Value € Leftpage L&‘I

&+ Either page

Page Setup.._ |

£ Inciement b Master page

© vale[ ’VQIarts onpage [ ‘

‘ ™ Eacing pages ‘

sz autter | 0in

Number Enter the number of columns for the section. You can have between 1 and 8
columns.

Gutter Enter the amount of space you want between columns.

Height Enter the height of the column. You can choose a fixed height, or choose Auto,

in which case the height of the columns is determined by the amount of text.
In other words, the columns will be automatically balanced. Choose Page
Height to make the column height equal to the height of the entire page.

Line Between Click this button to open the Lines dialog box where you can specify the style
of the line (if any) that is drawn between columns.
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Apply To If you have text selected, you can choose to apply your changes to the selected
text, the selected sections, or to the whole document. If no text is selected,
you can apply your changes to the current section, from the current position
to the end of the current section, or to the entire document.

Restart

Auto Numbers Click this option if you want auto numbers (see the Field command in the In-
sert menu) to be restarted at the beginning of the current section.

CHARACTER STYLE

Use Format > Character Style to select from a list of defined character styles, or to create and mod-
ify character styles.

Character styles are a collection of character attributes (font, size, type style, etc.) that you can
name, save, and later apply to text. When you choose a character style, all the attributes that make
up that style are applied to the selected text at once. In other words, you wouldn’t have to apply
several character formatting attributes individually to text in your document. All these changes
would take place at the same time, in one stroke, simply by selecting a character style.

Character styles can also be applied by choosing them from the Font list box on the Format
strip. Character styles are distinguished from fonts in this box by being preceded with the circle-S
symbol.

Character Style dialog box

Character Style [ x]
Appl)
Homl _ o |

Closs

Edit..
Delete
Bename..

Choose the style you want to apply from the list and click Apply to format the selected text with it.
If no text is selected, this will set the character style for new text you type from the current caret
location forward.

New Click this button to define a new character style. Give the new character style
a name and the Character dialog box is shown, letting you define the new
style.

Edit Click this button to open the Character dialog box where you can modify ex-
isting styles.

Delete Click this button to remove an existing character style from the list.

Rename Click this button to rename an existing character style.

To define a character style

1 Choose Format > Character Style. The Character Style dialog appears.
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Paragraph Style E

Bename...

2 Click the New button. A dialog where you can specify a name for the new character style ap-
pears, and then the Character dialog box comes up. This Character dialog is essentially the
same as the normal Character dialog box, but with a new Style tab.

3 Select the desired font for your new style and change any other formatting options such as
point size, color, etc.

4  Click the OK button when you are satisfied with your choices.

The style you just defined now appears in the Style Name list, as well as the font list on the
Format strip. It also appears when you choose the Character Style command—applying a character
style in this manner is the same as choosing it from the font menu on the Format strip.

Defining Character Styles: The Style tab

The Style tab in the Character dialog box provides some useful features that make formatting text
with styles easier.

Based On To use an existing style’s settings as the basis for a new style, select the exist-
ing style from the Based On list. If you later change the base style, the shared
attributes of styles based on it are changed accordingly.

For example, say you defined two styles—Headline and Sub-head—for use as
document headings. If both styles share the same font attribute, but at differ-
ent point sizes (e.g., Headline uses Tahoma 24 pt, and Sub-head uses Tahoma
18 pt), and Sub-head is based on the Headline style, changing the font of the
Headline style to Helvetica, for instance, automatically changes the font of the
Sub-head style to Helvetica as well.

If you don’t want a style to be based on another, you can set the Based On at-
tribute to itself, i.e., the current style.

Shortcut Key TextMaker lets you assign keyboard shortcuts to any styles you create. This
can make formatting text considerably easier because you won't have to open
any dialog boxes or make selections from menus. Simply select the text you
want to format with a style, and press the keyboard combination for that style.

Scale If a style is based on another style, you can base its point size as a percentage
of the point size of the parent style. For example, if your normal body text
style uses 10-point type, and you have a footnote style that you want format-
ted at a slightly smaller size, say 8-point type, if you decided to increase the
size of your normal text, you might also want the footnote text to be increased
accordingly. In this example, check the Scale option and enter a value of 80%.
If you change the normal style from 10-pt type to 11 points, the footnote style
will be automatically increased to approximately 9-pt type.

PARAGRAPH STYLE

Use Format > Paragraph Style to select from a list of defined paragraph styles you can apply to a
paragraph or to a group of selected paragraphs. You can also apply paragraph styles by selecting
them from the style menu on the Format strip.

Paragraph Styles are a collection of paragraph attributes (including an associated character style)
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that you can name, save, and later apply to text all at once. When you choose a paragraph style, all
the attributes that make up that style are applied to the selected paragraph at once. In other
words, you wouldn’t have to apply several paragraph formatting attributes individually to para-
graphs in your document. All these changes would take place at once simply by selecting a style.

Paragraph Style dialog box

Bename...

Choose the style you want to apply from the list and click Apply to format the selected paragraphs
with it. If no text is selected, this will set the paragraph style for the paragraph that currently con-
tains the caret.

New Click this button to define a new paragraph style.

Edit Click this button to open the Paragraph dialog box where you can modify the
paragraph style currently selected in the list.

Delete Click this button to remove an existing paragraph style from the list.

Rename Click this button to rename an existing paragraph style.

To define a paragraph style

1  Choose Format > Paragraph Style. The Paragraph Style dialog box appears.

2 Click the New button. A dialog where you can specify a name for the new paragraph style ap-
pears, and then the Paragraph dialog box comes up.

3 Change any paragraph formatting as desired.
4  Click the OK button when you are satisfied with your choices.

The style you just defined now appears in the Paragraph Style list. It also appears in the style
menu on the Format strip.

Basing styles on other styles

To use an existing style’s settings as the basis for a new style, select the existing style from the
Based On list. If you later change the base style, the shared attributes of styles based on it are
changed accordingly.

For example, say you defined two styles—Subhead 1 and Subhead 2—for use as document head-
ings. If both styles share the same font attributes, but have different indent and border settings,
and Subhead 2 is based on the Subhead 1 style, changing the shared attributes of the Subhead 1
style automatically changes them in the Subhead 2 style. In this case the shared attributes are font
and point size.

If you do not want a style to be based on another style, you can set the Based On attribute to it-
self, i.e., the current style. By doing so, you guarantee that changes made to any other style will
not affect this one.
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The Next Style attribute

The Next Style attribute lets you specify which style should follow the current style when you press
Return. The default next style is the same one you are editing or defining, meaning that a newly
typed paragraph will use the style of the paragraph preceding it.

For example, say you always want normal body text to follow headlines in a document. If you
defined a style named Headline without specifying a next style, every time you pressed Return
after typing the headline, you would have to manually change the paragraph style of the new para-
graph. However, if you set the Next Style attribute of the Headline style to Normal for example,
after typing a headline and pressing Return, the style would automatically be set to Normal.

Changing paragraph indents

Paragraph indents appear as inward pointing triangles on the ruler. You can change their position
on the ruler by clicking and dragging them with the mouse, or by entering different positions for
them in the Paragraph dialog box in the Indents section. Indents can be moved inward from the
margins, or moved outside past the margins.

The right indent is a single upward-pointing triangle on the ruler. You can click it with the
mouse and drag it to the left of the right margin. The right indent marks the right-most boundary
of the paragraph. When text you type reaches the right indent, it automatically wraps down to the
next line.

The left indent is actually comprised of two separate indents, and is indicated by two triangles.
The down-pointing triangle marks the left boundary of the first line of a paragraph; the up-point-
ing triangle marks the left boundary of all subsequent lines in a paragraph. Initially, these two
boundaries are the same, so the triangles appear one on top of the other. Click and drag the top
triangle if you only want to change the first line indent (moving it to the left of the left indent cre-
ates what is known as a hanging indent, and appears in the Paragraph dialog box as a negative
value). Click and drag the bottom triangle to move the left indent.

There is also a small rectangle located immediately below the left indent marker. Click and
drag this rectangle to move both the first and left indents, maintaining their current relative posi-
tions to one another.

First-line indents

The first-line indent is commonly used to indent paragraphs. Rather than setting a tab for use as
an indent, and pressing the Tab key at the beginning of new paragraphs, create a first-line indent.
You can do this by clicking the top triangle with the mouse and dragging it inward to the point
where you want the first line of your paragraph to begin, or choose Format > Paragraph and enter
in the First Indent box the number of inches you want the first line indented.

The value you enter for a first-line indent is measured from the left indent (bottom triangle), as
opposed to being measured from the left margin. A positive value moves the top triangle to the
right of the bottom triangle, creating a normal indent. A negative value moves the top triangle to
the left of the bottom triangle—creating a hanging indent.

Left indents

Left indents control the amount of space between the left side of a paragraph and the left margin.
You can create a left indent by dragging the bottom triangle with the mouse, or choosing Format >
Paragraph and entering in the Left indent box the number of inches you want the paragraph in-
dented from the left.

If the first indent is zero, then it will line up with the left indent (both the top and bottom trian-
gles will appear at the same position).
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Right indents

The right indent controls the amount of space between the right side of the paragraph and the
right margin.

A hanging indent is created by positioning the First line indent (the down-pointing triangle) to the left of the
Left indent (the up-pointing triangle). Hanging indents are useful for creating numbered paragraphs (see also
the Bullet command in this chapter), or drop caps such as this paragraph.

For numbered or bulleted paragraphs, the number or bullet character is entered, followed by a tab. Subse-
quent lines of text are aligned automatically to the Left indent.

To create a hanging indent on the ruler

1  Click the left indent (the up-pointing triangle) and drag it to the right, or click the first line in-
dent (the down-pointing triangle) and drag it to the left of the bottom triangle.

You can also create a hanging indent by entering values into the Paragraph dialog box: choose
Format > Paragraph and enter in the Left indent box the number of inches you want the second
and subsequent lines of the paragraph indented from the left margin. Enter the same value in the
First indent box, but enter it as a negative number. The position of the first indent is always meas-
ured relative to the left indent.

In your document, type a number, press the tab key and start typing the main text of your
paragraph. When the text wraps down to the next line, it will be lined up with the left indent
marker. The numbered steps in this manual are a good example of hanging indents.

Saving styles for easy access

Character styles and paragraph styles are saved in the document in which you created them. If
you want these styles to be available in more than one document, you can also define styles in a
document template and base future documents on this template—these documents inherit the char-
acter and paragraph styles from the document template.

Document templates are discussed in more detail in the File Menu Commands chapter.
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w7 | INSEFE Menu Commands

The Insert menu contains commands for inserting special items into your documents such as
headers and footers, page breaks, calculated fields, etc.

DATE/TIME

Use Insert > Date/Time command to insert the current time and/or date at the caret position.

The Insert Date/Time dialog offers a list of several date and time formats you can choose from.
You can also click the Settings buttons to define your own date and time format.

Date and time can be inserted in two ways:

» asregular text that is editable by the user, but never updated again by TextMaker
» as a field that is managed and updated by TextMaker

FIELD

Use Insert > Field to insert fields at the caret location. There are many different fields available, for
example current date, print date, document name, page number etc. These fields are automatically
updated by TextMaker: If you print a document, the Print Date, for example, will reflect the date
the document was printed.

Insert Field [ x]

Ei

i Mixed
Close
file infio SEttns,
User [Business)
Summary j

Choose the type of field you want to insert at the current caret location:

Auto Number Inserts a field that generates a number. You can specify Legal (e.g., 1., 1.1,
1.1.1, etc.), or Outline (e.g., I, A, i, a, etc.) numbering. The level is controlled
by the Outline Level setting in the Paragraph dialog box. The first auto num-
ber field you insert is ‘1", the second is “2’, the third is ‘3’, etc. Each field you
insert increments the next number. If you delete a field, the auto number
fields following it are renumbered accordingly.

Creation Date Inserts the date on which you created the document. You can choose from a
number of different date formats, or click the Settings button to open a dialog
box where you can enter your own custom format. This field is never updated
and always shows the date the document was first created.

Creation Time Inserts the time you created the document. You can choose from a number of
different time formats, or click the Settings button to open a dialog box where
you can enter your own custom format. This field is never updated and always
shows the time the document was first created.

File Name Inserts the file name of the current document. You can choose either the full
path or only the base file name.

Merge Field Inserts a merge field. If you have already specified a merge database, the Data
list displays the available fields from that database. Otherwise, the list displays
‘Field One’, ‘Field Two’, etc., representing the fields of the database in the or-
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der they are defined. You can click the Settings button to open the Set Data-
base dialog box, where you can select the database to use. See the Set Data-
base command under the Extras menu for more information about merging.

Merge File Info Inserts information about your merge database, like the number of records,
the current record number, and the name of the merge file.

Page number Inserts the current page number in either Arabic (1, 2, 3) or Roman (I, II, III)
format. This field is most useful in headers or footers.

Page count Inserts the total number of pages in your document.
Chapter number  Inserts the number of the current chapter.

Print Date Inserts the date on which the document was last printed. This field is auto-
matically updated each time you print your document. You can choose from a
number of different date formats, or click the Settings button to open the
Date/Time Format dialog box where you can enter your own custom format.

Print Time Inserts the time at which the document was last printed. This field is auto-
matically updated each time you print your document. You can choose from a
number of different time formats, or click the Settings button to open a dialog
box where you can enter your own custom format.

User (home) Inserts any of several fields from the Preferences > User Home Address dialog
box. The list of fields represents your home address. See the Preferences com-
mand under the Extras menu for more information about these fields.

User (business) Inserts any of several fields from the Preferences > User Business Address dia-
log box. The list of fields represents your business address. See the Preferen-
ces command under the Extras menu for more information about these fields.

Summary Inserts fields from the document summary. You may select title, subject, au-
thor, keywords and description.

Date last changed Inserts the date at which the document was modified the last time.
Time last changed Inserts the time the document was modified the last time.

Last edited by Inserts the initials, the first or the last name of the author who last worked on
the document.

Use the Display Field Codes option in the File > Properties dialog box to toggle the display of field codes be-
tween the field name and the field value. For example, if this option is checked, the Print Date field would be
displayed as “{PrintDate}”. If it is not checked, it would display the current date, for example, “April 24,
2003".

Formatting inserted fields

After inserting a field into the text, you can format it just like any other text. Double-clicking any-
where within the field selects the entire field as if it were a single character. You can then change
its font, size, color, etc.

CALCULATION

Use the Insert > Calculation command to insert a calculation in the text.
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To: Press:

Insert a calculation F2

Choosing Insert > Calculation opens a dialog in which you can put together a formula that will
be calculated by TextMaker, just like in a spreadsheet. The result of this calculation is not inserted
as text, as TextMaker does with Edit > Evaluate, but-just like in a spreadsheet—the calculation re-
mains a field which displays the result of the calculation.

You can draw from a wide variety of functions for string handling, date calculations, math
functions etc., and you can also access database fields from your calculation.

The Calculation dialog box offers several choices:

Decimals You can define how many decimals are displayed as a result of a numeric cal-
culation.

Thousands

separator If the result of your calculation is numeric, it will be displayed with the thou-

sands separator defined by your operating system, i.e. “10,000”.

Hide Result The result of your calculation will not be displayed. What is this good for? If
you enter a calculation like “3+4+VAL("32")”, this option has no use. But you
can set up a chain of calculations with variables passing results to other calcu-
lations. TextMaker evaluates all calculations from the top to the bottom of
your document. The following chain of calculations would be supported:

a=3*4
b=a/2
c=a*b+42

In this case, you have inserted three separate calculations, which are based on
each other. Variable “a” contains 12, variable “b” contains 6, and variable “c”
contains 114.

Now, the intermediate results of calculating a, b, and c are displayed at the
place where the calculations are defined. This might not be the desired behav-
ior because intermediate results should often be hidden-et voila, that is why
you can hide individual calculations!

How, then, can you insert the result of a series of hidden calculations in your
document? Easy, insert another calculation that just consists of the variable
name of the end result, like “c”.

Database fields are available like they were variables, so FIRST+chr(32)+LAST would insert a
concatenation of two database fields of that name, separated by a space character (ASCII 32).

You can also access table cells in your calculations. Table cells are named Al, A2, A3, B1, B2,
etc.—just as in a spreadsheet. The name of the current table cell is always displayed in the status
bar. By prefixing the cell name with a hash sign (#), you are referring to the cell: #A1+#A2 builds
the sum of these two cells, and sum(#A1;#A10) sums the range of cells from A1...A10.

Furthermore, all objects you insert are automatically named by TextMaker, for example Foot-
erl, TextFrame5, or Table9. You can reference the text in these frames just like you are accessing
variables: upper(Footer1) reads out the footer frame name “Footerl”, converts the text contained
to uppercase and inserts the result in your document.

Combining the latter two methods enables you to access individual table cells from anywhere
in your document. If you have inserted a table with the name “Table1” in your document, you can
place the calculation Tablel.#A1 anywhere below this table in your document to display the cur-
rent contents of cell Al in that table.
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You can edit an existing formula by selecting it and calling up Insert > Calculation again (or
pressing F2).

SYMBOL

The Insert > Symbol command opens a dialog box displaying all characters in a font, and lets you
insert any characters directly into your document at the caret location.

Font This menu displays a list of all installed fonts, and selecting a font from the list
inserts characters at the caret location in this font.

DOCUMENT

Use Insert > Document to embed another document at the caret location into your current docu-
ment. The Insert file dialog will appear, and you can choose a document to insert in your text.

SMARTTEXT

Use the SmartText command to insert a phrase from your list of text abbreviations, or “shorthand
codes”, into the document at the current caret location.

The SmartText dialog lets you define and modify your shorthand entries. You can create new
entries and save modified entries as well as you can delete existing ones or rename existing en-
tries.

You can use the SmartText feature to set up shorthand codes for common sentences or frag-
ments, for example “br” for “Best regards”, or “lax” for “Los Angeles”.

The SmartText items may, at your discretion, contain formatting or remain unformatted. Un-
formatted SmartText entries pick up the formatting from the place where they are inserted,
whereas formatted SmartText entries define their own formatting.

LISTS & LABELS

The Insert > Lists & Labels command lets you easily create lists or printing labels from data drawn
from a database. With this command, you can extract all or selected records from any dBASE data-
base-your TextMaker address book, for example—and turn them into a nicely formatted address
list or set of address labels.

The Lists & Labels dialog lists all previously created lists and labels, offering them for editing,
deleting, renaming, executing, and also allows you to create new list or label definitions.

To define a new list or label

1 Choose Insert > Lists & Labels. The Insert List & Labels dialog box appears.

2 Click the New button. A dialog appears where you can specify a name for the new list or label.
Next, you specify the database the data for the list/label should come from.

3 The Generate List/Label dialog box comes up. In this dialog, you can pick merge fields from
the list and put them into the Mask field for the list or label. You can also add static text by
simply entering it in the Mask field. Insert tabs by pressing Ctrl+Tab.

4  Next, you should decide whether the resulting list/label should be created as regular body text
or as a table. If you pick regular body text, each record from the database will be added to
your document as a separate paragraph. If you decide for a table, each individual table cell will
contain one record from the database.
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5 In the Records field, you can choose which records should be picked from the database. You
can choose All for using all records of the merge file or Selected Records for using only the se-
lected records, or you can specify a range of records to be used.

6  Click OK when you are satisfied with your choices.

The list or label you just defined now appears as an entry in the list of the List & Labels dialog box.
Now you can select it, and pressing the Insert button will create the list or set of labels in your
document.

BOOKMARK

The Insert > Bookmark command provides a convenient method for placing markers at various lo-
cations in your documents that you can return to using the Edit > Go To command.

When you insert a bookmark, TextMaker remembers the location by letting you assign it a
name. This name appears in a list that is displayed when you select Edit > Go To. Choosing one of
the bookmarks takes you directly to the location where you inserted it.

Insert Bookmark [x]

‘— Cancsl

Delete

Each bookmark you create is displayed in the Insert Bookmark dialog box. You can also re-
move bookmarks from the list, by simply selecting them and then clicking the Delete button.

To jump to a bookmark, choose Edit > Go To. All bookmarks you have defined appear in the
Go To dialog box. Select one and click OK. TextMaker moves the caret to that location in the docu-
ment.

HEADER / FOOTER

Use Insert > Header and Insert > Footer to insert headers and footers in your document. Headers
and footers are repeated on each page of the document. They are useful for containing fields such
as page number, file name, print date, etc.

TextMaker makes it easy for you to insert headers and footers in your document. Headers and
footers are a special type of text frame that is repeated on every page of the document. Headers
appear at the top of the page, halfway between the page edge and the top margin; footers at the
bottom of the page between the page edge and the bottom margin. Headers and footers are the
ideal place to include automatic page numbers, date, time, and several other insert fields. You can
format text and fields contained in headers and footers just like in any other text frame.

To insert a header or footer into your document

1 Choose Insert > Header or Insert > Footer.

A text frame is automatically created between the left and right margins. The initial width of
the header or footer depends on the position of your left and right margins.

2 Type the text that you want to appear in the header or footer into the frame.
3 Format the header or footer text just as you would other text.

4 Insert any fields into the header or footer—such as auto page numbers, print date, etc.—using
Insert > Field.
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5 Resize the header or footer horizontally like you would any other text frame, by first switching
to Object mode, and resizing it with the mouse. You can only resize it vertically by adding
lines of text or by pressing the Return key.

After inserting a header or footer, the menu command changes to Edit > Goto Header or Edit >
Goto Footer. These commands are useful for jumping from document text to header or footer
text—the caret is automatically placed within the header or footer frame allowing you to quickly
and easily edit the header or footer text.

Starting headers and footers on different pages

Quite often, you will not want your headers and footers to appear on the first few pages of your
document (when these pages are title pages, prefaces, and various front matter for example). If
you want your headers and footers to start on a later page in the document, you can enter the
page number for the start of the headers and footers into the Starts On Page field in the Chapter
dialog box. Choose Format > Chapter to access the dialog box.

Deleting headers and footers

After creating them, you can delete headers and footers as you would other text frames: switch to
Object mode, click the header or footer frame, then press the Delete key. The frame, as well as any
text contained in it, is deleted.

FOOTNOTE

Use Insert > Footnote to insert a footnote at the bottom of the page, the end of the chapter, or at
the end of the document. Footnote references can be automatically numbered (1, 2, 3, etc.), or you
can choose special or non-alphanumeric characters (1, #, *, etc.). You could even mix numbered
and non-numbered footnotes within the same document.

The first time you insert a footnote in a document, TextMaker creates a paragraph style named,
appropriately, Footnote. This style is based on the Normal style, so it appears with the same for-
matting specifications as regular body text, except that the footnote reference character is super-
scripted. You can change the formatting attributes of the Footnote style in the same manner you
would any other paragraph style.

Also, TextMaker creates a character style called Footnote Reference at the same time and for-
mats the footnote number in the body text in it. You can change the properties of this character
style in the same manner you would any other character style.

To insert a footnote

1 Place the caret where you want the footnote reference to appear.

2 Choose Insert > Footnote. The Insert Footnote dialog box appears:

Insert Footnote

[x]
Footnole marker—————————————
& ihuto numbered:
© Cancel
€ Custom: _I
DOptions...

3 Click the Auto numbered option if you want footnote references to be automatically numbered
starting with 1, and proceeding to 2, 3, 4, etc. Click the Custom option if you want the foot-
note to be referenced with a different character, such as a non-alphanumeric character—t
(Alt+0134),  (Alt+0135), or the plain old asterisk character (*), for instance.

4  Click the Options button to specify any special footnote options. Clicking this button opens
the Footnote Options dialog box:
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Position:
[Mumbering Cancel |

Start at 1

I™ Restart on each page
rLine separator margin-——————————

Line separator..
teft [on | Aot [om | e |
Top [005in | Botom [005m |
Position Choose an option from this list to instruct TextMaker where to place the foot-

notes. There are three choices: at the bottom of the page where the footnote
was inserted, at the end of the chapter, or at the end of the document.

Numbering The Start At field lets you specify any starting number for your footnotes. By
default, footnotes begin with 1, and are incremented each time you insert an-
other footnote. The Restart on Each Page option will set the next footnote num-
ber to the Start At value for each new page.

Separator Line Click the Separator Line button to specify a footnote separator, which is the
line between the body text on a page and the the footnote text. By default,
TextMaker creates a 1 pt separator line, but you can change this, or even
choose not to use a separator line at all. If you do use a separator line, you can
change the width of the line as well as the minimum amount of space between
it and the surrounding text with the Separator Line Margins values.

5 Click OK when you are satisfied with any footnote options you may have changed. You are re-
turned to the Insert Footnote dialog box. Click OK again to create the footnote and its refer-
ence.

6 Type your footnote text.

GOTO FOOTNOTE / GOTO FOOTNOTE REFERENCE

Use Insert > Goto Footnote to move between a footnote reference and the footnote text itself. If
the caret is near a footnote reference, this command appears in place of the Insert > Footnote com-
mand, and choosing it places the caret within the corresponding footnote. If the caret is within a
footnote, this command changes to Insert > Goto Footnote Reference, and choosing it moves the
caret to the position in the document where the corresponding footnote reference is located.

You can also move between footnotes and references simply by clicking with the mouse, of
course, but these commands may prove quite useful for documents that contain many footnotes,
such as reports or scholarly papers, for example.

BREAK > COLUMN BREAK

Use Insert > Break > Column Break to insert a column break at the current caret location. This
command is only useful if multiple columns have been selected for the current section (see the
Section command under the Format menu for information about setting up multiple columns).

To: Press:

Insert a column break Ctrl+Shift+Return

BREAK > SECTION BREAK

Use Insert > Break > Section Break to insert a section break at the current caret location (see the
Section command under the Format menu for more information about working with sections).
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BREAK > PAGE BREAK

Use Insert > Break > Page Break to insert a manual, or “hard” page break at the caret location.

TextMaker automatically determines where page breaks occur based on page size, orientation,
and margins. When text you type fills a page, a page break is automatically inserted and typing re-
sumes on the next page (this is also known as a “soft” page break).

You can also insert page breaks yourself without having to fill a page with text. A cover page to
a report, for example, may only contain a few lines of text, but needs to be on a page by itself.
Rather than pressing down and holding the Return key until a page break is automatically in-
serted, choose Insert > Break > Page Break.

To insert a manual page break

1 Position the caret at the beginning of the first line of text that belongs on a new page. Or, if
you want the new page to begin with a blank line, position the caret on a blank line or at the
end of the last line of text.

2 Choose Insert > Break > Page Break or press Ctrl+Return.

To: Press:

Insert a page break Ctrl+Enter

To delete an unwanted manual page break

1 Position the caret at the beginning of the new page.
2 Press the Backspace key to delete the hard page break.

This process is just like deleting a blank line, except that the blank line you are deleting hap-
pens to begin a new page.

BREAK > CHAPTER BREAK

Use Insert > Break > Chapter Break to insert a new chapter at the caret location. You would insert
a chapter break if you wanted to create a different set of headers and footers, for instance, within
the same document. Chapters also let you change paper size and orientation, and provide a loca-

tion where endnotes can be placed.
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saes | Object Menu Commands

The Object menu contains commands for drawing and manipulating objects, editing the place-
ment of non-printing guides, and toggling the snap setting of grids and guides. Here you can also
group and ungroup objects as well as specify the stacking order of overlapping objects and the tab
order for form objects.

Working with objects and frames

TextMaker lets you create and manipulate objects easily. There are six types of objects you can
work with:

=

Create text frames with the text frame tool.
Create graphics frames from many different graphics formats using the picture tool.

ﬁ Create table frames with the table tool.

Create OLE object frames, linking data from an OLE server such as WordPad.

EEFFEEH 2 &

Create forms objects like input fields, check boxes, and dropdown lists, allowing you to create
professional forms easily.

lZ [0

Draw basic graphics such as lines, rectangles, and ellipses using the drawing tools.

Objects you draw with the drawing tools are independent from the main body of text in a docu-
ment. They exist on a separate object layer, so to speak. If you draw a rectangle in the middle of a
blank page, for example, and then type text on that page, the text would not move or push the rec-
tangle down, but would rather flow over or around it (you determine which). In other words, ob-
jects you draw with the drawing tools are anchored to the page, not to the text. Text frames are al-
so anchored to the page. Pictures, OLE objects and tables, however, can be anchored either to the
page or to the text. In most situations, you will probably anchor these objects to the page—just like
other objects—but you can also insert them within the text using the Copy and Paste commands
(copy or cut an existing picture, OLE object or table, switch to Text mode, position the caret at the
point in your text you want the object to appear, then choose Edit > Paste), or the New Picture
and New Table commands in the Object menu.

NEW TEXT FRAME

Object > New Text Frame lets you create a new text frame. Text frames are graphical objects that
contain text.
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NEW PICTURE

Use Object > New Picture to insert an in-line graphic into the text at the current caret position.
The New Picture dialog box is displayed where you can select a picture file.

New picture

Lookin | 24 prctures | =

IE picturel.bmp

“hicture2 b
I picture3. bmp
IE pictured.bmp
[E0 pictureS bp
I picturef. bmp

File Name;  |pictureZ bmp Open |
Type ol File, [l s () I~ | Cancel

I Sawe with document
I | Capyita dosumentsifaldzr

[2]x]

¥ Preview

R
Look in Select the drive and folder where you want TextMaker to look for picture files.
After selecting a folder, any documents of the type specified (from the Files of
Type menu) are displayed.
Files of Type Select options from this menu to tell TextMaker the type of picture file you

want to open. The default is All Pictures, which will display all files created in
any of the supported graphic file formats.

Choosing a specific format determines the available files displayed in the list. For example, if you
select Windows Bitmap Format from this menu, TextMaker will only display picture files of the

BMP variety in the list.

Supported graphic file formats:

File extension:

Windows Metafile
Windows Bitmap
Tagged Image File
Encapsulated Postscript
GIF format

JPG format

Targa

Image format
Photo CD format
PPM format

PBM format

PGM format
XBM format

2BP format

PC Paintbrush

WMEF (Windows-only)
BMP
TIF
EPS
GIF
JPEG
TGA
MG
PCD
PPM
PBM
PGM
XBM
2BP

PCX
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Preview Check the Preview option if you want pictures to be displayed in the preview
window whenever you click on them.

Save w/Document Check this option if you want TextMaker to store a copy of the selected pic-
ture directly within the current document. This option can significantly in-
crease file size, but can be convenient for transporting documents because
you won't have to worry about whether the original graphics files are present
or not. The copy stored in the document is all TextMaker needs to correctly
display and print it.

Copy to Document’s folder
Check this option if you want TextMaker to store a copy of the selected pic-
ture in the same folder as the document itself. This makes it easier to keep
track of which pictures belong to which document.

This option cannot be used until the document has been saved at least
once—unsaved documents don’t have a folder to which pictures could be cop-
ied to.

NEW PICTURE FRAME

Object > New Picture Frame lets you create a frame object that contains an image. After drawing a
frame with this tool, the New Picture Frame dialog box pops up, and you select the picture file to
be placed into the frame.

Difference between inserting a picture and creating a picture frame

Using the New Picture command to insert a graphic into your document is different than using
the New Picture Frame tool to insert a graphic.

The former inserts the picture as an in-line graphic directly into the text at the caret location.
The picture’s location on the page is dependent upon the surrounding text, and will move with
the surrounding text as new text is typed, deleted, or formatted. Using the New Picture Frame
tool, on the other hand, inserts the picture as an object attached at an absolute position on the
page. There are some other limitations as well: in-line graphics cannot be moved with the mouse.
An in-line graphic is aligned with the baseline of the line of text where you inserted it. As the text
moves—say from editing or formatting—so do any in-line graphics.

NEW TABLE

Object > New Table enables you to insert a new table in the text. It is identical to the Table > New
Table command.

NEW TABLE FRAME

Object > New Table Frame enables you to insert a new table as a frame object that is positioned
absolutely on the page. Table frames are similar to regular tables, but they are anchored on the
page and do not move with the text surrounding them. After drawing a frame with this tool, the
New Table dialog box is opened, where you specify how many rows and columns you want in that
table.

NEW OLE OBJECT

Object > New OLE Object lets you insert a new OLE object in the text.
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NEW OLE OBJECT FRAME

Object > New OLE Object Frame enables you to insert a new OLE object as a frame object that is
positioned absolutely on the page. OLE Object frames are similar to regular OLE Objects, but they
are anchored on the page and do not move with the text surrounding them.

TextMaker is an OLE container, meaning it can import OLE objects from OLE server applica-
tions such as Paintbrush, WordPad, et al.

NEW HORIZONTAL LINE

Object > New Horizontal Line inserts a horizontal line in your document at the current caret posi-
tion.

NEW FORMS OBJECT

Object > New Forms Object displays a sub-menu offering different form objects for use in the cre-
ation of fill-in forms:

Forms Objects

Textfield Creates an input field in which text can be entered
Checkbox Creates a check box that can be checked on or off

Checkbox frame same as above, but anchored to the page

Dropdown Creates a list of different choices, one of which can be picked
Dropdown frame same as above, but anchored to the page

With these objects, the creation of professional-looking forms becomes very easy.

NEW DRAWING

Object > New Drawing displays a sub-menu from which you can select a drawing tool for creating
an object. Choosing a tool from the New Drawing sub-menu is the same thing as choosing one
from the object strip.

I~

Draws lines.
Hold the Shift key while drawing to create horizontal, vertical, or 45° angled lines.

Draws rectangles.
Hold the Shift key while drawing to create squares.

= Draws round-corner rectangles.
Hold the Shift key while drawing to create round-corner squares.
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O

Draws ellipses and circles.
Hold the Shift key while drawing to create circles.

To draw an object, first choose a tool, then click the position on the page where you want one
corner or start-point to be, and while holding down the mouse button, drag to the position you
want the opposite corner or end-point to be. When you release the mouse button, the object is
drawn.

PROPERTIES

Use Object > Properties to display a dialog box where you can edit the size, position, wrap mar-
gins, appearance, and other attributes of an object. Choosing the Properties command is the same
as double-clicking an object. This command is grayed-out if no object, or multiple objects, are se-
lected.

The dialog box that appears when you choose this command changes depending on what type
of object is selected.

Line Properties dialog

If the selected object is a line, the following dialog box appears when you choose Object > Proper-
ties.:

Line
Properties |
- Option:
Mame: (]
li ™ Hide ¥ Tab stop
Color; [ I Black, o | A
From—
Thickness _
1Dt— Horizontal: |1 73in
01 pt " Wertical: |3,24 in
osp ——— || :
:
15p @é—— Harizontal 42in
2pt E—— Wertical: 271in
oy ——— ‘ertical
Name Contains the name of the object.
From, To The From and To fields determine the coordinates of the line. It would prob-

ably be easier to change the line’s position using the mouse, but you can also
do it from this dialog if you need to specify exact coordinates.

Thickness Click a Thickness option to change the width of the selected line, or enter a
line thickness in the Thickness field.

Color Select a line color from this menu of standard colors. These are the same col-
ors you can choose for text, shades, and graphic objects. The last item in this
list is Define Colors. Choose this option to open a dialog box where you can
set up a user-defined color and assign it a name. The new color will then ap-
pear in all color menus.

Options Select from additional options like Hidden (object is invisible), Tab stop (ob-
ject can be tabbed to in form-fill mode) or Lock (object cannot be reposi-
tioned).

Rectangle Properties dialog

If the selected object is a rectangle or rounded-corner rectangle, the following dialog box appears
when you choose the Properties command:
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Rectangle [x]

Formal | Propetties | Lines | Shades |

- Puosition
Horizontal

Verical

- Margin:

[ Size

T240n
width B

Left: 01in
Right: 01in
Top: 01in

Bottom: 01in

Height [1.361n

Squere

rComners

[ Sampls

™ Founded
Width Op

T

Heig Opt

|

Cancel

The Format tab

Size, Position

Square

Margins

Corners

The Properties tab

Name

Wrap

Options

The Lines tab
Line Style

Thickness 1,2

Color

Edit the rectangle’s size and position on the page by entering directly values
into the fields for size and position. The position is measured from the top-left
corner of the page.

Click the Square button if you want the selected rectangle to be a square. Text-
Maker then sets the rectangle’s height equal to its width.

Enter values for the object’s wrap margin. The wrap margins determine the
distance of the text from each side of the object, or in other words, how close
text in your document may appear above, below, or to either side of the object
before wrapping. See the section “Changing wrap margins with the mouse”
for more detailed information.

Click a Corners option if you want the rectangle to be a rounded-corner rectan-
gle. All four corners will be beveled. The Sample field shows a preview of the
object.

The Name field contains the name of the object in your document.

The Wrap list contains options for setting the wrapping behavior of the object.
Choose None for no text wrapping—text will flow over the object, ignoring its
wrap margins. Choose Line if you want text to jump over the object and con-
tinue below it. Choose Text if you want text to wrap around all sides of an ob-
ject.

Select from additional options like Hidden (object is invisible), Tab stop (ob-
ject can be tabbed to in form-fill mode) or Lock (object cannot be reposi-
tioned).

Select a preset line style from the Line Style options.

Click a Thickness option to change the width of the selected line, or enter a
line thickness in the Thickness field.

Select a line color from the list of standard colors. The last item in this list is
Define Colors. Choose this option to open a dialog box where you can set up a
user-defined color and assign it a name. The new color will then appear in all
color menus.
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The Shades tab

Click this tab to select a shade or fill pattern for the rectangle. This is the same as choosing Format
> Shades.

Ellipse Properties dialog

If the selected object is an ellipse, the dialog box appearing when you choose the Properties com-
mand is quite the same as if you have a rectangle or rounded-corner rectangle, except for one dif-
ference:

Circle Click the Circle button to change the selected ellipse to a circle.

The other options in this dialog box are exactly the same as those for rectangles (see the “Rectan-
gles and rounded-corner rectangles” section).

Text Frame Properties dialog

If the selected object is a text frame, the following dialog box appears when you choose the Prop-
erties command:

Text Frame
Format | Margins: I Properties I Borders I Shades I
Pasilion
Hotzorlal
Velical  [405in
\17\/idlh
[Fived =l J2z30n
Height:
Fived =l [r1esin
Cancel
The Format tab
Size, Position Edit the text frame’s size and position on the page by entering directly values
into the fields for size and position. The position is measured from the top-left
corner of the page.
Text frames can optionally grow in different directions if the text they contain
gets too large. If you want to have a text frame grow to the left, right, left and
right; or to the top, bottom, or top and bottom, select the corresponding op-
tion from the Width and Height lists.
Text Frame
Format I Margins: | Properties I Borders I Shades I
Wrap margin: Margin:

Lef o2 - Left [ooiem
HBight IU,ZET Right: IU,UBT
T [ | Im [omw
Bottom: ID,ZET Eottom ID,DBT

Cancel
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The Margins tab
This tab lets you define the wrap margins as well as the object margins for the text frame.

The wrap margins define the distance that text flowing around the object keeps from the object.
The margins define the distance of text inside the frame from the frame’s border.

Text Frame

Formt | Marains | Propetiss | Borders | Shades |

~Optiar:
" Hide ¥ Tab stop
™ Lock

 Dverlapping Dbjects

& lgnore Object
%l " Wiap Test

Wertical Alignment
& Top

ﬁ £ Centered
£ Bottom

" Flushed

Cancel

The Properties tab

Name The Name field contains the name of the object in your document.

Wrap The Wrap list contains options for setting the wrapping behavior of the object.
Choose None for no text wrapping—text will flow over the object, ignoring its
wrap margins. Choose Line if you want text to jump over the object and con-
tinue below it. Choose Text if you want text to wrap around all sides of an ob-
ject.

Options Select from additional options like Hidden (object is invisible), Tab stop (ob-
ject can be tabbed to in form-fill mode) or Lock (object cannot be reposi-
tioned).

Rotation In the Rotation section you can choose from one of four orientations for the

text frame: 0° rotation, 90° rotation, 180° rotation, 270° rotation.

Vertical Alignment Under Vertical Alignment you can determine how text within the frame aligns
vertically with the frame boundaries. These options do not affect line width,
or horizontal alignment, only vertical alignment. TextMaker automatically ad-
justs the line spacing, increasing or decreasing it as necessary.

Overlapping Objects

With Overlapping Objects, you can specify whether overlapping objects should
be ignored or wrapping around this object.

Text Frame

Formt | Marains | Propetiss | Borders | Shades |

Line: style:

rSample—————————

Single

Double R >,
hickaess il hictness 2

1 pt 1pt

g —H Jore —E

05pt — 0&pt —

ot — Tpt —

15pt — [ | 150t — 5

L <

Separatian: 1pt

Colour: [ Black. -
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The Borders tab
Line Style

Thickness 1,2

Color

Sample

Text Frame

Formt | Marains | Propetiss | Borders | Shades |

Ly Shad

Select a preset line style from the Line Style options.

Click a Thickness option to change the width of the selected line, or enter a
line thickness in the Thickness field.

Select a line color from the list of standard colors. The last item in this list is
Define Colors. Choose this option to open a dialog box where you can set up a

user-defined color and assign it a name. The new color will then appear in all
color menus.

The Sample shows a preview of the border, and you can click on the lines you
want to edit.

© Shade:

S| OO0
| .
© Patiem OEm

Sampls

R
7

s =
=[N

Foreground;

Cancel

The Shades tab

Click this tab to select a shade or fill pattern for the text frame. This is the same as choosing For-

mat > Shades.

Picture Properties dialog

If the selected object is a picture frame, the following dialog box appears when you choose the
Properties command:

Picture
Fomat | Propetiss | Bordess |
~Position ~Margin:
Harizantal: Left: 0.1in
Welical |2,7B in RBight: 01in
Top: 01i
I - n
Blott: i
width [2740n e ol
Height: Iz,sz in pCop————
Left: IU %
Horz. soale: |?2 4 Rlight: ID— %
Wert. scale: IEB % P
= Top IU %
™ Maintain aspect ratio Eottom: |U %
Eile.. Cancel
The Format tab

Size, Position

Edit the picture’s size and position on the page by entering directly values into
the fields for size and position. The position is measured from the top-left cor-

ner of the page. It is also possible to scale the picture by percentage values in
the appropriate fields.

Maintain Aspect Ratio
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Click this check box if you want the original aspect ratio of the picture to be
preserved when it is resized.

Margins Enter values for the object’s wrap margin. The wrap margins determine the
distance of the text from each side of the object, or in other words, how close
text in your document may appear above, below, or to either side of the object
before wrapping. See the section “Changing wrap margins with the mouse”
for more detailed information.

Crop If you want to crop the picture, enter percentage values in the appropriate in-
put fields.

File Click the File button to open a file dialog box where you can select a different
picture to be inserted in place of the current one. This is the same dialog box
that appears when you choose the Insert > Picture command.

Fomat | Propetiss | Bordess |
T Ficue | Ot
P | T Hide I Tabstop

— w1 ™ Lock

% g hig:e Foregraund color.

- I

-Rotation . r Eélkgruundcobl

o -

® o I Sarve with cocument
I= | Compressed

Eile.. Cancel

The Properties tab

Name The Name field contains the name of the object in your document.

Wrap The Wrap list contains options for setting the wrapping behavior of the object.
Choose None for no text wrapping—text will flow over the object, ignoring its
wrap margins. Choose Line if you want text to jump over the object and con-
tinue below it. Choose Text if you want text to wrap around all sides of an ob-
ject.

Options Select from additional options like Hidden (object is invisible), Tab stop (ob-
ject can be tabbed to in form-fill mode) or Lock (object cannot be reposi-
tioned).

Rotation In the Rotation section you can choose from one of four orientations for the

text frame: 0° rotation, 90° rotation, 180° rotation, 270° rotation.

Save with Document

Compressed

Foreground Color

Click the Save with Document option if you want the picture file to be saved
within the document. If you do not check this option, just a link is preserved
to it, and you will need to make sure the picture file is available the next time
you open the TextMaker document. Saving graphics with the document can
significantly increase the size of the document.

If you saved the picture with the document, you can check this option to in-
struct TextMaker to compress the size of the picture. Using this option can re-
duce the size of documents containing imported graphics by a substantial
amount.

The default option, Normal, ensures that the picture is displayed in its original
colors. If you want to reduce the colors to a duotone picture, select a specific
color for the foreground.
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Background Color If the foreground color is not set to Normal, this option becomes available and
lets you set the background color of your duotone picture.

Picture

Format I Properties I Borders |
~Sample

Thichress | Thickness 2 T I
1 pt 1pt

o —E Jore —E

05pt — 05pt —

g — g —

150 — [ 150t — 5 . .
SEmaratian: l‘lpt— - -
Colour: l-Bl‘“k—L[

File. Cancel

The Borders tab

Line Style Select a preset line style from the Line Style options.

Thickness 1,2 Click a Thickness option to change the width of the selected line, or enter a
line thickness in the Thickness field.

Color Select a line color from the list of standard colors. The last item in this list is
Define Colors. Choose this option to open a dialog box where you can set up a
user-defined color and assign it a name. The new color will then appear in all
color menus.

Sample

The Sample shows a preview of the border, and you can click on the lines you
want to edit.

Table Properties dialog
If the selected object is a table, the following dialog box appears when you choose the Properties
command:

Table

Format | Propettiss | Bordess | Grid | Shades |
- Position

Horizantal:

Wertical

rSize

Wwidth: |1 B8in

Height: Josi |
Cancel
The Format tab

Size, Position Edit the table’s size and position on the page by entering directly values into

the fields for size and position. The position is measured from the top-left cor-
ner of the page.

Margins Enter values for the object’s wrap margin. The wrap margins determine the
distance of the text from each side of the object, or in other words, how close
text in your document may appear above, below, or to either side of the object
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Table [ x]

Fomal | Propettes | Borders | Grid | Shades |

before wrapping. See the section “Changing wrap margins with the mouse”
for more detailed information.

rr— Optian
[ Hide ¥ Tab stop
- ™ Lock

Cancel

The Properties tab

Name The Name field contains the name of the object in your document.

Wrap The Wrap list contains options for setting the wrapping behavior of the object.
Choose Norne for no text wrapping—text will flow over the object, ignoring its
wrap margins. Choose Line if you want text to jump over the object and con-
tinue below it. Choose Text if you want text to wrap around all sides of an ob-
ject.

Options Select from additional options like Hidden (object is invisible), Tab stop (ob-
ject can be tabbed to in form-fill mode) or Lock (object cannot be reposi-
tioned).

Table E

Fomat | Propsttiss | Bordess | Girid | Shades |

Line style:
Nore S ample:
Doubls R4 ¥
Thickness 1: Thickness 2
1pt 1pt
m otp —E
05pt — 05pt —

1pt —
15— o |10 — , .
Sepaior [1p | . :
Colour: l-Black—;[

Cancel

The Borders tab
Line Style

Thickness 1,2

Color

Sample

Select a preset line style from the Line Style options.

Click a Thickness option to change the width of the selected line, or enter a
line thickness in the Thickness field.

Select a line color from the list of standard colors. The last item in this list is
Define Colors. Choose this option to open a dialog box where you can set up a
user-defined color and assign it a name. The new color will then appear in all
color menus.

The Sample shows a preview of the border, and you can click on the lines you
want to edit.
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Table E

Fomat | Propsttiss | Bordess | Girid | Shades |

Samph

Thickness 1: Thickness 2

0.5pt 1pt
oo — [0 — 2
05pt — 05pt —

1pt — 1pt —

15pt — =] 150t — ]
Separation: 1pt
Colour: [EElack -

Cancel

Grid tab
Click this tab to specify the line style for the internal grid lines of the table.

Table

Format I Properties I Borders I Grid I Shades |

Ty Shad Sampl
& el CIC 0]
™ EEE
cewen | [ NI

Fareground:

AN B | ek =
Hﬂﬂ]] E @ Eélkgmund

Cancel

The Shades tab

Click this tab to select a shade or fill pattern for the rectangle. This is the same as choosing Format
> Shades.

GUIDES AND GRIDS

Use Object > Guides and Grids to open the Guides and Grids Dialog box. Under the tab Guides
you can specify horizontal and vertical guides. Guides are non-printing lines that you can place
anywhere on a page, and are useful for positioning and aligning objects and frames: If you move
objects around, they will ,snap” to the guides.

Guides and Grids [ x]
Guides | G |
Horizontal: Wertical
[0 Oin Set
Clear

rDptions

¥ Snap to quides

Tolerance[s 5] Pisel

0K Cancel

In this dialog you can add and delete horizontal and vertical guide lines. You can also add, move,
and delete guide lines with the mouse in Object mode.

To create a new guide, enter the vertical or horizontal position where you want the new guide
in the Position field, then click Set. The new guide is added to the list of guides.
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When you click OK, the new guide appears in your document.

To delete a guide, click the guide to be deleted and click Clear.

Adding and editing horizontal guides with the mouse

To add a horizontal guide line with the mouse, change to Object mode, click anywhere within the
horizontal ruler and drag down. When you release the mouse button, a guide line appears at that

position.

You can move a guide line by clicking and dragging it. To delete a horizontal guide line with
the mouse, switch to Object mode, click on the guide and drag it back to the horizontal ruler.

Adding and editing vertical guides with the mouse

Adding and editing vertical guides is identical to adding horizontal rulers. Just make sure that the

vertical ruler is turned on (through Extras > Preferences).

To add a vertical guide line with the mouse, change to Object mode, click anywhere within the
vertical ruler and drag to the right. When you release the mouse button, a guide line appears at
that position.

You can move a guide line by clicking and dragging it. To delete a vertical guide line with the

mouse, click it and drag it back to the vertical ruler.

If you see guide lines on your page, but none appear in the Edit Horizontal or Vertical Guides dialog boxes,

then the guides have been created on a master page. To edit them, first choose View > Master Pages, then se-

lect Object/Guides and Grids.

Use the Snap to Guides command under the Guides tab to precisely position objects, frames, and
bles to any guide lines you have created in your document. A check mark next to this command
indicates that it is active.

ta-

The Tolerance means the distance, in pixels, an object may be placed to a guide before snapping to

it. Think of tolerance as the gravitational field of grids and guides.

SET GRID

Use the Grid tab to determine the horizontal and vertical grid increments for positioning—or
“snapping”—objects, frames, and tables.

Guides and Grids [ x]

Guides | Grid |

- Girid distance

Horizontal: | MR

Vettical: [0.25in
~Optigns——————————
™ Snap to grid
™ Snap to page margins

Snap to Grid The default grid setting is one-quarter inch. You can create a coarser or finer

grid by entering different Horizontal and Vertical values.

Snap To Page Margins

If you activate this option for the page margins, the margins will act like guide

lines, and objects will snap to them too.
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GROUP / UNGROUP

Use Object > Group to combine several objects—such as text frames, tables, pictures, OLE objects,
or those you create with the drawing tools—into a group so that the objects are treated as a single
unit. This allows you to move the objects together. For example, you might group a picture object

and a text frame used for a caption so that you could reposition it on the page as a single unit.

To group objects

1  Select multiple objects by Shift-clicking them with the pointer tool.

2 Choose Object > Group to combine them into one unit.

This is my text frame
This is my text frame
This is my text frame
This is my text frame
This is my text frame
This is my text frame

To ungroup objects

1  Select the group.
2 Choose Object > Ungroup.

This is my text frame
This is my text frame
This is my text frame
This is my text frame
This is my text frame
This is my text frame

Guidelines for grouping objects

The following notes apply to grouped objects:

» Groups can not be pasted as in-line objects (inserted within the text). You can copy and
paste groups in Object mode, but not within the text as in-line objects.

» Groups can be made up of other groups, and the nesting is retained when you ungroup

them.
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SEND TO FRONT, SEND TO BACK

Use Object > Send To Front and Object/Send To Back to change the stacking order of overlapping
frame objects.

Choose Object > Send To Front to make an object the topmost object on the page. To move an
object to a position behind all other objects, choose Object > Send To Back.

These commands apply only to objects, and will only be active (that is, not gray) if you are in
Object mode and an object is currently selected.

TAB ORDER

Use Object > Tab order to set the order in which objects are selected in Forms Mode when you
cycle through them with Tab and Shift-Tab.
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wes | TADI@ Menu Commands

The Table menu contains commands for working with tables. Tables are spreadsheet-like objects
ideal for storing tabular or columnar data such as forms, price sheets, and invoices. You can create
table frames that are anchored to the page and in-line tables that move with the text around them.

NEW TABLE

Use Table > New Table to insert an in-line table into the text at the current caret position or into a
table cell. The New Table dialog box is displayed where you can enter the number of rows and col-
umns for the table.

Bows: IE_E Lolumns: IS_E
Border Cancel

Left [004in [5]  Right [004in 5]
Top [004in (5] Botom [004n 5]

This command creates an in-line table that is inserted into the text, as opposed to Table > New
Table Frame which creates a table that is attached to an absolute position on the page.

In-line tables move with the surrounding text.

If the caret is in a table, then this command will create a sub-table within the current cell of the
table.

NEW TABLE FRAME

The Table > New Table Frame command let you create tables as frame objects. After drawing a
frame with this tool, the New Table dialog box is opened where you tell TextMaker how many
rows and columns you want.

This command creates a table frame that is anchored to the page and does not move with the
surrounding text.

EDIT ROWS

Use Table > Edit Rows to edit the properties of rows of a table. The properties of all of the cur-
rently selected rows will be changed. If no rows are selected, the properties of the row currently
containing the caret will be changed.

# Columns Enter the number of columns in the selected rows.

Min. Height Enter the minimum height for each of the selected rows. The height of the row
is determined by the height of the largest cell in the row, subject to the limita-
tion that it not be smaller than the Min. Height value.

Keep Together

With Next Row  Click this option if you do not want a page break to occur between this row of
the table and the next. This option is only available for in-line tables, not table
frames-table frames never wrap to a new page anyway.

Break Page At Row Click this option if you want to force a page break before the selected row. If
more than one row is selected, page breaks are inserted between each of
them. This option is only available for in-line tables that were inserted into the
text, not table frames.
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EDIT CELLS

Use Table > Edit Cells to edit the properties of selected cells in a table. If no cells are selected, then
the properties of the cell currently containing the caret are changed.

Margins Enter the left, right, top, and bottom margins. The margins represent the dis-
tance from the edge of a cell to the text.

Auto Width Click this option if you want the width of the cell to be determined by the
width of the text contained within the cell.

Width Enter the width of the cell. If the Auto Width option is selected, the width of
the cell is determined by the width of the text contained within that cell and
this field is grayed.

Align Baselines  Click this option to align the baselines of all of the cells in a row with the Align
Baselines option set.

Borders Click the Borders button to show the Borders dialog box where you can select
the border style for the table cells.

Shades Click this button to open the Shades dialog box where you can select a shade
or fill pattern for the table cells. This is the same as choosing the Shades com-
mand from the Format menu with table cells selected.

Changing cell widths with the mouse

You can change the width of selected cell columns with the mouse: switch to Text mode, place the
text caret into the table you wish to change, then position the mouse cursor over a column border.
The mouse cursor changes its appearance and lets you move column borders. Click and drag to
the right or left to increase or decrease the column width.

If no table rows have been selected before, this mouse movement changes the width of the cell
the caret was in. If table rows have been selected before, this uniformly changes the widths of all
selected columns to the same widths.

INSERT ROWS

Use Edit > Insert Rows to insert rows into a table. If one or more rows are selected, the number of
rows equal to the number selected is inserted before the first row in the selection. For example, if
one row is selected, this command will insert a single row before it; if three rows are selected, this
command will insert three rows.

If no rows are selected, the Insert Rows dialog box is displayed where you can enter the num-
ber of rows you want to insert. The rows are inserted before the row containing the caret.

APPEND ROWS
Use Edit > Append Rows to append rows to a table.

INSERT COLUMNS

Use Table > Insert Columns to insert columns into a table. If one or more columns are selected,
the number of columns equal to the number selected is inserted before the first column in the se-
lection. For example, if one column is selected, this command will insert a single column before it;
if three columns are selected, this command will insert three columns.
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If no columns are selected, the Insert Columns dialog box is displayed where you can enter the
number of columns you want to insert. The columns are inserted before the column containing
the caret.

APPEND COLUMNS

Use Table > Append Columns to append columns to a table.

DELETE CELLS

Use Table > Delete Cells to delete the selected cells. If no cells are selected, this command is
grayed. Delete Cells differs from the Edit > Cut in that deleted cells are not copied to the clip-
board. You can also delete cells by pressing the Delete key when cells are selected.

To delete a cell, you must select, or highlight, the entire cell, not just the contents of the cell.
Otherwise, the Delete Cells command is grayed.

When you delete a cell, any cells to the right of it move over, assuming the deleted cell’s posi-
tion.

SELECT TABLE

Use Table > Select Table to select the entire table in which the caret is located.

SELECT ROWS

Use Table > Select Rows to select entire rows of a table. If no cells are selected, the row containing
the caret is selected. If cells are selected, all of the rows containing the selected cells are selected.

SELECT COLUMNS

Use Table > Select Columns to select entire columns of a table. If no cells are selected, the column
containing the caret is selected. If cells are selected, all of the columns containing the selected cells
are selected.

CONVERT TABLE TO TEXT

Use Table > Convert Table to Text to convert a table into body text.

To convert a table to text

1  Set the caret into a cell of the table.

2 Call up Table > Convert Table to Text. The Convert Table to Text dialog box will appear.
3 Choose the separator that will be used to set the cell contents apart.
4

Click OK to convert the table. The table now changes into regular text, delimited by the sepa-
rator you chose.

If your table looks like this...
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cell 1 cell 2

cell 3 cell 4

... the Convert Table to Text command will turn it into this (assuming you specified a semicolon as
separator):

cell 1;cell 2
cell 3;cell 4

Each row will be written as a separate paragraph, and in this example, each item is separated
from the next with a semicolon.

Depending on what kind of separator you use you will get different results:

Separator Result

Paragraph break Every table cell will go into a new paragraph.

Tabs Cells in a row are separator by tabs, rows are turned into paragraphs.
Semicolon Cells are separated by semicolon, rows are turned into paragraphs.
User-defined Specify your own separator.

CONVERT TEXT TO TABLE

Use Table > Convert Text Table to Table to convert text into a table.

To convert text into a table

1  Select the paragraphs that you want to convert.

2 Call up Table > Convert Text to Table. The Convert Text to Table dialog box will appear.
3 Choose the separator at which the table cells should be split.
4

Define how many rows and columns the new table should have. Please note that TextMaker
automatically calculates the optimal values for you.

5  Click on the OK button.

The text is now converted into a table. Every paragraph is now a row in the new table.

Example: You want to convert these lines into a table:

Peter;Mouse;24 Niceplace;2345;Pleasantville
Thomas;Root;7 Grapevine 7;4321;New Pike

Call Table > Change Text into Table and choose the semicolon as your separator. After the con-
version, your table will look like this:

Peter Mouse 24 Niceplace 2345 Pleasantville

Thomas Root 7 Grapevine 4321 New Pike
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You can influence how text is converted to a table with the options in the Convert Text to Table

dialog box:

Rows, Columns

Separator

Remove quotation
marks

SORT TABLE

Usually it is not necessary to take care for these values as TextMaker calcu-
lates the correct values for you.

The most important setting. This indicates to TextMaker what character is to
be used when splitting the paragraph into cells:

» Paragraph Break (each paragraph gets its own cell)
» Tabs (each entry is separated by a tab)
» Semicolon (each entry is separated by a semicolon)

» User-defined separator

Activate this option to delete all quotation marks in the text before changing
the text into table cells. This option is useful for converting a list which has en-
tries with quotation marks in it. ("Thomas";"Robert";...).

Use Table > Sort Table to sort a table alphabetically in ascending or descending order.

To sort a table

1  Select the table you want to sort.

Choose Table > Sort Table.

2
3 Set the sorting order to ascending (A...Z) or descending (Z...A).
4

Click on OK to sort the table.

Some additional options are available:

Sort by

Then sort by

First Row
contains Headings

Case-sensitive

In most cases, you want the table to be sorted alphabetically by the first table
column; however, you can specify another column instead.

There are cases in which the table column by which you are sorting contains
duplicates. By selecting additional columns here, you can specify the sorting
order in these cases.

Switch this option on if the first selected row contains a heading. In this case,
TextMaker will leave out this row when sorting.

Check this option if you want sorting to be aware of uppercase and lowercase
letters.
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w0 | EXEFAS Menu Commands

The Extras menu contains commands for setting up mail-merge documents, spell-checking docu-
ments, creating tables of contents, customizing TextMaker etc.

EDIT MERGE FILE

Use the Edit Merge File command to open and edit a merge file. This command starts the Text-
Maker database editor in which you can view and edit dBASE (.DBF) databases.

[% Fle Edt Wiew Golo Select Window Help ISEIES
A A AR Y e A

J FILK MR FILMTITEL GENRE FILMLAENGE | REGIE DARSTELLER | FSK FURZBESCHR| LEIHGEBUHR | WERLEIHT | KUMDEMNA
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A database can be displayed in two different kinds of views:

» List view shows multiple records in a spreadsheet-like layout
» Form view shows and lets you edit single records of the database

Switch between both modes with the View > Form command.

While List view is helpful in getting a general overview of a database, records can only be
edited in Form view.

With the database open, you can append, duplicate, delete, and search for records by calling
up the appropriate commands in the Edit menu.

One of the most important uses of TextMaker’s database module is letting you select records
for mail-merging. You can select records by going to List view and clicking/unclicking the check
boxes in front of the record lines, you can select/deselect by record numbers, and you can select
by entering selection criteria in Select > By Condition.

When you delete a record in the database, it is not permanently gone but just marked as de-
leted. To finally remove deleted records from your database, call up the Edit > Compress Database
command.
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CREATE MERGE FILE

Use Extras > Create Merge File to create a new database suitable for mail-merging. First, this com-
mand shows a file dialog, letting you specify a name for the new database. After clicking OK, the
Create New Merge File dialog will appear.

In this dialog you can set up the structure of the database you want to create. Field by field, you
enter the following data:

Name Give every field a name between 1 and 10 characters. Make sure the name
starts with a letter, and do not use duplicate names.

Type Every field in your database has a specific type, defining what kind of data it
can store. The available field types are Character, Numeric, Date, Logical, Memo.

Length, Decimal  Every field in your database can store as many characters as you defined dur-
ing database creation. Character fields may contain 1 to 254 characters, nu-
meric fields up to 18 characters. Logical and date field have pre-defined
lengths.

Be sure to specify field lengths that are adequate for the amount of data you
want to store: define a field too small, and you cannot put in the information
you want; define a field too large, and the database will be unnecessarily large
on your hard disk.

Memo fields are a special case: In most regards, they behave like character
fields. However, their size limit is about 4,000, and they are managed dynami-
cally. You do not have to (nor can you) define the maximum length of memo
fields when creating the database—this is handled by TextMaker internally.

Append After completing a field definition, press this button to add the field to your
database. It is appended as the last field.

Insert You can also insert a pending field definition at the position of the highlight
bar. Click on Insert to do this.

Replace Replaces the currently selected field with the pending field definition.

Delete Removes the currently selected field from your database.

The OK button closes the dialog box and opens the new database for editing.

SET MERGE FILE

Use Extras > Set Merge File to specify the database to use for print merging. The name of the data-
base is saved in the document.

When the document is printed, you can specify that a “merge” is to take place. In this case, the
document will be printed once for each record in the database (or for the range of records speci-
fied). Each time the document is printed, each merge field (see the Field command under the In-
sert menu) in the document will be replaced by the associated field from a record of the database.

See the “Print merging” section for more information and instructions on print merging a TextMaker docu-
ment with a database file.

Look in Select the drive and folder where you want TextMaker to look for databases
from this list.

Files of Type Select File of Type from this menu to tell TextMaker the type of database you
want to merge: Windows/ANSI Comma-Delimited, DOS/PC-8 Comma-De-
limited, Windows/ANSI dBASE or DOS/PC-8 dBASE.
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Use First Record for Field Names
Check this option if you want to use the first record of the database for the
field names. This is only useful for comma-delimited databases.

Clear Click this button to remove, or un-associate, any database you may have se-
lected for merging with the current document.

INSERT INDEX ENTRY

Use Extras > Insert Index Entry to add an index marker for each word, phrase, or topic you want
to appear in the index. Typically, you would select some text in a document before choosing this
command, but this might not always be the case. This command marks the current caret location;
if no text is selected when you choose this command, you can enter a description for the location
in the Insert Index Entry dialog box.

Adding an index entry

To add an index entry, select the text you want indexed—or simply place the caret at a location you
want indexed—and choose Extras > Insert Index Entry. The selected text appears in the edit field at
the top of the dialog box. If no text was selected prior to choosing the command, this field is blank
(where you could, for example, enter a description for a topic or concept you want included in the
index, but which isn’t tied to a specific word or phrase).

Index All Occurrences
Check this option if you want TextMaker to locate every occurrence of the se-
lected text, and automatically add them to the index when it is generated.

EDIT INDEX ENTRIES

Use Extras > Edit Index Entries to edit the list of index entries. The Edit Index Entry dialog box ap-
pears, listing all the index items you have added so far. Select the index item you want to delete
from the list and click the Delete button. Then click the Close button to close the dialog box.

Edit Index [ x]

e entry Closs
[elete,
JEellic)

With a click on the Go To button, the caret will be set to the starting point of the selected index
entry. This makes it easy to find an index entry in your document.

GENERATE INDEX

Use Extras > Generate Inex to create an index for your document. The information TextMaker in-
cludes in the index is based on the tagged index entries you inserted throughout the document.

To tag text you want included in the index, use the Extras > Insert Index Entry command just
described.
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Generate Index dialog box

rPlacement

€ Coerin v Lo |

) Henlace evisting indes Cancel |

rHeadng—

& Nonei

" Blark line

" First letter

™ Use chapter number

Placement Normally, you would create an index at the end of the document, but this is

not necessarily so; an index can be created anywhere in the document. You
can choose here whether you want to create a new index or replace an exist-
ing one.

Heading TextMaker generates indices in one of three styles which you can choose here.
Click the First Letter option if you want index items grouped alphabetically ac-
cording to the first letter, e.g., all index items beginning with the letter “a’ will
be preceded by an ‘A’ heading, all ‘b’ items will be preceded by a ‘B” heading,
etc. Click Blank line if you want alphabetical groups separated by a blank line,
but not by a letter. Click None for no separation between the indexed items.

Use Chapter Number
Normally, index entries are listed with the absolute page number. If you pre-
fer the index to contain chapter numbers (and page numbers relative to the
chapters), check this option. Thus, TextMaker will insert “5-2” instead of “24”,
for example, if page 24 happens to be the second page of the fifth chapter.

GENERATE TABLE OF CONTENTS

Use Extras > Generate Table of Contents to automatically create a table of contents for your docu-
ment. TextMaker includes in the table of contents any paragraph with an outline level falling with-
in a range you specify. Outline levels are numbers you can assign to paragraphs denoting their
heading level. Level 1 is the highest. This might be a title or headline, for instance. Level 2 might
be for chapter headings, level 3 for sub-headings, and so on. Level 0, or no outline level, is used
for normal body text. You specify a paragraph’s outline level from the Paragraph dialog box. You
can also set a paragraph’s outline level with the Outline strip in Outline view.

Generate Table Of Contents dialog box

Generate Table of Contents [x]
Include levels:
H _DK
[EE—

Cancel
™ Use up tofiist tab —I

 Placement

(= (Ereate e bl

" Henlace eyistina tatle

Include Levels Choose options from this list to determine which outline levels TextMaker will
include in the table of contents.

Use up to Ist tab  When TextMaker adds a heading to the table of contents, it adds the entire
paragraph. Many headings contain text with tabs inserted in them, for exam-
ple to separate chapter numbers from chapter titles. Select this option if you
only want text up to but not including the first tab to appear in the table of
contents.

Placement Normally you would create an index at the beginning of the document, but
this isn’t a requirement; a table of contents can be created anywhere in the
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document. Click Create new table or if there is already an old version or choose
Replace existing table here.

RUN SCRIPT

Use Extras > Run Script to run a Basic program that you have created with the BasicMaker script-
ing language. BasicMaker is an add-on component to TextMaker.

EDIT SCRIPT

Use Extras > Edit Script start BasicMaker, the editor for the BasicMaker scripting language. Then
you can edit an existing BasicMaker script or create a new one.

THESAURUS

Use Extras > Thesaurus to look up synonyms (words with similar meanings) for a selected word in
your document. The thesaurus can then replace the word in your document with the synonym you
select.

To replace a word with a synonym

1 Place the caret in the word you want to replace with a synonym.
2 Choose Extras > Thesaurus.

The Thesaurus dialog box appears. The selected word appears in the Word combo box, with a
list of synonyms beside it.

hury -

alacrity Replace |
M ) dispatch
L oese |

hurmy [noun] hastiness
hustle
speed [verb) precipitance
precipitation
quickness
ush

=

speed
swiftness

You can double-click a word in the Synonym:s list to place it in the Word combo box and auto-
matically look up its synonyms.

3 Select a synonym from the Synonyms list.
4  Click Replace to replace the original word with the selected synonym.

The Thesaurus dialog box is closed, and you are returned to the document with the synonym
in the place of the original word.

You don’t have to select a word in order to use the thesaurus. You can choose the Thesaurus command with
no word selected, then simply type the word you want to look up in the Word box, and click Look up.

If you are writing a letter to your Congressman, for example, and you want to say that her tax-
increasing proposals are stupid, but think that “stupid” is too simplistic a word to describe such
absurd foolishness, you can use the thesaurus to find a more suitable description. Type “stupid”
into your document wherever you want to place the word, move the caret anywhere into the word
“stupid,” and select Extras > Thesaurus menu. A list of synonyms appears. To select “daft” to re-
place “stupid,” click the word “daft,” and then click the Replace button.
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If none of the available synonyms are exactly what you want, you can even see a list of syno-
nyms of the synonyms. Select a synonym from the list, but instead of clicking Replace, click Look
up. Double-clicking the synonym does the same thing. The selected synonym moves up to the
Word box, and a list of its synonyms appears beside it. You can continue this process until you
find a suitable synonym.

You may, however, discover that as you move through this look up process you stray too far
from the original word in meaning. If this happens, you can return to the original word by select-
ing it from the Word combo box (each time you perform a look up, the word is added to the com-
bo box),

You can, at any time, type another word into the Word box, and click Look up to see a list of
synonyms for the typed word.

Click Close to return to your document without changing any words.

CHECK SPELLING

Use Extras > Check Spelling to check the spelling of words in your document.

You are first asked if you want to start at the beginning of the document or at the current caret
position. Click the Whole Document option if you want the entire document to be checked. Click
the From Caret option if you want to search only from the current location to the end of the docu-
ment.

Click OK to begin the spell check. If a misspelled word is found, TextMaker highlights it and
opens the Spell Check dialog box:

‘whord: waanted
= Skip
Add
Clase
Mo more suggestions
Change To This combo box displays a list of suggested spellings. Click the correct spelling
or type it in the edit field.
Change Click this button to change the selected word to the word displayed in the

Change To field, and continue checking the remainder of the document.

Change All Click this button to change all future occurrences of the misspelled word to
the word displayed in the Change To field. Spell checking for other misspelled
words continues.

Close Click this button to stop spell checking and return to the document.
Skip Click this button to ignore this occurrence of the word.
Add Click this button to add the word to your user dictionary. Later, when this

word is found by the spell-checker again, it won’t be flagged anymore as an
unknown word.

EDIT USER DICTIONARIES

Use Extras > Edit User Dictionaries command to examine and edit the list of dictionary entries you
have collected.

The dialog contains a Languages list and a box where you can see all dictionary entries for the se-
lected language.
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To remove an entry from a user dictionary, hit the Delete button.

RECALCULATE

Use Extras > Recalculate to update all calculations in your document. Please note that this com-
mand is not required before printing because printing updates all fields and calculations anyway.

CUSTOMIZE

Under Extras > Customize you can find a submenu in which you can choose to configure Control
Strips and Keyboard Mappings.

Customizing control strips

Control strips are placeholder lines on screen that can be filled with buttons for common opera-
tions. There are several pre-defined control strips, like the Format strip, the Outline strip, the Ob-
ject strip, etc. With Extras > Customize > Control Strips, you modify the contents and the place-
ment both of existing control strips and newly-created ones.

You can choose which command buttons appear on the strip, as well as their order, and the
amount of space between the command buttons.

Instead of going through the menu, you can also double-click anywhere inside any control strip (not on one
of the buttons though!) to open the Customize Control Strip dialog box.

Configuring the control strips with the mouse

The easiest way to customize the control strips is to use the mouse.

To customize the control strip with the mouse

1.  Open the Customize dialog box by choosing Extras > Customize > Control Strips, or by
double-clicking the control strip itself.

2. Select a command icon to add from the Command list.

3. Click the desired icon now and drag it from the Customize dialog box onto one of the
control strips.

4. The button’s icon appears on the strip. You can rearrange the order of tools on the strip
—or add space between tools—by clicking a tool and dragging it to a new position. You
can remove a tool from the control strip by clicking it and dragging it off the control strip.

5. Click Close when you're satisfied with the layout.

Customizing keyboard mappings

Use this command to change a keyboard mapping. A keyboard mapping is a list of keystrokes that
result in certain commands being executed. For example, TextMaker’s default keyboard mapping
defines, among many other commands, Ctrl+C as Edit > Copy and Ctrl+X as Edit > Cut. The alter-
native WordStar-like keyboard mapping defines Ctrl+C as Page Down and Ctrl+X as Arrow
Down.

You can switch between existing keyboard mappings, modify them and even create new key-
board mappings from scratch.

There are several options in the keyboard mappings dialog:
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» New Lets you create a new keyboard layout.

» Delete Will remove a mapping from the list.

» Rename Gives an existing mapping a new name.

» Edit Lets you modify an existing mapping.

» Reset Restores the default settings in a mapping.

When you create or modify keyboard mapping, the Edit Keyboard Mapping dialog box will ap-
pear. In this dialog, you can see the Group and Commands for which you can define a keyboard
shortcut.

Choose the command you want to define a shortcut for and go to the Shortcut section. Press
the key(s) you want to assign to this command and click Add. The new shortcut will be added to
the Current shortcuts list. The Remove button deletes the shortcut from the list.

PREFERENCES

Use Extras > Preferences to configure TextMaker’s basic settings. All settings you make here are
global for all documents, whereas settings in File > Properties are document-specific.

You can change numerous settings, display options, and user data. Choosing this command
displays the Preferences dialog box that is comprised of five tabs: View, General, Look & Feel,
Language, and Files.

Preferences: The View tab

Preferences
Yiew | General I LookéFeel I Language I Files I

- Document window
[V i able quidelines I¥ Horizontal rler
¥ Erame guidelines ¥ Mertical ner
¥ OLE object guidelines ¥ Page borders
¥ Guides

(-Show unprintable characters
I~ Paragraph breaks ™ Spaces
[~ Tabs a0

Scrolbars
¥ Showtolips | W Horizontal ¥ Vertical
Carca

Options under the View tab are used to turn on or off the display of certain TextMaker features.

Table Guidelines,

OLE Object Guidelines,

Frame Guidelines Click these options if you want table, OLE object, and frame guidelines to be
displayed. These guidelines are displayed as gray marker lines around tables
and frames, giving you an indication of the size of the object.

Page Borders Click this option to turn on or off the display of page borders.

Guides Click this option to turn on or off the display of non-printing guides. Guides
are lines that help you position objects on pages (see Object > Guides &
Grids) but do not appear in print.

Horizontal Ruler
Vertical Ruler Turn on these options if you want the horizontal and vertical rulers to be dis-
played.

Show unprintable Characters
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Show tooltips

Scrollbars

Click the option Paragraph Breaks if you want paragraph breaks displayed with
a ¥ character. This is useful to help you distinguish paragraphs from normal
line endings, for example. Also you can check Tabs and Spaces to be displayed.
If you want all unprintable Characters shown, select the All option.

Click this option to turn on or off tooltips. Tooltips are small windows that
show helpful information when you click on a control strip button but then
hesitate for a moment before releasing the mouse button.

In this section, you can turn on or off the horizontal and vertical scrollbars for
the document window.

Preferences: The General tab

Wiew I General | Look&Feel I Language: I Files I
I+ {Use rew windows by defaul User (Home), |
¥ Beepon ermors User [Business)...

™ Individual profile for each user

Smart quates: Auta hd
Marimum number of undo steps:| 43 E

Cancel

Options under the General tab are used to control many TextMaker default settings. Default set-
tings determine how TextMaker appears when you first start it up, as well as other characteristics:

Use New Windows by default

Beep on Errors

Click this option if you want the New Window check box to be checked when
you choose File > Open or File > New.

If this option is active, TextMaker will beep before showing an error message.
If you don’t want an acoustic warning, then turn this option off.

Individual profile for each user

Smart quotes

TextMaker saves all user-related settings (program settings, user dictionaries
for spell checking, SmartText definitions, keyboard mappings, and control
strips layout) in a user profile. This option indicates whether all users share
the same settings profile or if every user has a profile of his or her own.

When typing quotes (') or double quotes ("), you can have TextMaker turn
them into aesthetically more pleasing typographical quotes “like this”. This list
lets you define the quotes style you prefer:

» ‘English’ “quotes”

» ‘German’ ,quotes”
» French> «quotes»

» >Swiss< »quotes«

» Auto quotes

The most useful setting, is “Auto”. In this case, TextMaker finds out the lan-
guage the text is written in (by looking up Format > Character > Language)
and switches to the appropriate quotes style.

Maximum number of undo steps
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You can define here how many of your actions should be undoable. The high-
er the value, the more memory is consumed to store old versions of your text.

User (Home) Click this button to open another dialog where you can enter your personal
information such as name, address, phone and fax numbers, e-mail address,
etc. TextMaker uses this information for merge fields (see the Field command
under the Insert menu).

For example, you could create a document template that, whenever you open
it, automatically pulls your name and address from this dialog box. Several
document templates shipped with TextMaker already use information from
this dialog box.

User (business) This is similar to User (Home), however, it lets you specify a second address,
for example your business address.

Preferences: The Look & Feel tab

Preferences
Wiew | General | LooksFes! | Languags | Fies |

rUser interface

Dialog style: |
¥ Show Fants in fant list
¥ Useicons in menus

¥ Use new file dislogs
Language: [ Engish [UK] -
[ Smoath edges of screen fonts

In documents: Control panel settings 'I

In dislogs: Ott i

Carcel

Options under the Look & Feel tab are used to control the dialog style, user interface language and
other display options.

Dialog Style Choose the dialog style, or “skin” you want TextMaker to display. Available
options include Windows 3.1, Windows 95, OS/2, Pocket PC, and others.

Show fonts in fonts list
All font lists contain the names of the installed fonts. If you prefer to see the
names displayed in their actual style, check this option.

Use icons in menu This option turns on the display of icons in TextMaker’s menus.

Use new file dialogs
Decides whether TextMaker shows its own file dialogs or Windows Explorer-
type file dialogs.

Language Choose the user interface language of your choice.

Smooth edges in screen fonts
Depending on your operating system, TextMaker supports smoothing of
screen fonts through anti-aliasing and/or ClearType. With these settings, you
can specify your preferred smoothing technology, or you can turn off smooth-
ing altogether.
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Preferences: The Language tab

Wiew I General I Look&Feel I Language: | Files I

Default language;
English [US]

Autornatic Spellcheck

= Disabled

" Check speling as you type
™ Beep on enors

" Background spel-checking
¥ Underling tpas in red

¥ Underline "old" German speling in blue

[Mew German spelling only] Options. I

¥ Evpand glossam entries

Cancel

The Language tab is where you choose the default language for spell-checking and hyphenation. It
also allows you to specify options for on-the-fly spell checking.

Default language

Spell Checker

Select your default language here. This setting is used for spell-checking and
hyphenating text that has no specific language setting (i.e., in Format > Char-
acter > Language, the language is set to Default).

Here you can determine the way in which the spell checker works. Click Dis-
abled to turn spell checking off.

For on-the-fly checking, click Check Spelling As You Type. Every time you type
a word and hit the space or Return key, TextMaker checks the spelling and
pops up a dialog box if it does not recognize the word. You can also specify
that you want an acoustic signal to go with that.

The most advanced, and preferred, spell checking method is Background spell
checking. TextMaker checks your document while you are typing, and under-
lines all unknown words in red. Simply right-click on such a word to correct it
or add it to the user dictionary.

Expand SmartText Entries

The SmartText feature (described in the Insert Menu chapter) lets you define
“shorthand”, or abbreviations. You could set up “br” to mean “Best regards”.
When Expand SmartText Entries is checked and you type “br” and a space, Re-
turn, or a punctuation mark, TextMaker automatically expands this to “Best
regards.”

Preferences: The Files tab

Pieferences

Yiew I General I LookéFeel I Language I Files I

Template folder: | R

Default file farmat: Texthaker =

Saving
™ Eastsave

¥ Create backup copies

I~ Ask for summary information when saving

7 Autosave document every [5[2] minutes

Recently used fles: 4

Cancel

Options under the Files tab are used to control settings related to TextMaker’s file handling.
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Template folder  This is the directory where your document templates are stored. You can
change the folder by editing this field.

Default File Format
Lets you choose which format you prefer for saving your documents in. You
can choose between TextMaker’s own .TMD format and Microsoft Word’s
.DOC file format. .TMD is much more compact and faster to read and write,
but if you work with Microsoft Word on one machine and with TextMaker on
another, it might make sense to keep everything in .DOC format.

Saving Fast Save is an option which can accelerate file saving by only writing changes
to the file. Over time, this increases the file size because old text is never re-
claimed from the file.

Check Create Backup Copies if you want to have TextMaker create .BAK files of
the last-saved file when saving documents.

Check Ask for summary information when saving to be prompted to enter a few
facts about the new document.

Autosave document every indicates the time between auto-save intervals. Auto-
save is a nifty feature designed to keep your documents even in the case of
system crashes or power failures: TextMaker saves your document in regular
intervals to temporary files. If you restart TextMaker after a crash, it finds out
about pending auto-save files and asks you whether you want to restore your
work from these.

Recently used files Set up the number of entries under the File menu for the recently-used files
list.
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weice | K@yboard Shortcuts

TextMaker provides quick access to many of the commands and dialog boxes available through
the menus. Wherever possible, TextMaker conforms to standard shortcut keys as set forth in the
Windows Guidelines.

With Keyboard Shortcuts you can access commonly used functions and dialogs, easily move
through the document, select and format text.

FILE SHORTCUTS

The following shortcuts are used when working with files:

Ctrl+N
Ctrl+O
Ctrl+S
Ctrl+W
Ctrl+P
Ctrl+S

Ctrl+Q

Create a new document
Open an existing document
Save the current document
Close the current document
Print the document

Save the current document

Exit TextMaker

WINDOWS SHORTCUTS

The following shortcuts help manage the windows within TextMaker:

F1

Ctrl+F4
Alt+F4
Ctrl+F5
Alt+F5
Ctrl+Fé6
Sh+Ctrl+F6
Ctrl+F9
Alt+F9
Ctrl+F10

Alt+F10

TextMaker 2002 —

Bring up the Windows Help facility

Closes the current document window

Exits TextMaker

Restores the current document window to normal size
Restores the main TextMaker window to normal size
Cycles to the next open document window

Cycles to the previous open document window
Minimizes the current document window

Maximizes the current document window

Minimizes the main TextMaker window

Maximizes the main TextMaker window
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CLIPBOARD SHORTCUTS

The following shortcuts move selections between documents and the clipboard.

Ctrl+X
Sh+Del
Ctrl+C
Ctrl+Ins
Ctrl+V

Sh+Ins

Cut the selected text or object to the clipboard

Cut the selected text or object to the clipboard
Copy the selected text or object to the clipboard
Copy the selected text or object to the clipboard
Paste the contents of the clipboard to the document

Paste the contents of the clipboard to the document

CURSOR MOVEMENT SHORTCUTS

The following shortcuts are used when selecting text:

Left arrow
Right arrow

Ctrl+Left arrow

Move to the previous character
Move to the next character

Move to the previous word

Ctrl+Right arrow Move to the next word

Up arrow
Down arrow

Ctrl+Up arrow

Move to the previous line
Move to the next line

Move to the previous paragraph

Ctrl+Down arrowMove to the next paragraph

Home

End
Ctrl+Home
Ctrl+End
PgUp
PgDn
Ctrl+PgUp
Ctrl+PgDn

Tab

Move to the beginning of line

Move to the end of line

Move to the beginning of document
Move to the end of document

Move to the previous window

Move to the next window

Move to the beginning of current window
Move to the end of current window

Move to next cell (tables only)

TEXT SELECTION SHORTCUTS

The following shortcuts are used when selecting text:

Sh+Left arrow
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Select the previous character
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Sh+Right arrow
Sh+Ctrl+Left
Sh+Ctrl+Right
Sh+Up arrow

Sh+Down arrow
Sh+Ctrl+Up
Sh+Ctrl+Down
Sh+Home
Sh+End
Sh+Ctrl+Home
Sh+Ctrl+End
Sh+PgUp
Sh+PgDn
Sh+Ctrl+PgUp

Sh+Ctrl+PgDn

Select the next character
Select the previous word
Select the next word

Select the previous line

Select the next line

Select the previous paragraph
Select the next paragraph
Select to the beginning of line
Select to the end of line
Select to the beginning of document
Select to the end of document
Select up one window

Select down one window

Select to the top of current window

Select to the bottom of current window

TEXT EDITING SHORTCUTS

The following shortcuts perform standard text editing commands:

Ctrl+Z

Ctrl+Y
Alt+BkSp
BkSp

Del

Sh+Enter
Enter
Ctrl+Sh+Enter

Sh+Enter
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Undo the last command or action

Redo the last undo

Undo the last command or action

Delete the previous character or selection

Delete the next character or selection

Inserts a line break within the current paragraph

Inserts a paragraph break
Inserts a column break

Inserts a page break
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CHARACTER FORMATTING SHORTCUTS

The following shortcuts perform text formatting commands:

Ctrl+B

Ctrl+I
Ctrl+U
Ctrl+A
Ctrl+G
Ctrl+D

Ctrl+]

Apply bold to the selected text

Apply italics to the selected text

Apply continuous underline to the selected text

Access the font drop down on the control strip

Access the point size drop down on the control strip
Access the paragraph style drop down on the control strip

Access the font color drop down on the control strip

PARAGRAPH FORMATTING SHORTCUTS

The following shortcuts perform text formatting commands:

Ctrl+L

Ctrl+R

Ctrl+E

Ctrl+B

Ctrl+1

Ctrl+2

Ctrl+5

Ctrl+T

TextMaker 2002 —

Left align the selected paragraphs

Right align the selected paragraphs
Center align the selected paragraphs
Justify the selected paragraphs

Set line spacing to single spacing

Set line spacing to double spacing

Set line spacing to one and a half spacing

Set and edit tabs
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COMMAND SHORTCUTS

The following shortcuts are used when working with files:

Ctrl+F
Ctrl+H
F3

F5

F8

F9

Search for specific text
Search and replace text
Repeat last search or replace
Go to

Evaluate

Recalculate
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